Bug 1624353 - Xfce: Sorry, your Window Manager does not support compositing
Summary: Xfce: Sorry, your Window Manager does not support compositing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfwm4
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1624354 (view as bug list)
Depends On:
Blocks: F29BetaFreezeException 1624354
TreeView+ depends on / blocked
 
Reported: 2018-08-31 10:13 UTC by Miro Hrončok
Modified: 2018-09-12 02:54 UTC (History)
6 users (show)

Fixed In Version: xfwm4-4.13.1-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 02:54:37 UTC


Attachments (Terms of Use)
Xfwm4 with compositor enabled (2.56 MB, image/gif)
2018-09-02 13:00 UTC, Mukundan Ragavan
no flags Details


Links
System ID Priority Status Summary Last Updated
Xfce 14652 None None None 2018-09-02 13:08:32 UTC
Red Hat Bugzilla 1618914 None None None Never

Internal Links: 1618914

Description Miro Hrončok 2018-08-31 10:13:42 UTC
After upgrading to Fedora 29 my Window Manager does not support compositing and my Xfce terminal no longer has Opacity settings.

    Sorry, your Window Manager does not support compositing:
    Opacity setting is not available.

This is xfce4-terminal-0.8.7.4-20.fc29.x86_64.

I think that this is not a bug in the terminal but rather xfwm, but I have no idea how to debug this.

Comment 1 Kevin Fenzi 2018-08-31 16:01:23 UTC
This is due to nonamedotc disabling composite at build time to work around a X bug in rawhide. 

So, we should see if that is still happening and undo that change asap... we probibly need a Freeze Exception if we want it to be fixed by beta.

Comment 2 Miro Hrončok 2018-08-31 16:45:23 UTC
That would be https://src.fedoraproject.org/rpms/xfwm4/c/99d64b52e86f325685c5a43bd214f703200b506d?branch=master

There is no bug number reference there.

Comment 3 Miro Hrončok 2018-08-31 16:48:04 UTC
scratchbuilding with that reverted to see what happens:

https://koji.fedoraproject.org/koji/taskinfo?taskID=29400182
https://koji.fedoraproject.org/koji/taskinfo?taskID=29400189

Comment 4 Miro Hrončok 2018-08-31 17:05:35 UTC
Everything blinks a lot.

Comment 5 Raphael Groner 2018-08-31 17:32:56 UTC
(In reply to Kevin Fenzi from comment #1)
> This is due to nonamedotc disabling composite at build time to work around a
> X bug in rawhide. 

Wayland?

Comment 6 Kevin Fenzi 2018-08-31 17:41:21 UTC
(In reply to Raphael Groner from comment #5)
>
> Wayland?

Nope. Xfce has no wayland support at all. 

https://bugzilla.redhat.com/show_bug.cgi?id=1618914 is the bug where compostiing was disabled.

Comment 7 Mukundan Ragavan 2018-08-31 23:17:37 UTC
yeah, this is supposed to have been fixed with xorg-server 1.20.1 which we have in rawhide and F29 but something is still off and I have not had the chance to take a look yet.

I will take a look at this soon.


(In reply to Miro Hrončok from comment #4)
> Everything blinks a lot.

Can you explain?

Do you get a working desktop with the compositor enabled?

Comment 8 Miro Hrončok 2018-09-01 08:32:14 UTC
> > Everything blinks a lot.
> 
> Can you explain?
> 
> Do you get a working desktop with the compositor enabled?

Yes. The desktop works, but there are rectangular areas of windows, panel, etc, that are blinking - one moment they are visible and the second moment they are transparent. The frequency of blinking is random, but it in seconds.

I'll try to record this, if it helps.

Comment 9 Miro Hrončok 2018-09-01 10:18:33 UTC
> I'll try to record this, if it helps.

Too large for bugzilla attachment, so here it is: https://youtu.be/hk0TsYLbZjk

Comment 10 Mukundan Ragavan 2018-09-01 13:06:04 UTC
*** Bug 1624354 has been marked as a duplicate of this bug. ***

Comment 11 Mukundan Ragavan 2018-09-01 18:55:45 UTC
That's weird! I am not seeing it here on my test system. I will attach a recording but we should file this upstream.

Can you give me some system specs? I will file this upstream with our system configs.

Comment 12 Miro Hrončok 2018-09-01 22:47:28 UTC
I have a Red Hat issued Lenovo X1 carbon 3rd gen. I've recently updated from F28 to F29.

What kind of specs do you want (output of what commands should I send)?

Comment 13 Raphael Groner 2018-09-02 05:06:04 UTC
(In reply to Miro Hrončok from comment #12)
> I have a Red Hat issued Lenovo X1 carbon 3rd gen. I've recently updated from
> F28 to F29.
> 
> What kind of specs do you want (output of what commands should I send)?

Graphics card, obviously. Lenovo specs tell Intel HD 620, is this right?

So the flickering did not happen with F28 before the major update to F28? Can you try with Plasma maybe to see if it's really Xfce to blame?

Comment 14 Raphael Groner 2018-09-02 05:08:32 UTC
Err, found the wrong generation. 3rd should have HD Graphics 5500 inside.
http://thinkwiki.de/X1_Carbon_%283rd_Gen%29

Comment 15 Paul DeStefano 2018-09-02 06:24:37 UTC
From what I can tell, this is a direct and deliberate result of the temporary workaround for bug 1618914.  This is essentially a duplicate.

Comment 16 Mukundan Ragavan 2018-09-02 13:00:05 UTC
Created attachment 1480326 [details]
Xfwm4 with compositor enabled

I do not see the flickering in my laptop which is using a nvidia (see attachment). That said, I am filing an upstream bug now.


(In reply to Paul DeStefano from comment #15)
> From what I can tell, this is a direct and deliberate result of the
> temporary workaround for bug 1618914.  This is essentially a duplicate.

Paul, Miro has re-enabled compositor.

Comment 17 Miro Hrončok 2018-09-03 08:21:27 UTC
flickering fixed in: https://src.fedoraproject.org/rpms/xfwm4/pull-request/1

However upstream says: "if you get flickering, that means you're using GLX and not Xpresent, whereas Xpresent is the default. Can you check your build?"

So let's see what comes out of that.

Comment 18 Miro Hrončok 2018-09-03 10:07:18 UTC
Also added libXpresent into that PR. Still no flickering.

Comment 19 Mukundan Ragavan 2018-09-03 13:42:32 UTC
Merged. Build should be up shortly.

I think we will get freeze exception since the fix is on its way.

Comment 20 Mukundan Ragavan 2018-09-03 18:03:28 UTC
"real" builds are now done. Patch is applied and we now have xpresent support. Now, we need freeze exception to get this into beta.

Comment 21 Miro Hrončok 2018-09-03 19:32:52 UTC
We need f29 update in bodhi.

Comment 22 Geoffrey Marr 2018-09-04 20:58:29 UTC
Discussed during the 2018-09-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as 
this bug affects live and ARM disk image media and thus cannot be fixed fully with an update. The change here seems well planned and in accordance with upstream's intentions, and can be reverted if it turns out to cause problems.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-04/f29-blocker-review.2018-09-04-16.01.txt

Comment 23 Fedora Update System 2018-09-04 22:38:55 UTC
xfwm4-4.13.1-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dbb9beece8

Comment 24 Fedora Update System 2018-09-05 21:27:36 UTC
xfwm4-4.13.1-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-dbb9beece8

Comment 25 Fedora Update System 2018-09-12 02:54:37 UTC
xfwm4-4.13.1-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.