Bug 163440 - Package version is ancient and requires an update.
Package version is ancient and requires an update.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wxPython (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
:
: 185903 (view as bug list)
Depends On: 154618
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-16 14:16 EDT by Chris Spencer
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: wxPython-2.6.3.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 22:52:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Spencer 2005-07-16 14:16:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The current version of wxPython available in the repositories is                       2.4.2.4-7. This was released nearly 2 years ago, in mid 2003, and is considerably out-of-date. The current version is 2.6. Could someone please add this most recent version to the repositories? Also, wxPython-demo is an invalable aid in learning wx, and is not in the repositories at all. Could this also be added (preferably wxPython-demo-2.6)?

I apologize if this is not the right forum for suggestions or requests, but I was unable to find any other outlet.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to use wxPython
2.
3.
  

Additional info:
Comment 1 Matthew Miller 2005-11-30 16:07:45 EST
Panu -- mind if I take this one over?

In-progress updated packages at http://mattdm.org/misc/fedoraextras/
Comment 2 Panu Matilainen 2005-12-01 03:03:50 EST
It's all yours :)
Comment 3 Matthew Miller 2005-12-01 07:33:14 EST
Thanks, man. :)
Comment 4 Matthew Miller 2006-02-07 10:51:06 EST
Despite appearances, I'm actually working on this. The current wxPython upstream
package (2.6.2.1) has some Issues, wherein it seems to actually only work with a
cvs snapshot of wxWidgets, not with the released 2.6.2.
Comment 5 Matthew Miller 2006-02-07 17:06:29 EST
So, from the wxPython author, the problems noted above are a mistake. And:

> BTW, if everybody stays on schedule and there aren't any critical
> breakages, then there should be a 2.6.3(.0) release in a couple weeks
> for both wxWidgets and wxPython.

It's highly tempting, now that I've waited this long, to wait for that too,
since at that point it should Just Work.
Comment 6 Matthew Miller 2006-03-14 21:28:02 EST
Okay, so, it's been a little longer than I'd hoped, but wxGTK 2.6.3 and wxPython
2.6.3.0 should be out any day now....
Comment 7 Douglas Kosovic 2006-03-15 22:06:41 EST
If the new wxPython spec is going to be based on the one at 
http://mattdm.org/misc/fedoraextras/ , could the wxPython include dir with the 
header files and swig .i files not be deleted, or be put in a wxPython-devel 
package? As the swig based wxMozilla ( http://wxmozilla.sourceforge.net/ ) 
python module can't be built without the header files.

Thanks,
Doug
Comment 8 Matthew Miller 2006-03-15 22:08:30 EST
I have a somewhat updated version of it, but I had still removed those things. I
can make a wxPython-devel package -- I'll just try to make it clear that most
people developing with wxPython don't actually need that. Thanks for the comment.
Comment 9 Matthew Miller 2006-03-19 19:12:20 EST
*** Bug 185903 has been marked as a duplicate of this bug. ***
Comment 10 Alex Lancaster 2006-03-30 02:25:28 EST
2.6.3.0 is out, any chance for this long awaited package update? ;-)

http://wxpython.org/recentchanges.php
Comment 11 Matthew Miller 2006-03-30 06:49:09 EST
My update plan was stymied by the broken buildsystem. :) wxGTK is building in
devel right now; after that comes wxPython (later today; I've got a meeting all
morning). Then after that goes well I'll do FC5 and FC4 successively over the
next few days.
Comment 12 Matthew Miller 2006-03-31 08:16:04 EST
Building now in devel.... 
Comment 13 Alex Lancaster 2006-04-04 15:11:55 EDT
(In reply to comment #12)
> Building now in devel.... 

Looks like building wxPython on devel has succeeded, and wxGTK2 is now 2.6.3 in
FC-5 too, so perhaps we could have an FC-5 (and even, dare I say it an FC-4)
build. ;-)
Comment 14 Douglas Kosovic 2006-04-05 03:40:11 EDT
The x86-64 built wxPython-2.6.3.0-4 doesn't work, wxPython applications 
complain about not being able to find the module.

To get it working on x86-64, I added the following at the end of the %install 
section of the spec file:

%if "%{_lib}" == "lib64"
mv $RPM_BUILD_ROOT/%{python_sitelib}/* $RPM_BUILD_ROOT/%{python_sitearch}
rm -rf $RPM_BUILD_ROOT/%{python_sitelib}
%endif

And changed the location of wx.pth and wxversion.py* in the %file section to 
be:

%{python_sitearch}/wx.pth
%{python_sitearch}/wxversion.py*


Doug
Comment 15 Matthew Miller 2006-04-05 06:29:09 EDT
Hmmm. It's odd that that's getting installed in the wrong place in the first place.
Comment 16 Matthew Miller 2006-04-05 10:37:35 EDT
I know I'm always full of excuses... I'll try to get this done before Fudcon....
Comment 17 Matthew Miller 2006-04-06 22:37:51 EDT
*** Bug 188215 has been marked as a duplicate of this bug. ***
Comment 18 Alex Lancaster 2006-04-13 12:37:53 EDT
Sorry to ping again, but erm, Fudcon's over now ;-) 
Comment 19 Matthew Miller 2006-04-13 13:08:13 EDT
No no, fair enough. :)

I'm working on it right now.
Comment 20 Matthew Miller 2006-04-13 17:11:45 EDT
Building in Fedora Extras devel. Since it's currently broken and has been for so
long, I'll build for FC5 as soon as I hear positive feedback or on Monday,
whichever comes first.
Comment 21 Alex Lancaster 2006-04-14 10:59:20 EDT
(In reply to comment #20)
> Building in Fedora Extras devel. Since it's currently broken and has been for so
> long, I'll build for FC5 as soon as I hear positive feedback or on Monday,
> whichever comes first.

And then FC-4 on Tuesday? ;-)
Comment 22 Douglas Kosovic 2006-04-16 03:17:14 EDT
Builds and runs fine on x86-64 FC5

On FC4 wxGTK-2.6.3-2.6.3.2.0 doesn't build, the following line in wxGTK.spec:
   BuildRequires:  mesa-libGL-devel, mesa-libGLU-devel
needs to be changed to:
   BuildRequires:  libGL-devel, libGLU-devel

wxPython.spec already has that mod and builds fine on FC4.
Comment 23 Matthew Miller 2006-04-18 22:52:51 EDT
Building in FC4 now. If there are severe problems with that build, please reopen
this. For other issues, please file new bugs. Thanks for your patience on this!
Comment 24 Joel Schaerer 2006-04-19 10:18:32 EDT
How about wxPythonGTK2 ? You marked my bug (188215) as a duplicate of this one,
but you didn't do anything about wxPythonGTK2. As a result, I still have the
same problem.
Comment 25 Matthew Miller 2006-04-19 10:29:14 EDT
The new wxPython package obsoletes wxPythonGTK2. If you do "yum upgrade",
wxPython will replace wxPythonGTK2. (This conforms to the normal Fedora
package-naming guidelines -- the upstream package is just "wxPython".)

I see from your bug report that you're using FC5, so the new package should be
there. If this _doesn't_ work, let me know right away. Thanks.
Comment 26 Alex Lancaster 2006-04-19 10:35:10 EDT
(In reply to comment #24)
> How about wxPythonGTK2 ? You marked my bug (188215) as a duplicate of this one,
> but you didn't do anything about wxPythonGTK2. As a result, I still have the
> same problem.

wxPythonGTK2 should be replaced by compat-wxPythonGTK2 but it hasn't yet been
built on devel or FC-5.  This is probably by the Package Review isn't closed:
bug #175500.
Comment 27 Matthew Miller 2006-04-19 10:36:40 EDT
*nod*

And that should only be necessary if you need wxPython 2.4.x.

Note You need to log in before you can comment on or make changes to this bug.