Bug 1634964 - Ceph MGR regression in DaemonPerfCounters::update [NEEDINFO]
Summary: Ceph MGR regression in DaemonPerfCounters::update
Keywords:
Status: CLOSED DUPLICATE of bug 1670781
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: z1
: 3.2
Assignee: Kefu Chai
QA Contact: ceph-qe-bugs
Bara Ancincova
URL:
Whiteboard:
: 1635012 (view as bug list)
Depends On:
Blocks: 1629656 1584264
TreeView+ depends on / blocked
 
Reported: 2018-10-01 19:45 UTC by Vikhyat Umrao
Modified: 2019-02-11 18:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Documented with BZ#1670781
Clone Of:
Environment:
Last Closed: 2019-01-30 15:41:41 UTC
jbrier: needinfo? (asriram)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 21197 None None None 2018-10-03 22:54:28 UTC
Ceph Project Bug Tracker 36244 None None None 2019-01-17 18:14:45 UTC

Description Vikhyat Umrao 2018-10-01 19:45:50 UTC
Description of problem:
Ceph MGR regression in DaemonPerfCounters::update

It was claimed to be fixed in upstream trackers:
https://tracker.ceph.com/issues/21197
This says 12.2.2 - https://tracker.ceph.com/issues/21656

but it is not fixed.


ceph version 12.2.5-42.el7cp (82d52d7efa6edec70f6a0fc306f40b89265535fb) luminous (stable)
 1: (()+0x3f19e1) [0x7f6ca65029e1]
 2: (()+0xf370) [0x7f6ca3e2e370]
 3: (gsignal()+0x37) [0x7f6ca2e4a1d7]
 4: (abort()+0x148) [0x7f6ca2e4b8c8]
 5: (__gnu_cxx::__verbose_terminate_handler()+0x165) [0x7f6ca374eab5]
 6: (()+0x5ea26) [0x7f6ca374ca26]
 7: (()+0x5ea53) [0x7f6ca374ca53]
 8: (()+0x5ec73) [0x7f6ca374cc73]
 9: (std::__throw_out_of_range(char const*)+0x77) [0x7f6ca37a1a87]
 10: (DaemonPerfCounters::update(MMgrReport*)+0xbbc) [0x7f6ca63b23ec]
 11: (DaemonServer::handle_report(MMgrReport*)+0x243) [0x7f6ca63ba3e3]
 12: (DaemonServer::ms_dispatch(Message*)+0x47) [0x7f6ca63c63f7]
 13: (DispatchQueue::entry()+0x792) [0x7f6ca67fca72]
 14: (DispatchQueue::DispatchThread::entry()+0xd) [0x7f6ca65eb04d]
 15: (()+0x7dc5) [0x7f6ca3e26dc5]
 16: (clone()+0x6d) [0x7f6ca2f0c76d]
 NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 John Brier 2018-10-01 21:00:49 UTC
*** Bug 1635012 has been marked as a duplicate of this bug. ***

Comment 7 John Brier 2018-10-03 18:10:42 UTC
This is documented as a known issue in the release notes now:

https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3.1/html-single/release_notes/#rados_3

Comment 8 John Brier 2018-10-03 18:12:09 UTC
Doc Text update: Changed "may" to "can" per IBM Style Guide. This will be pulled in the next time the Release Notes are updated.

Comment 10 Josh Durgin 2019-01-30 15:41:41 UTC

*** This bug has been marked as a duplicate of bug 1670781 ***


Note You need to log in before you can comment on or make changes to this bug.