Bug 1670781 - mgr: fix crash due to multiple sessions from daemons with same name
Summary: mgr: fix crash due to multiple sessions from daemons with same name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: z1
: 3.2
Assignee: Boris Ranto
QA Contact: Vasishta
Bara Ancincova
URL:
Whiteboard:
: 1634964 (view as bug list)
Depends On:
Blocks: 1629656 1584264
TreeView+ depends on / blocked
 
Reported: 2019-01-30 11:02 UTC by Boris Ranto
Modified: 2019-03-07 15:51 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-12.2.8-64.el7cp Ubuntu: ceph_12.2.8-49redhat1
Doc Type: Bug Fix
Doc Text:
.Ceph Manager no longer crashes when two or more Ceph Object Gateway daemons use the same name Previously, when two or more Ceph Object Gateway daemons used the same name in a cluster, Ceph Manager terminated unexpectedly. The underlying source code has been modified, and Ceph Manager no longer crashes in the described scenario.
Clone Of:
Environment:
Last Closed: 2019-03-07 15:51:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0475 None None None 2019-03-07 15:51:38 UTC

Description Boris Ranto 2019-01-30 11:02:32 UTC
Description of problem:
We should back-port https://github.com/ceph/ceph/pull/25534

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
This is staged for 12.2.11 but we should back-port it for the next 3.2 z-stream release. The ceph-mgr daemon crashes randomly with multiple rgw daemons of same name.

Expected results:
No crash.

Additional info:

Comment 1 Josh Durgin 2019-01-30 15:41:28 UTC
Thanks for taking care of this Boris!

Comment 2 Josh Durgin 2019-01-30 15:41:41 UTC
*** Bug 1634964 has been marked as a duplicate of this bug. ***

Comment 3 Boris Ranto 2019-01-30 19:59:27 UTC
No problem, I knew we had another bugzilla downstream for this but I just couldn't find it, thanks for linking it!

Comment 11 Vasishta 2019-02-18 14:09:54 UTC
Followed steps mentioned in Comment 7 , working fine with ceph-12.2.8-77
Moving to VERIFIED state.

Regards,
Vasishta Shastry
QE, Ceph

Comment 13 errata-xmlrpc 2019-03-07 15:51:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0475


Note You need to log in before you can comment on or make changes to this bug.