Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1646150 - mesa 18.2.3 update breaks accelerated compositing in WebKitGTK+, many webpages fail to display
mesa 18.2.3 update breaks accelerated compositing in WebKitGTK+, many webpage...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
29
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 1646617 1646837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-05 04:19 EST by Milan Zink
Modified: 2018-11-07 18:29 EST (History)
27 users (show)

See Also:
Fixed In Version: mesa-18.2.4-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-11-06 21:42:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Empty pages in Epiphany / Gnome-Web (23.97 KB, image/png)
2018-11-05 04:19 EST, Milan Zink
no flags Details

  None (edit)
Description Milan Zink 2018-11-05 04:19:30 EST
Created attachment 1501704 [details]
Empty pages in Epiphany / Gnome-Web

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open gmail.com and try to sign in
2. Same issues on other pages like https://root.cz

Actual results:
Empty white page
Cannot sign-in to online accounts (Google)


Expected results:
Visible content, able to browse pages, Normal sign-in to online accounts

Additional info:
Screenshot attached
rpm -qa | egrep 'epiphany|gnome' | sort
chrome-gnome-shell-10.1-3.fc29.x86_64
desktop-backgrounds-gnome-29.0.0-1.fc29.noarch
epiphany-3.30.2-1.fc29.x86_64
epiphany-runtime-3.30.2-1.fc29.x86_64
f27-backgrounds-gnome-27.0.1-4.fc29.noarch
f28-backgrounds-gnome-28.1.5-1.fc29.noarch
f29-backgrounds-gnome-29.1.3-1.fc29.noarch
fros-gnome-1.1-17.fc29.noarch
gnome-abrt-1.2.6-8.fc29.x86_64
gnome-autoar-0.2.3-2.fc29.x86_64
gnome-backgrounds-3.30.0-1.fc29.noarch
gnome-bluetooth-3.28.2-1.fc29.x86_64
gnome-bluetooth-libs-3.28.2-1.fc29.x86_64
gnome-boxes-3.30.2-1.fc29.x86_64
gnome-calculator-3.30.1-1.fc29.x86_64
gnome-calendar-3.30.0-1.fc29.x86_64
gnome-characters-3.30.0-1.fc29.x86_64
gnome-clocks-3.30.1-1.fc29.x86_64
gnome-color-manager-3.30.0-1.fc29.x86_64
gnome-contacts-3.30.1-1.fc29.x86_64
gnome-control-center-3.30.2-1.fc29.x86_64
gnome-control-center-filesystem-3.30.2-1.fc29.noarch
gnome-desktop3-3.30.2-1.fc29.x86_64
gnome-disk-utility-3.30.2-1.fc29.x86_64
gnome-documents-3.30.0-1.fc29.x86_64
gnome-documents-libs-3.30.0-1.fc29.x86_64
gnome-font-viewer-3.30.0-1.fc29.x86_64
gnome-getting-started-docs-3.30.0-1.fc29.noarch
gnome-getting-started-docs-cs-3.30.0-1.fc29.noarch
gnome-gmail-2.4.1-6.fc29.noarch
gnome-icon-theme-3.12.0-10.fc29.noarch
gnome-initial-setup-3.30.0-1.fc29.x86_64
gnome-keyring-3.28.2-2.fc29.x86_64
gnome-keyring-pam-3.28.2-2.fc29.x86_64
gnome-logs-3.30.0-1.fc29.x86_64
gnome-maps-3.30.2-1.fc29.x86_64
gnome-menus-3.13.3-10.fc29.x86_64
gnome-online-accounts-3.30.0-3.fc29.x86_64
gnome-online-miners-3.30.0-1.fc29.x86_64
gnome-photos-3.30.1-1.fc29.x86_64
gnome-screenshot-3.30.0-1.fc29.x86_64
gnome-session-3.30.1-2.fc29.x86_64
gnome-session-wayland-session-3.30.1-2.fc29.x86_64
gnome-session-xsession-3.30.1-2.fc29.x86_64
gnome-settings-daemon-3.30.1.2-1.fc29.x86_64
gnome-shell-3.30.1-2.fc29.x86_64
gnome-shell-extension-common-3.30.1-1.fc29.noarch
gnome-shell-extension-user-theme-3.30.1-1.fc29.noarch
gnome-software-3.30.5-1.fc29.x86_64
gnome-system-monitor-3.30.0-1.fc29.x86_64
gnome-themes-extra-3.28-2.fc29.x86_64
gnome-tweaks-3.30.1-1.fc29.noarch
gnome-usage-3.30.0-1.fc29.x86_64
gnome-user-docs-3.30.2-1.fc29.noarch
gnome-user-share-3.28.0-2.fc29.x86_64
gnome-vfs2-2.24.4-27.fc29.x86_64
gnome-vfs2-common-2.24.4-27.fc29.noarch
gnome-video-effects-0.4.3-4.fc29.noarch
gnome-weather-3.26.0-5.fc29.noarch
libgnomekbd-3.26.0-6.fc29.x86_64
libgnome-keyring-3.12.0-15.fc29.x86_64
NetworkManager-openconnect-gnome-1.2.4-10.fc29.x86_64
NetworkManager-openvpn-gnome-1.8.8-1.fc29.x86_64
NetworkManager-pptp-gnome-1.2.8-1.fc29.x86_64
NetworkManager-ssh-gnome-1.2.7-5.fc29.x86_64
NetworkManager-vpnc-gnome-1.2.6-1.fc29.x86_64
pinentry-gnome3-1.1.0-4.fc29.x86_64
polkit-gnome-0.106-0.3.20170423gita0763a2.fc29.x86_64
qgnomeplatform-0.4-2.fc29.x86_64
Comment 1 Tomas Popela 2018-11-05 04:45:55 EST
Just to be sure, what's your webkit2gtk3 version? Also can you please try running this from terminal?

WEBKIT_DISABLE_COMPOSITING_MODE=1 epiphany

and see if it helps?
Comment 2 Milan Zink 2018-11-05 05:10:46 EST
Hi Tomas,

this workaround works. I see rendered pages now. 

There are warnings in terminal

** (epiphany:19666): WARNING **: 11:00:39.277: Failed to decrypt the BSO payload

** (epiphany:19666): WARNING **: 11:00:39.277: Failed to create synchronizable object from BSO, skipping...

** (epiphany:19666): WARNING **: 11:00:39.277: Incorrect HMAC value

** (epiphany:19666): WARNING **: 11:00:39.277: Failed to decrypt the BSO payload

** (epiphany:19666): WARNING **: 11:00:39.277: Failed to create synchronizable object from BSO, skipping...

** (epiphany:19666): WARNING **: 11:00:39.277: Incorrect HMAC value

but it might be unrelated.
Comment 3 Tomas Popela 2018-11-05 05:40:31 EST
That means that there is a problem with your graphic card drivers. Can you please paste the output of:

lspci | grep VGA

?
Comment 4 Milan Zink 2018-11-05 05:52:43 EST
Sure:)

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)

And some other details:

Getting SMBIOS data from sysfs.
SMBIOS 3.0.0 present.

Handle 0x000C, DMI type 1, 27 bytes
System Information
	Manufacturer: LENOVO
	Product Name: 20HGS22D0W
	Version: ThinkPad T470s
	Serial Number: PC0MUX4K
	UUID: 60d1bccc-3420-11b2-a85c-9708035f28f1
	Wake-up Type: Power Switch
	SKU Number: LENOVO_MT_20HG_BU_Think_FM_ThinkPad T470s
	Family: ThinkPad T470s


# dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 3.0.0 present.

Handle 0x000B, DMI type 0, 24 bytes
BIOS Information
	Vendor: LENOVO
	Version: N1WET51W (1.30 )
	Release Date: 09/14/2018

fwupdmgr get-updates 
No upgrades for 20HGS22D0W System Firmware, current is 0.1.30: 0.1.28=older, 0.1.30=same


Kernel
4.18.16-300.fc29.x86_64

which should be the latest stable - https://koji.fedoraproject.org/koji/buildinfo?buildID=1154877

I can try to boot to some older kernel, or I'm free to test some newer build from koji.

There was also bunch of *firmware* packages update. It might be related. I was using F29 on the same HW since beta release without issues.
Comment 5 Milan Zink 2018-11-05 05:58:19 EST
alsa-firmware-1.0.29-7.fc29.noarch
alsa-tools-firmware-1.1.7-2.fc29.x86_64
atmel-firmware-1.3-19.fc29.noarch
crystalhd-firmware-3.10.0-20.fc29.noarch
ipw2100-firmware-1.3-23.fc29.noarch
ipw2200-firmware-3.1-16.fc29.noarch
iwl1000-firmware-39.31.5.1-88.fc29.noarch
iwl100-firmware-39.31.5.1-88.fc29.noarch
iwl105-firmware-18.168.6.1-88.fc29.noarch
iwl135-firmware-18.168.6.1-88.fc29.noarch
iwl2000-firmware-18.168.6.1-88.fc29.noarch
iwl2030-firmware-18.168.6.1-88.fc29.noarch
iwl3160-firmware-25.30.13.0-88.fc29.noarch
iwl3945-firmware-15.32.2.9-88.fc29.noarch
iwl4965-firmware-228.61.2.24-88.fc29.noarch
iwl5000-firmware-8.83.5.1_1-88.fc29.noarch
iwl5150-firmware-8.24.2.2-88.fc29.noarch
iwl6000-firmware-9.221.4.1-88.fc29.noarch
iwl6000g2a-firmware-18.168.6.1-88.fc29.noarch
iwl6000g2b-firmware-18.168.6.1-88.fc29.noarch
iwl6050-firmware-41.28.5.1-88.fc29.noarch
iwl7260-firmware-25.30.13.0-88.fc29.noarch
libertas-usb8388-firmware-20181008-88.gitc6b6265d.fc29.noarch
linux-firmware-20181008-88.gitc6b6265d.fc29.noarch
zd1211-firmware-1.5-3.fc29.noarch
Comment 6 Milan Zink 2018-11-05 08:58:37 EST
So it seems to be HW/Graphics related. No issues on older HW.

~ > lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
~ > sudo dmidecode -t system
# dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x000C, DMI type 1, 27 bytes
System Information
	Manufacturer: LENOVO
	Product Name: 20ARS19C0B
	Version: ThinkPad T440s
	Serial Number: PC005MYB
	UUID: 9528ec01-53ee-11cb-8770-898d1c401a7d
	Wake-up Type: Power Switch
	SKU Number: LENOVO_MT_20AR_BU_Think_FM_ThinkPad T440s
	Family: ThinkPad T440s
Comment 7 pimou 2018-11-05 10:55:53 EST
Hello, 

Same problem here.

WEBKIT_DISABLE_COMPOSITING_MODE=1 epiphany is working.

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
Comment 8 Michael Catanzaro 2018-11-05 11:03:54 EST
Working with Benjamin Berg, we discovered:

 * This only affects websites that trigger accelerated compositing mode (and thus OpenGL usage)
 * This is a regression caused by mesa 18.2.3
Comment 9 Michael Catanzaro 2018-11-05 11:06:22 EST
(In reply to Michael Catanzaro from comment #8)
>  * This is a regression caused by mesa 18.2.3

Benjamin tested the 18.2.4 update and that is also broken.
Comment 10 Michael Catanzaro 2018-11-05 14:18:15 EST
Igor thinks this is bug #1645400.
Comment 11 Michael Catanzaro 2018-11-05 16:42:22 EST
So roadmap here:

 (1) Wait until tomorrow. (uggg this be emergency!)
 (2) Request buildroot override with fixed GCC package
 (3) Rebuild mesa and submit to bodhi

There's no way to pull the bad update, so users will continue to update to the broken package today and tomorrow....
Comment 12 Fedora Update System 2018-11-05 19:19:45 EST
mesa-18.2.4-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b73380a8e4
Comment 13 Dave Airlie 2018-11-05 19:23:49 EST
I've just rebuilt mesa with store merging turned off for now, the new gcc will end up in the buildroot eventually and we can remove the workaround.
Comment 14 Tomas Popela 2018-11-06 02:03:18 EST
*** Bug 1646837 has been marked as a duplicate of this bug. ***
Comment 15 Milan Zink 2018-11-06 02:55:09 EST
Hi All,

thanks for a really fast fix. I've tested  https://bodhi.fedoraproject.org/updates/FEDORA-2018-b73380a8e4. Works perfect.

Cheers

Milan
Comment 16 Nicolas Dufresne 2018-11-06 11:27:56 EST
*** Bug 1646617 has been marked as a duplicate of this bug. ***
Comment 17 Szőke Károly 2018-11-06 14:05:36 EST
(In reply to pimou from comment #7)
> Hello, 
> 
> Same problem here.
> 
> WEBKIT_DISABLE_COMPOSITING_MODE=1 epiphany is working.
> 
> lspci | grep VGA
> 00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen
> Core Processor Integrated Graphics Controller (rev 06)

This workaround worked in gnome-control-center's online accounts (google):
WEBKIT_DISABLE_COMPOSITING_MODE=1 gnome-control-center
Comment 18 Fedora Update System 2018-11-06 21:42:25 EST
mesa-18.2.4-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Hin-Tak Leung 2018-11-07 18:24:59 EST
I am glad it is fixed. I have a little C# based webkit2gtk4 app I wrote for web browsing. Curiously it broke for google.com (and a few other places) but not bugzilla.redhat after upgrading to f29 from f28. Then it works again with mesa 18.2.4, so I looked here. I was looking at amdgpu bugs earlier.

  lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] (rev c1)
Comment 20 Hin-Tak Leung 2018-11-07 18:29:28 EST
BTW, I think 18.2.2 was broken too, although according to my record, I had it at 18.2.2 for about 36 hours before 18.2.3 was available and I upgraded at 2018-11-04 13:42.

Note You need to log in before you can comment on or make changes to this bug.