Bug 1649714 - nextcloud-client-2.5.0 is available
Summary: nextcloud-client-2.5.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nextcloud-client
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1650356 1651017 1651579 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 10:46 UTC by Upstream Release Monitoring
Modified: 2019-05-06 14:04 UTC (History)
11 users (show)

Fixed In Version: nextcloud-client-2.5.2-1.fc29
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-22 05:09:41 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2018-11-14 10:46:20 UTC
Latest upstream release: 2.5.0
Current version/release in rawhide: 2.3.3-2.fc28
URL: https://nextcloud.com/install/#install-clients

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/18381/

Comment 1 Germano Massullo 2018-11-16 08:51:19 UTC
2.5.0 will *not* be released on Fedora due
https://github.com/nextcloud/desktop/issues/566#issuecomment-439190829

Comment 2 Germano Massullo 2018-11-16 08:51:25 UTC
*** Bug 1650356 has been marked as a duplicate of this bug. ***

Comment 3 Germano Massullo 2018-11-18 20:07:31 UTC
*** Bug 1651017 has been marked as a duplicate of this bug. ***

Comment 4 Kevin Kofler 2018-11-19 15:54:13 UTC
It is pointless to block on QtWebEngine becoming available on PPC or s390x. This is not going to happen in the foreseeable future.

Please follow the instructions under:
https://bugzilla.redhat.com/show_bug.cgi?id=1298011#c18

Comment 5 Kevin Kofler 2018-11-19 15:59:05 UTC
https://github.com/nextcloud/desktop/commit/c4a88fe57ecaec22a8afc05e1bb9052eb6f39349
adds QtWebEngine as a mandatory dependency, so this package must become:
ExclusiveArch: %{qt5_qtwebengine_arches}

Comment 6 Germano Massullo 2018-11-19 16:23:00 UTC
Kevin what can you tell me about qt5-qtwebengine-devel missing in EPEL7 for all CPU architectures?

Comment 7 Fedora Update System 2018-11-19 16:37:21 UTC
nextcloud-client-2.5.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7255a8cc56

Comment 8 Fedora Update System 2018-11-19 16:37:22 UTC
nextcloud-client-2.5.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7255a8cc56

Comment 9 Fedora Update System 2018-11-19 16:37:44 UTC
nextcloud-client-2.5.0-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-54b3fd08be

Comment 10 Fedora Update System 2018-11-19 16:37:44 UTC
nextcloud-client-2.5.0-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-54b3fd08be

Comment 11 Fedora Update System 2018-11-19 16:38:02 UTC
nextcloud-client-2.5.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b9f641bf49

Comment 12 Fedora Update System 2018-11-19 16:38:05 UTC
nextcloud-client-2.5.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b9f641bf49

Comment 13 Germano Massullo 2018-11-19 16:38:59 UTC
Please test it and report if there is any need to reconfigure login access mode

Comment 14 Germano Massullo 2018-11-20 11:53:17 UTC
*** Bug 1651579 has been marked as a duplicate of this bug. ***

Comment 15 Marko Bevc 2018-11-20 11:57:54 UTC
Nice; will test it out - thanks!

Comment 16 Fedora Update System 2018-11-20 15:21:11 UTC
nextcloud-client-2.5.0-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-54b3fd08be

Comment 17 Fedora Update System 2018-11-20 17:02:19 UTC
nextcloud-client-2.5.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b9f641bf49

Comment 18 Fedora Update System 2018-11-20 19:28:33 UTC
nextcloud-client-2.5.0-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7255a8cc56

Comment 19 Marko Bevc 2018-11-20 19:30:03 UTC
On F29 it gives me connection timeout to cloud server. Same server is acccessible via WebGUI.

Comment 20 Jan Vlug 2018-12-07 11:44:30 UTC
Please note that in the meanwhile version 2.5.1 is available:
https://github.com/nextcloud/desktop/releases/tag/v2.5.1

Comment 21 Fedora Update System 2019-01-09 16:17:43 UTC
nextcloud-client-2.5.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-117007362a

Comment 22 Fedora Update System 2019-01-09 16:17:54 UTC
nextcloud-client-2.5.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-184842aa8c

Comment 23 Fedora Update System 2019-01-11 04:16:41 UTC
nextcloud-client-2.5.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-184842aa8c

Comment 24 Fedora Update System 2019-01-11 05:42:42 UTC
nextcloud-client-2.5.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-117007362a

Comment 25 Jan Vlug 2019-03-21 06:59:57 UTC
Nextcloud client 2.5.2  is now available, see bug 1690427.

Comment 26 Fedora Update System 2019-04-11 13:20:37 UTC
nextcloud-client-2.5.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c5d5d5aef3

Comment 27 Fedora Update System 2019-04-11 13:20:49 UTC
nextcloud-client-2.5.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5705bd6549

Comment 28 Fedora Update System 2019-04-13 03:22:04 UTC
nextcloud-client-2.5.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c5d5d5aef3

Comment 29 Fedora Update System 2019-04-13 12:10:19 UTC
nextcloud-client-2.5.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5705bd6549

Comment 30 Fedora Update System 2019-04-22 05:09:41 UTC
nextcloud-client-2.5.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Germano Massullo 2019-05-06 14:04:28 UTC
Be very careful about serious bug " Subfolders of moved folders not synced" https://github.com/nextcloud/desktop/issues/1000
Unfortunately I cannot rollback to 2.3 because it will break nextcloud-client installation


Note You need to log in before you can comment on or make changes to this bug.