Bug 165089 - KPilotDaemon crashes on resolving conflicting addressbook values
KPilotDaemon crashes on resolving conflicting addressbook values
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 166902 167840 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-04 06:02 EDT by A. Folger
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 08:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Folger 2005-08-04 06:02:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
The KPilot program works, so does the syncing, until a window pops up showing 
that there are conflicting values on a particular record in the address book. 
No matter which button is pressed (use PC values, handheld values, last sync), 
the next thing that happens is that KPilotDaemon crashes. Changing the conduct 
settings not to ask user in case of conflict but use handheld settings, 
instead, is of no use, the dialog asking the user what to do still pops up 
(that is actually a bug, too) and after pressing any button, KPilotDaemon 
crashes again.  

Version-Release number of selected component (if applicable):
kdepim-3.4.2-0.fc4.2

How reproducible:
Always

Steps to Reproduce:
1. Start KPilot  
2. Dock the Palm and press the HotSync button  
3. Assuming that at least one address record was modified (say you changed one  
telephone number that had previously been syncronized with the PC, from "home"  
to "main"), the conflict resolution dialog of the addressbook conduit will pop  
up (to reproduce this, remember to activate this conduit in the KPilot  
Settings->Configure Kpilot)  
4. Click on "Handheld Values", "PC Values" or "Last Sync" button 
    

Actual Results:  KPilotDaemon crashes 

Expected Results:  Based on which of the three buttons mentioned in step four was pressed, 
KPilotDaemon should have chosen one way to reconcile the difference, and 
continued syncing the next items. 

Additional info:

This bug is critical for handheld users, because otherwise we can't sync. I  
can't make my agenda up to date. HELP. SAVE ME. I am drowning in a rising wave 
of bits, flowing at 115000baud (oh, wait, you can't really drown in bits, can 
you? ;-) Still the bug is critical).
Comment 1 Ngo Than 2005-08-15 12:23:21 EDT
could you please try the new kdepim-3.4.2-2 on ftp://people.redhat.com/than/fc4
does it fix the problem?
Comment 2 A. Folger 2005-08-15 14:28:06 EDT
I tried out the package and there was no improvement. 
 
However, I alsoneed to raise the following aggravation, already noticed before 
I installed your patched version, which persists even in that new package: 
while new calendar entries in the palm are synced to the kde calendar 
resource, they do not sync in the opposite direction, and after having been 
copied to the desktop calendar resource, the new entries often disappear from 
the palm. Likewise, changing entries on the desktop does not cause them to be 
changed on the palm (say, addition of a note to an event) 
Comment 3 A. Folger 2005-08-15 15:16:39 EDT
I wonder whether the version of the palmOS used is relevant here. I am using 
v. 4.1 on a Palm m515. It worked like a charm until FC3 included. 
Comment 4 Ngo Than 2005-08-16 06:30:14 EDT
Could you please downgrade to kdepim-3.4.2-0.fc4.2 first and then install the
kdepim-debuginfo-3.4.2-0.fc4.2 package, try again to get the backtrace, then
attach it into bugzilla. Thanks

i cannot reproduce this problem with PalmVx.
Comment 5 A. Folger 2005-08-16 09:23:01 EDT
Well, it doesn't produce backtraces. I probably need to install an extra 
package, do I? Which one? (devel?) 
Comment 6 Ngo Than 2005-08-16 09:52:58 EDT
you should install kdepim-debuginfo-3.4.2-0.fc4.2 please.
Comment 7 A. Folger 2005-08-22 12:26:45 EDT
Sorry for the delay, busy at the office. Here is the backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208338752 (LWP 18262)]
[KCrash handler]
#4  0x00468bb5 in memcpy () from /lib/libc.so.6
#5  0x006b8c63 in PilotAddress::pack_ (this=0xa21f4a8, buf=0xa46c960, len=0x0)
    at pilotAddress.cc:681
#6  0x006a95b4 in PilotAppCategory::pack (this=0xa21f4a8)
    at pilotRecord.cc:220
#7  0x002aed55 in AbbrowserConduit::_writeBackup (this=0xa46c960, 
    backup=0xa21f4a8) at abbrowser-conduit.cc:1342
#8  0x002b139d in AbbrowserConduit::_copyToPC (this=0xa036140, 
    pcAddr=@0xbf9bf638, backupAddr=0xa46c960, palmAddr=0xa21f4a8)
    at abbrowser-conduit.cc:1327
#9  0x002b3785 in AbbrowserConduit::_smartMergeAddressee (this=0xa036140, 
    pcAddr=@0xbf9bf638, backupAddr=0xa0ff748, palmAddr=0xa21f4a8)
    at abbrowser-conduit.cc:2059
#10 0x002b433c in AbbrowserConduit::syncAddressee (this=0xa036140, 
    pcAddr=@0xbf9bf638, backupAddr=0xa0ff748, palmAddr=0xa21f4a8)
    at abbrowser-conduit.cc:1223
#11 0x002b7321 in AbbrowserConduit::slotPalmRecToPC (this=0xa036140)
    at abbrowser-conduit.cc:851
#12 0x002b76b2 in AbbrowserConduit::qt_invoke (this=0xa036140, _id=4, 
    _o=0xa46c960) at abbrowser-conduit.moc:92
#13 0x04de1df4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x0515a206 in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x04dff673 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x04e07f55 in QSingleShotTimer::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x04d7d0cd in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x04d7da4c in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x05442851 in KApplication::notify () from /usr/lib/libkdecore.so.4
#20 0x04d71972 in QEventLoop::activateTimers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x04d2735a in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x04d95772 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x04d95696 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x04d7ca99 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x0805d65b in main (argc=172411232, argv=0xa46c960) at pilotDaemon.cc:1367
#26 0x00411de6 in __libc_start_main () from /lib/libc.so.6
#27 0x08053e61 in _start ()
Comment 8 Ngo Than 2005-08-24 04:45:20 EDT
Could you please install the pilot-link-debuginfo-0.12.0-0.pre3.0.fc4.1 and 
try again to get the backtrace. Many thanks for your help 
Comment 9 A. Folger 2005-08-25 07:15:35 EDT
OK, I installed pilot-link-debuginfo, as requested. Note that in order not to
ruin my agenda, I have disabled the calendar conduit, so that you only see debug
info of the addressbook conduit. Here is the output:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208625472 (LWP 4398)]
[KCrash handler]
#4  0x00e74865 in memcpy () from /lib/libc.so.6
#5  0x006b8c63 in PilotAddress::pack_ (this=0x9ebe158, buf=0xa14fc20, len=0x0)
    at pilotAddress.cc:681
#6  0x006a95b4 in PilotAppCategory::pack (this=0x9ebe158)
    at pilotRecord.cc:220
#7  0x00378d55 in AbbrowserConduit::_writeBackup (this=0xa14fc20, 
    backup=0x9ebe158) at abbrowser-conduit.cc:1342
#8  0x0037b39d in AbbrowserConduit::_copyToPC (this=0x9d20648, 
    pcAddr=@0xbfd79688, backupAddr=0xa14fc20, palmAddr=0x9ebe158)
    at abbrowser-conduit.cc:1327
#9  0x0037d785 in AbbrowserConduit::_smartMergeAddressee (this=0x9d20648, 
    pcAddr=@0xbfd79688, backupAddr=0x9facd18, palmAddr=0x9ebe158)
    at abbrowser-conduit.cc:2059
#10 0x0037e33c in AbbrowserConduit::syncAddressee (this=0x9d20648, 
    pcAddr=@0xbfd79688, backupAddr=0x9facd18, palmAddr=0x9ebe158)
    at abbrowser-conduit.cc:1223
#11 0x00381321 in AbbrowserConduit::slotPalmRecToPC (this=0x9d20648)
    at abbrowser-conduit.cc:851
#12 0x003816b2 in AbbrowserConduit::qt_invoke (this=0x9d20648, _id=4, 
    _o=0xa14fc20) at abbrowser-conduit.moc:92
#13 0x04de1df4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x0515a206 in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x04dff673 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x04e07f55 in QSingleShotTimer::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x04d7d0cd in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x04d7da4c in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x05442851 in KApplication::notify () from /usr/lib/libkdecore.so.4
#20 0x04d71972 in QEventLoop::activateTimers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x04d2735a in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x04d95772 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x04d95696 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x04d7ca99 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x0805d65b in main (argc=169147424, argv=0xa14fc20) at pilotDaemon.cc:1367
#26 0x00e1dd5f in __libc_start_main () from /lib/libc.so.6
#27 0x08053e61 in _start ()

What now?
Comment 10 Joe Christy 2005-08-26 18:54:40 EDT
I see this with my Zire 31, and kdepim-3.4.2-0.fc4.3.
Do you want stack traces? Should I downgrade to kdepim-3.4.2-0.fc4.2 first?
Comment 11 Joe Christy 2005-08-26 21:25:07 EDT
As I look more carefully at what I am seeing, it appears that the circumstances
leading up to the appearance of the bug are substantially different (though the
stack trace I get is virtually identical). In particular, i don't have any
conflicts to be resolved. Cf.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=166902
OTOH, the conflict resolution probably is a red herring, in light of the stack
trace.
Comment 12 Ngo Than 2005-08-29 13:24:23 EDT
*** Bug 166902 has been marked as a duplicate of this bug. ***
Comment 13 Ngo Than 2005-08-29 13:28:21 EDT
Could someone please update to pilot-link-0.12.0-0.pre4.2.fc4.1 and see if the
problem still appears? 

You find the new version on ftp://people.redhat.com/than/fc4/

Thanks
Comment 14 Joe Christy 2005-09-01 21:12:40 EDT
Bingo! With pilot-link-0.12.0-0.pre4.2.fc4.1, after a chilling pause during the
HotSync when it got to my Address Book, Kpilot continued on successfully! My
problem, at least, is solved.

Sorry I had my head up my *** when comment 13 was posted and didn't see it until
today to test the new pilot-link. Hurray!
Comment 15 A. Folger 2005-09-02 07:28:28 EDT
Well, now it seems to work. I resolved the conflicts without crashes, but I
still need to look at the data on the palm and in the kde addressbook in detail.
At first sight, it does seem ok, though.

Now I still have another problem, which wasn't fixed with this release: the
calendar doesn't sync. While I have added many appointments to the desktop
calendar, they don't show up on the Palm, even though the conduit is active.
Since KPilot doesn't compain, it would be hard to do a stack trace, correct?
Comment 16 Ngo Than 2005-09-05 04:50:05 EDT
Can anyone reproduce this problem on Comment #15 ? A.Folger, which kernel 
version are you using on your machine? 
  
  
Comment 17 Joe Christy 2005-09-05 22:48:05 EDT
Cannot reproduce this
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165089#c15 (w/
kernel-2.6.12-1.1505_FC4, pilot-link-0.12.0-0.pre4.2.fc4.1, and
kdepim-3.4.2-0.fc4.3.

After https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165089#c14, I did
notice that both my palm and desktop address books were corrupt, but restoring
from backups and little scraps of paper (sigh) solved that.
Comment 18 A. Folger 2005-09-06 03:30:23 EDT
afolger@dhcppc4 ~]$ rpm -q kdepim kernel pilot-link
kdepim-3.4.2-0.fc4.3
kernel-2.6.12-1.1398_FC4
pilot-link-0.12.0-0.pre4.2.fc4.1

Note that my addressbook is ok now (using the latest update you created), but
the calendar conduit is broken, as I pointed out above. Is there a way to reset
the calendar, force pilot-link to wipe it out and copy all the data from the
desktop addressbook, just in case the problem is a file corruption? Is there a
way to diagnose file corruption on the Palm?
Comment 19 Joe Christy 2005-09-10 15:26:51 EDT
Sometime in the last few days, all the entries on my palm's Calendar disappeared
and I can't persuade kpilot to sync them back onto the palm from Korganizer.
Comment 20 A. Folger 2005-09-11 13:58:12 EDT
Ahum, I had a look, and my addressbook was eaten up, as well. I am now restoring
the last backup from before this saga began. By now I also updated the kernel to
2.6.12-1.1447_FC4 although I am not sure if that matters for our purpose.

Can somebody bring some light to this isue?
Comment 21 Joe Christy 2005-09-12 12:58:33 EDT
When my addressbook got munged a couple of weeks ago, I discovered, by looking
at the post-sync stored .pdb's on my laptop that the data was apparently still
there on the palm, not that it did me any good.

This time, with my datebook, that doesn't seem to be the case.

My latest theory is that somehow or another, my palm thinks that the data has
been deleted and that the data in Kaddressbook and Korganizer is "archived". I'm
trying to figure out is there is a way to convince Kpim to un-archive them and
sync them back to the palm.
Comment 22 Joe Christy 2005-09-12 13:00:40 EDT
And one more data point - my comment #19 isn't quite accurate. The lone
appointment I entered onto my palm the day before I noticed that everything else
was gone, syncs back and forth just fine.
Comment 23 Joe Christy 2005-09-12 20:48:48 EDT
After consulting the kdepim-users list, I tried to tell KPilot Daemon to "Copy
PC to Handheld (once)", with only the Kadressbook and ToDo conduits checked, to
no avail. Sigh. 
Comment 24 Ngo Than 2005-09-13 06:01:48 EDT
*** Bug 167840 has been marked as a duplicate of this bug. ***
Comment 25 Joe Christy 2005-09-19 15:05:26 EDT
More data: This weekend I took the latest pilot-link from Updates
(0.12.0-0.pre4.0.fc4.2) and freshly installed and otherwise completely updated
system, then synced my Zire 31 using kpilot (from kdepim-3.4.2-0.fc4.3). Result,
the sync didn't get the new ToDo's and appointments from my Palm and mangled
trying to resolve some putative conflicts in my addressbook (which didn't
actually exist [I'm sure since one of them was my own contact info]) corrupted
the data on my Palm. I then fixed the newly corrupted data on my Palm by hand
(stylus, actually).

Then, just for grins, I uninstalled pilot-link-0.12.0-0.pre4.0.fc4.2, built an
FC4 rpm of pilot-link-0.11.8 from the FC3 SRPM and installed it. Next I rebuilt
the kdepim-3.4.2-0.fc4.3 rpm from the SRPM against the stable (0.11.8)
pilot-link and installed it. Lo and behold, no problems in 3 days - syncs both
directions, no bogus conflicts, no corrupt data.

Given that pilot-link-0.12.0-0.preX, for all X, intermittently fails and
corrupts data, but pilot-link-0.11.8 doesn't and kdepim builds fine against it,
would it be possible to release a) a pilot-link-0.11.8-compat RPM and b) a
kdepim update that uses it, so thatr KDE users can have reliably working palm
syncs, please?
Comment 26 Anthony Meijer 2005-10-01 15:11:32 EDT
I've had similar problems, including the one where the entire agenda  
disappeared. I would also really appreciate a pilot-link-0.11.8-compat RPM 
with a kdepim update so that I can sync again, please. 
Comment 27 A. Folger 2005-10-10 07:55:05 EDT
I have been watching the updates for a few weeks, hoping the solution would
appear, but am still without a functioning sync system for my Palm.
Buhuhuuuuuuuu. Are there any plans to fix this, if only by releasing rpms for
reverting to pilot-link-0.11.8 while keeping as many current fc4 files as possible?
Comment 28 A. Folger 2005-11-07 16:27:34 EST
Hmmm, another month during which I remain weaned from my palm has passed. Will
someone at least tell me whether there are any plans to fix this? ... whether
pilot-link will be fixed or whatever? I don't seem to be the only guy suffering
from this bug, am I? I do not want to make any demanss on anybody, much
opensource work is done by volunteers, but a little information would go a long way.
Comment 29 A. Folger 2006-03-15 14:16:34 EST
Since September, nothing happened on this area. I know that FC5 is coming out
any day, but since I applied all the updates to my FC4, I expected that things
would have cleared up by now. So I tested it. I synced the Palm. The first thing
I noticed is that the myriads of appointments I entered in Kontact since the
problems started in the summer were NOT transferred to the Palm. Then, I entered
a new appointment on the Palm and another one on the Desktop, and synced, and
while the Palm's appointment synced to the desktop, the reverse was not true.

My questions are:
* Will there be a fix for FC5?
* Will there be a fix for FC4? (production systems don't migrate so quickly)
* Considering I am not a developer, can I do something to make this happen soon
anyway?

Thanks for the great work.
Comment 30 A. Folger 2006-03-15 14:26:08 EST
In addition to the malfunctioning calendar conduit, I shall also add that the
address book conduit isn't working, either. Every time I sync, it asks me to
resolve the same conflict. It doesn't matter which button I click ("Handheld",
"Desktop", "Last Sync", Apply", etc.), the next time, I will be presented with
the same conflict, again.

Thus, a ppart of the problem that we believed fixed is broken again.
Comment 31 Ngo Than 2006-03-16 04:26:50 EST
it seems pilot-0.12 prerelease causes many problems here, so i plan to revert to
pilot-link-0.11.8 for FC4 and FC5 after FC5 release.
Comment 32 Joe Christy 2006-03-16 11:11:07 EST
Re: Comment #31 - Hurray! Since I started rebuilding the successive kdepims
against pilot-link-0.11.8 6 months ago*, I haven't had any problems with kpilot.

However, it appears that kdepim atop kpilot/pilot-link is moribund and opensync
is the wave of the future. Any plans to move to opensync (http://www.opensync.org/)?


* quite a pain, since the disfunctional pilot-0.12 prerelease is a pre-req for
many packages that I never use, but are installed by default and are
prerequisites in turn for packages I do use)
Comment 33 Rex Dieter 2006-03-16 11:13:39 EST
AFAIK, opensync's "wave of the future" is slated for KDE 4, not KDE 3.x
Comment 34 A. Folger 2006-04-25 12:30:53 EDT
I am using FC5 now and the problems are gone. Thanks Ngo Than.

AFAIK, thus bug can now be closed. However, before taking this ahem dramatic
step, could anybody help me with a little side effect of this bug? Since both
addressbook and organizer were malfunctioning, I lost quite a few appointments
on my Palm. These appointments are present on the desktop korganizer resource.
How can I "reset" the Palm's organizer and make it resync the complete
korganizer resource (more than three years of appointments)? Interestingly, the
problem made me even lose old appointments, from before the upgrade to FC4!

Note You need to log in before you can comment on or make changes to this bug.