Bug 165594 - When Autocompletion is checked for LDAP it does not work
When Autocompletion is checked for LDAP it does not work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 165595 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 13:29 EDT by Matthew Wright
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-09 05:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
e-d-s started from putty console (16.36 KB, text/plain)
2005-08-17 18:39 EDT, Matthew Wright
no flags Details

  None (edit)
Description Matthew Wright 2005-08-10 13:29:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
In my installation I am running.
evolution-2.2.3-1.fc4
evolution-data-server-1.2.3-2.fc4

This is a test server for a production SOE dekstop environment with real non technical end users running LTSP and FreeNX Terminal Services FC4

When you check the Edit Preferences

Version-Release number of selected component (if applicable):
evolution-2.2.3-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. Start Evolution from the Launchmail icon on the Control Panel
2. Setup an LDAP address book (in my test case the user has write access to the LDAP store)
3. Goto Edit Preferences then Autocompletion and switch the checkbox on next to the addressbook you have created  (you can leave personal checked or uncheck it --> same result either way
4. Click close to clear the dialog
5. in the main window click the New button to create a new email message 
6. Start typing a name that you have verified is in your LDAP address book
(You can verify names are in your LDAP address book by clicking on Contacts and doing a search) --> you can also find them manually by clicking on the To button


Actual Results:  The Name does not auto resolve
if you try this with the personal address book for the same card (ie drag and drop a card that didn't work from you ldap store into your personal address book, make sure Autocompletion is checked for Personal, you will find that autocompletion works when you start typing a few charachters for an address book card (any email address that is in a card)

Expected Results:  Evolution should have started querying the LDAP server and tried to resolve the rest of the name real time autocompleting it   I have noticed that Queries are rather slow hitting OpenLDAP (which is on the same machine as my evolution) ie Dell GX270 / P4HT 3.0GHZ 1MBL2Cache / 4GB RAM) So I left it for 20 seconds and it still didn't resolve.



Additional info:

I haven't been able to test this in the past cause we were waiting on resolution the problem Bug #165269  We now have a fix for this and this has allowed us to progress in our use of Evolution Groupware components.
Comment 1 Matthew Wright 2005-08-10 13:39:54 EDT
*** Bug 165595 has been marked as a duplicate of this bug. ***
Comment 2 Dave Malcolm 2005-08-10 22:20:28 EDT
Thanks for this report.

FWIW, this appears to be working for me in rawhide: evolution-2.3.7-1

IIRC, Evolution's autocompletion code only kicks in after 3 or more characters
have been typed.

If you use Ethereal or a similar tool, is Evolution actually sending any LDAP
queries to the server when you try autocompleting?

Comment 3 Dave Malcolm 2005-08-10 22:22:35 EDT
Also, is Evolution in "online" mode?  Code was added recently that tries to make
an offline cache of LDAP addressbooks; can't remember off the top of my head if
that made it into FC4's Evolution.
Comment 4 Matthew Wright 2005-08-14 21:48:06 EDT
Unable to test with rawhide at the moment sorry :(

My version is FC4 uptodate Evolution 2.2.3
evolution-2.2.3-2.fc4
and
evolution-data-server-1.2.3-2.fc4
I have the following settings
Edit | Preferences | Autocompletion | Personal = Unchecked (Off)
Edit | Preferences | Autocompletion | on LDAP Servers | MyLDAPtest = CHECKED (on)

Under Contacts Right button Properties on MyLDAPtest General Tab

Name = MyLDAPtest
copy book content locally for offline operation = unchecked (off)
Mark as default folder = on (I have tested this with on and off both fail)
Server = localhost
Port = 389
user secure connection = Never
Login Method = using Email address
Login Matthew.wright2@hp.com  password is matt and saved
-------------
Details tab
DC=vic,dc=greens,dc=org,dc=au
Search scope = Sub
Timeout 5 mins
Download limit 100 cards

Just to confirm problem,  autocompletion is when you type directly into the To
Field in the Compose a message window

I can search teh LDAP database if I click on the To: button.  That is all
working fine.

Are you able to test at your end?
Comment 5 Matthew Wright 2005-08-16 18:31:06 EDT
created upstream gnome bugzilla report
http://bugzilla.gnome.org/show_bug.cgi?id=313673

And have found that this problem stil occurs in 2.3.6.1 (rawhide version of
Evolution).

I don't seem to be getting the latest update in my rawhide, i'll check the yum.conf
Comment 6 Matthew Wright 2005-08-17 18:39:54 EDT
Created attachment 117859 [details]
e-d-s started from putty console

Ran e-d-s from console as requested, started evolution, created a new mail
message
then started entering a name.  As you can see LDAP database was queried however
no name resolutin ocurred int the To field of the email as I typed it.
Comment 7 Matthew Wright 2005-08-20 17:11:14 EDT
From upstream bug report http://bugzilla.gnome.org/show_bug.cgi?id=313673#c2

This fix at 311684 is committed to cvs head.
And for me autocompletion works with LDAP backend.

Can you start evolution-data-server in a seperate
console and look for the debug messages printed there while
querying LDAP server?

Also, searching for a contact in LDAP book works for you?


------- Additional Comment #3 From Sushma Rai 2005-08-20 10:31 UTC -------

I'll commit the fix for 311684 for 2.2 stable branch also.
closing the bug. Please reopen if needed, with the details.
Comment 8 Dave Malcolm 2005-08-24 17:23:32 EDT
(the reference to 311684 in copy of comment in comment 7 is the upstream version
of our bug 165269; and isn't relevant anymore: it's the crasher that was fixed;
we're still at the debugging stage with this one, AFAIUI)
Comment 9 Dave Malcolm 2005-08-24 17:28:53 EDT
I doublechecked this, and autocompletion is working against LDAP with rawhide
evolution/e-d-s (2.3.8/1.3.8).  I had to be careful to turn it off for the local
addressbook, since the bbdb plugin tends to populate your local addressbook with
stuff from the LDAP store
Comment 10 Matthew Wright 2005-10-09 05:30:35 EDT
This is confirmed working.  I have since got it working, the final problem was a
configuration issue with my LDAP.
Comment 11 Dave Malcolm 2005-10-09 06:11:53 EDT
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.