Bug 1655503 - [RFE]Add "windows 2019 x64" support
Summary: [RFE]Add "windows 2019 x64" support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.3.2
Hardware: x86_64
OS: Unspecified
medium
low
Target Milestone: ovirt-4.3.4
: 4.3.4
Assignee: Steven Rosenberg
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On: 1563004 1659067 1659071 1676893
Blocks: 1656346
TreeView+ depends on / blocked
 
Reported: 2018-12-03 10:27 UTC by mxie@redhat.com
Modified: 2024-06-13 22:00 UTC (History)
16 users (show)

Fixed In Version: ovirt-engine-4.3.4
Doc Type: Enhancement
Doc Text:
This release adds support for virtual machines to use Windows 2019 x64 in the Administration Portal.
Clone Of:
Environment:
Last Closed: 2019-06-11 06:25:41 UTC
oVirt Team: Virt
Embargoed:
rbarry: ovirt-4.3?
pm-rhel: planning_ack?
pm-rhel: devel_ack+
lleistne: testing_ack+


Attachments (Terms of Use)
win2019 (45.07 KB, image/png)
2018-12-03 10:27 UTC, mxie@redhat.com
no flags Details
operating system select in new VM (75.57 KB, image/png)
2019-03-29 13:56 UTC, Petr Matyáš
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 98834 0 master MERGED engine: Added Windows 2019 x64 Support 2020-11-02 14:09:43 UTC
oVirt gerrit 99488 0 ovirt-engine-4.3 MERGED engine: Added Windows 2019 x64 Support 2020-11-02 14:09:44 UTC

Description mxie@redhat.com 2018-12-03 10:27:46 UTC
Created attachment 1510849 [details]
win2019

Description of problem:
[RFE]Add "windows 2019 x64"to operating system option on rhv4.2

Version-Release number of selected component (if applicable):
rhv:4.2.7.5-0.1.el7ev

How reproducible:
100%

Background:
1.Use virt-v2v convert a win2019 guest to rhv4.2 but its operating system shows Windows 2016 x64,pls refer to screenshot"win2019"



Actual results:
As above description

Expected results:
Should add "windows 2019 x64" to operating system option on rhv4.2

Additional info:

Comment 2 Ryan Barry 2018-12-04 11:29:40 UTC
In general, we adjust the os types when there's a difference in the virtual hardware configuration. Windows 2019 is more or less identical to Windows 2018 in this sense.

We can add it to the list of ostypes, but there is basically no chance that such a change will make 4.2

Comment 3 Michal Skrivanek 2018-12-11 13:08:58 UTC
Need to add support in windows guest tools / drivers first, only then it can be supported in RHV.
Also do not forget new icon and sysprep xml

Comment 4 Michal Skrivanek 2018-12-12 10:01:13 UTC
also, guest agent reporting. I suspect it's not working in current qemu-ga either.

Comment 5 Michal Skrivanek 2019-01-04 11:48:48 UTC
(In reply to Michal Skrivanek from comment #4)
> also, guest agent reporting. I suspect it's not working in current qemu-ga
> either.

so please also pull in fixed qemu-ga from bug 1659071

Comment 9 Tomáš Golembiovský 2019-02-13 14:33:20 UTC
(In reply to Michal Skrivanek from comment #5)
> (In reply to Michal Skrivanek from comment #4)
> > also, guest agent reporting. I suspect it's not working in current qemu-ga
> > either.
> 
> so please also pull in fixed qemu-ga from bug 1659071

The fix there is not relevant to us as we don't rely on names reported from qemu-ga. I opened a VDSM bug 1676893

Comment 13 Petr Matyáš 2019-03-29 13:55:50 UTC
Tested on ovirt-engine-4.3.3.1-0.1.el7.noarch

The Win 2019 option is still missing from operating system pick when creating a new VM.

Comment 14 Petr Matyáš 2019-03-29 13:56:27 UTC
Created attachment 1549464 [details]
operating system select in new VM

Comment 18 Petr Matyáš 2019-05-17 16:07:30 UTC
Verified on ovirt-engine-4.3.4-0.1.el7.noarch

Comment 19 Sandro Bonazzola 2019-06-11 06:25:41 UTC
This bugzilla is included in oVirt 4.3.4 release, published on June 11th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.