Bug 165595 - When Autocompletion is checked for LDAP it does not work
When Autocompletion is checked for LDAP it does not work
Status: CLOSED DUPLICATE of bug 165594
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 13:30 EDT by Matthew Wright
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-10 13:39:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Wright 2005-08-10 13:30:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
In my installation I am running.
evolution-2.2.3-1.fc4
evolution-data-server-1.2.3-2.fc4

This is a test server for a production SOE dekstop environment with real non technical end users running LTSP and FreeNX Terminal Services FC4

When you check the Edit Preferences

Version-Release number of selected component (if applicable):
evolution-2.2.3-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. Start Evolution from the Launchmail icon on the Control Panel
2. Setup an LDAP address book (in my test case the user has write access to the LDAP store)
3. Goto Edit Preferences then Autocompletion and switch the checkbox on next to the addressbook you have created  (you can leave personal checked or uncheck it --> same result either way
4. Click close to clear the dialog
5. in the main window click the New button to create a new email message 
6. Start typing a name that you have verified is in your LDAP address book
(You can verify names are in your LDAP address book by clicking on Contacts and doing a search) --> you can also find them manually by clicking on the To button


Actual Results:  The Name does not auto resolve
if you try this with the personal address book for the same card (ie drag and drop a card that didn't work from you ldap store into your personal address book, make sure Autocompletion is checked for Personal, you will find that autocompletion works when you start typing a few charachters for an address book card (any email address that is in a card)

Expected Results:  Evolution should have started querying the LDAP server and tried to resolve the rest of the name real time autocompleting it   I have noticed that Queries are rather slow hitting OpenLDAP (which is on the same machine as my evolution) ie Dell GX270 / P4HT 3.0GHZ 1MBL2Cache / 4GB RAM) So I left it for 20 seconds and it still didn't resolve.



Additional info:

I haven't been able to test this in the past cause we were waiting on resolution the problem Bug #165269  We now have a fix for this and this has allowed us to progress in our use of Evolution Groupware components.
Comment 1 Matthew Wright 2005-08-10 13:39:45 EDT
********DUPLICATE********
My apologies -- this is what happens when you file bug reports @ 3:30AM in the
morning
please refer to Bug #165594
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165594

*** This bug has been marked as a duplicate of 165594 ***

Note You need to log in before you can comment on or make changes to this bug.