Bug 1656053 - [ceph-metrics]ceph-metric ansible uses iscsis instead of iscsigws
Summary: [ceph-metrics]ceph-metric ansible uses iscsis instead of iscsigws
Keywords:
Status: CLOSED DUPLICATE of bug 1595288
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Metrics
Version: 3.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: 3.2
Assignee: Boris Ranto
QA Contact: ymane
URL:
Whiteboard:
Depends On:
Blocks: 1629656
TreeView+ depends on / blocked
 
Reported: 2018-12-04 14:47 UTC by ymane
Modified: 2019-01-17 16:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
.The _iSCSI Overview_ dashboard does not display graphs if the [iscsigws] role is included in the Ansible inventory file. When deploying the Red Hat Ceph Storage Dashboard, the _iSCSI Overview_ dashboard does not display any graphs or values if the Ansible inventory file has the [iscsigws] role included for iSCSI gateways. To work around this issue, add `[iscsis]` as a role in the Ansible inventory file and run the Ansible playbook for `cephmetrics-ansible`. The _iSCSI Overview_ dashboard then displays the graphs and values.
Clone Of:
Environment:
Last Closed: 2019-01-09 23:01:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ymane 2018-12-04 14:47:39 UTC
Description of problem:
Ceph-metric ansible requires [iscsis] in inventory file to display "iSCSI Overview" dashboard.  

Version-Release number of selected component (if applicable):
cephmetrics-ansible-2.0.1-1.el7cp.x86_64
ceph-ansible-3.2.0-0.1.rc4.el7cp.noarch

How reproducible:
Always

Steps to Reproduce:
1.Deploy cluster with iscsi gateways
2.Deploy ceph-metrics with inventory file [iscsigws] role
3.playbook completes successfully,however graghs in "iSCSI Overview" dashboard are not displayed
4.After adding [iscsis] in inventory file & rerunning ceph-metrcs playbook,graghs in "iSCSI Overview" dashboard are displayed

Actual results:

After adding [iscsis] in inventory file & rerunning ceph-metrcs playbook,graghs in "iSCSI Overview" dashboard are displayed

Expected results:

Cephmetrics-ansible should have deployed with [iscsigws] / [iscsi-gws] role as used by ceph-ansible 

Additional info:
Inventory file
[iscsigws] #(for cephansible)
magna087
magna089
[iscsis] #(for cephmetric-ansible)
magna087
magna089

Comment 4 Christina Meno 2018-12-04 21:46:06 UTC
Boris,

Do we have any work upstream to support this? If no let's get it fixed in 3.2z1

Comment 5 Boris Ranto 2018-12-05 14:10:08 UTC
This is actually a duplicate of

https://bugzilla.redhat.com/show_bug.cgi?id=1595288

or even

https://bugzilla.redhat.com/show_bug.cgi?id=1515153

For 3.2, it would be nice if we at least documented it. The patch itself should not be too invasive but it is not ready, yet.

Comment 8 Christina Meno 2019-01-09 23:01:11 UTC

*** This bug has been marked as a duplicate of bug 1595288 ***


Note You need to log in before you can comment on or make changes to this bug.