Bug 1656750 - No metrics displayed in console in 4.0
Summary: No metrics displayed in console in 4.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 4.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.0.0
Assignee: Samuel Padgett
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1656751 1659854 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 09:09 UTC by Junqi Zhao
Modified: 2019-01-10 02:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-10 02:19:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
only show "Kubernetes API" and "OKD Console" for cluster-admin user on "Home -> Status" page (146.15 KB, image/png)
2018-12-06 09:09 UTC, Junqi Zhao
no flags Details
Could show Health, Control Plane Status and Capacity Planning panel under "Home -> Status" (73.34 KB, image/png)
2019-01-10 02:19 UTC, Junqi Zhao
no flags Details

Description Junqi Zhao 2018-12-06 09:09:21 UTC
Created attachment 1512011 [details]
only show "Kubernetes API" and "OKD Console" for cluster-admin user on "Home -> Status" page

Description of problem:
This bug is cloned from https://jira.coreos.com/browse/MON-487
File it again for QE team to track the monitoring issue.

Deploy cluster monitoring on AWS with Next-Gen Installer and then login cluster console with cluster-admin user,
it only show "Kubernetes API" and "OKD Console" for cluster-admin user on "Home -> Status" page.
See the attached picture OKD_cluster_console.png. "Alerts Firing", "Crashlooping Pods" under Health and
"Control Plane Status", "Capacity Planning" panel are missing

Note: after doing workaround manually, could see the UI

Version-Release number of selected component (if applicable):
cluster monitoring images used
docker.io/grafana/grafana:5.2.4
docker.io/openshift/oauth-proxy:v1.1.0
docker.io/openshift/prometheus-alertmanager:v0.15.2
docker.io/openshift/prometheus-node-exporter:v0.16.0
docker.io/openshift/prometheus:v2.5.0
quay.io/coreos/configmap-reload:v0.0.1
quay.io/coreos/kube-rbac-proxy:v0.4.0
quay.io/coreos/kube-state-metrics:v1.4.0
quay.io/coreos/prom-label-proxy:v0.1.0
quay.io/coreos/prometheus-config-reloader:v0.26.0
quay.io/coreos/prometheus-operator:v0.26.0
registry.svc.ci.openshift.org/openshift/origin-v4.0-2018-12-06-021016@sha256:398213ab383af6c260e36b414e8847e855e690e94a1f913fd16bfd803e80cc1b


console images used
console-operator:registry.svc.ci.openshift.org/openshift/origin-v4.0-2018-12-06-021016@sha256:b3ced03b1d2e181199dd387b6caa15ff051e2019a4dd22abaf5365de25d874b3
openshift-console:registry.svc.ci.openshift.org/openshift/origin-v4.0-2018-12-06-021016@sha256:30377f30198cd28ba77ff3fb729702ddec8eb0794c9470ad3d9d9298ca3ec1e6


How reproducible:
Always

Steps to Reproduce:
1. Deploy cluster monitoring on AWS with Next-Gen Installer and then login cluster console with cluster-admin user
2.
3.

Actual results:
only show "Kubernetes API" and "OKD Console" for cluster-admin user on "Home -> Status" page

Expected results:
Should show all the monitoring fields

Additional info:

Comment 1 Samuel Padgett 2018-12-10 16:30:17 UTC
We need to inject service-ca.crt into our container to proxy to Prometheus. The way this has done has changed in 4.0.

Comment 2 Samuel Padgett 2018-12-13 14:08:21 UTC
*** Bug 1656751 has been marked as a duplicate of this bug. ***

Comment 3 Samuel Padgett 2018-12-17 14:51:02 UTC
*** Bug 1659854 has been marked as a duplicate of this bug. ***

Comment 4 Samuel Padgett 2018-12-17 20:32:56 UTC
Console change:

https://github.com/openshift/console/pull/960

Console operator change:

https://github.com/openshift/console-operator/pull/96

Comment 5 Samuel Padgett 2019-01-04 14:09:59 UTC
When the console-operator PR merges, this will be fixed. We're fighting test flakes.

Comment 6 Junqi Zhao 2019-01-10 02:18:30 UTC
Could show Health, Control Plane Status and Capacity Planning panel under "Home -> Status"
although some metrics are not shown, it is monitoring issue, already filed Bug 1664180

Move this bug to VERIFIED.

Comment 7 Junqi Zhao 2019-01-10 02:19:22 UTC
Created attachment 1519620 [details]
Could show Health, Control Plane Status and Capacity Planning panel under "Home -> Status"


Note You need to log in before you can comment on or make changes to this bug.