Bug 165867 - FC3 kdm gives an error about not finding Bluecurve theme
FC3 kdm gives an error about not finding Bluecurve theme
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 166411 166500 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 18:56 EDT by Martí­n Marqués
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 02:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martí­n Marqués 2005-08-12 18:56:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
When ever kdm stats it gives an error about not finding /usr/share/apps/kdm/themes/Bluecurve (which doesn't exist). All this with the last kde upgrade (I think it was 10/Agust/2005).

Also, any configuration of kdm will result in no change at all.

Version-Release number of selected component (if applicable):
kdebase-3.4.2-0.fc3.2

How reproducible:
Always

Steps to Reproduce:
1. Start kdm


Actual Results:  Error about not finding /usr/share/apps/kdm/themes/Bluecurve

Expected Results:  There should be a Bluecurve theme.

Additional info:
Comment 1 Aleksey Nogin 2005-08-14 00:25:33 EDT
Note that this only happens with the latest kdebase upgrade. The
/etc/X11/xdm/kdmrc contains lines:

Theme=/usr/share/apps/kdm/themes/Bluecurve
Themes=/usr/share/apps/kdm/themes/circles,/usr/share/apps/kdm/themes/Bluecurve

but the directory /usr/share/apps/kdm/themes/Bluecurve does not exist.

P.S. On FC4 this directory is provided by edhat-artwork-0.122-10, but
redhat-artwork-0.117-1 on FC3 does not have it.
Comment 2 John (J5) Palmieri 2005-08-14 10:00:42 EDT
It seems to me to be a problem with the new KDE base pointing to the wrong
location.  I don't think it is worth the effort backporting the FC4 changes in
redhat-artwork since older versions of KDE worked fine.  
Comment 3 Martí­n Marqués 2005-08-14 19:11:49 EDT
So, what should be done to solve this BUG? Is there a way to fix kdmrc so that 
it finds what it has to find? 
 
I also found (don't know if it's related with this bug) that some changes done 
to KDM through kcontrol don't take effect (users to show with there 
fotographs, etc.). 
Comment 4 Ngo Than 2005-08-15 02:06:49 EDT
it seems kdmtheme is enable in FC3. You should please type the following
commandline (need root) to fix this problem:

perl -pi -e 's|UseTheme=true|UseTheme=false|g' /etc/X11/xdm/kdmrc


it's now fixed in CVS. Thanks for your report.

Comment 5 Martí­n Marqués 2005-08-15 08:57:02 EDT
OK, but didn't have to bother old friend perl for that. Emacs was enough. :-)
Comment 6 Ngo Than 2005-08-22 04:39:19 EDT
*** Bug 166411 has been marked as a duplicate of this bug. ***
Comment 7 Ngo Than 2005-08-22 12:02:29 EDT
*** Bug 166500 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.