Bug 1660851 - Disable NUMA live migration by default
Summary: Disable NUMA live migration by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 15.0 (Stein)
Assignee: Stephen Finucane
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks: 1660852 1660853 1660869 1660870 1660872 1707808 1775181 1805828
TreeView+ depends on / blocked
 
Reported: 2018-12-19 11:39 UTC by Stephen Finucane
Modified: 2020-02-21 15:46 UTC (History)
7 users (show)

Fixed In Version: openstack-nova-19.0.1-0.20190421200346.2888bc6.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1660852 1660869 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:19:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1289064 None None None 2018-12-19 11:39:34 UTC
OpenStack gerrit 611088 'None' 'MERGED' 'Fail to live migration if instance has a NUMA topology' 2019-11-21 09:09:37 UTC
Red Hat Product Errata RHEA-2019:2811 None None None 2019-09-21 11:20:11 UTC

Description Stephen Finucane 2018-12-19 11:39:35 UTC
Description of problem:
As noted in bug 1222414, nova does not currently support live migration of instances with NUMA topologies. The CPU and memory mapping information is not recalculated for the destination host, meaning the instance can fail to boot on a destination host with less cores/hugepages than the source or, worse, actually boot but consume resources dedicated to an existing instance.

The long term fix for this is to properly enable live migration for these instances. However, we're seeing issues with this in older versions (and every future version until that feature lands) and the fix won't be backportable to these. In addition, the previous downstream-only workaround for this, seen in bug 1585068 and related bugs, has proven problematic and is not something we want to continue to invest in. As such, we need an upstream-first approach to resolving this issue that can be backported to older versions. The easiest way to do this is to disable live migration of NUMA-based instances by default, providing a workaround flag for users who insist on being able to live migrate even with the issues seen. That is what we've done, and this bug tracks the progress in supporting that downstream.

Version-Release number of selected component (if applicable):
All supported versions of OSP.

How reproducible:
See bug 1222414.

Steps to Reproduce:
See bug 1222414.

Actual results:
See bug 1222414.

Expected results:
See bug 1222414.

Additional info:

Comment 5 errata-xmlrpc 2019-09-21 11:19:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.