Bug 166153 - "External Amplifier" is off by default / eadphone Jack Sense issue
"External Amplifier" is off by default / eadphone Jack Sense issue
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Reopened
: 166969 175871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 11:38 EDT by Marius Andreiana
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 10:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aplay -l (324 bytes, text/plain)
2005-08-17 11:38 EDT, Marius Andreiana
no flags Details
amixer when sound works (4.88 KB, text/plain)
2005-08-17 11:40 EDT, Marius Andreiana
no flags Details
amixer when sound on speakers is mute (4.88 KB, text/plain)
2005-08-17 11:40 EDT, Marius Andreiana
no flags Details
lsmod (2.22 KB, text/plain)
2005-08-17 11:41 EDT, Marius Andreiana
no flags Details
lspci -vv (9.98 KB, text/plain)
2005-08-17 11:41 EDT, Marius Andreiana
no flags Details

  None (edit)
Description Marius Andreiana 2005-08-17 11:38:43 EDT
This is a followup from bug #144742

"External Amplifier" is off by default, and this causes my laptop speaker to be
off no matter what the volume sliders are. With headphones it works.

Expected results:
By default, "External Amplifier" should be on.


Additional info: Attached
Comment 1 Marius Andreiana 2005-08-17 11:38:44 EDT
Created attachment 117836 [details]
aplay -l
Comment 2 Marius Andreiana 2005-08-17 11:40:06 EDT
Created attachment 117837 [details]
amixer when sound works
Comment 3 Marius Andreiana 2005-08-17 11:40:32 EDT
Created attachment 117838 [details]
amixer when sound on speakers is mute
Comment 4 Marius Andreiana 2005-08-17 11:41:25 EDT
Created attachment 117839 [details]
lsmod

# cat /etc/modprobe.conf
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
Comment 5 Marius Andreiana 2005-08-17 11:41:45 EDT
Created attachment 117840 [details]
lspci -vv
Comment 6 Marius Andreiana 2005-08-17 11:42:49 EDT
I don't have "Headphone Jack Sense" in alsamixer as other people reported in
#144742, but it shouldn't be mute too.
Comment 7 Martin Stransky 2005-08-23 10:28:53 EDT
External Amplifier was unmuted in rawhide. If anybody need to unmute the
"Headphone Jack Sense", please reopen this report.
Comment 8 Martin Stransky 2005-08-29 06:11:49 EDT
*** Bug 166969 has been marked as a duplicate of this bug. ***
Comment 9 Martin Stransky 2005-12-19 05:17:32 EST
*** Bug 175871 has been marked as a duplicate of this bug. ***
Comment 10 Pekka Savola 2006-10-13 13:49:33 EDT
Shifting the version from fc4 to fc5..

Could you clarify what you mean by "unmute Headphone Jack Sense" ? (In
particular, what "unmute" means in this context -- I wasn't able to figure out
which setting is "mute" and which is "unmute"..)

I have FC5 with kernel-2.6.18-1.2189.fc5 on Thinkpad X31, with:

00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio
Controller (rev 02)

.. and couldn't get sound to work with aplay, etc.  I even upgraded alsa to
1.0.13 and no luck.  The only thing that worked was pcspkr (beeps etc.).  The
result was the same whether internal or external speakers were connected or not.

When I turned off "Headphone Jack Sense", both internal and external speakers
started working.

Maybe this means that at least in some cases "Headphone Jack Sense" is not
configured correctly?
Comment 11 Martin Stransky 2007-05-22 10:24:44 EDT
"Headphone Jack Sense" is turned off by default in fc-6/rawhide so it should
work there.

Note You need to log in before you can comment on or make changes to this bug.