Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1661681 - Kernels since 4.19.9-300 fail to boot with amdgpu AMD Radeon RX 500 series graphics cards
Summary: Kernels since 4.19.9-300 fail to boot with amdgpu AMD Radeon RX 500 series gr...
Keywords:
Status: CLOSED DUPLICATE of bug 1659810
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-22 03:49 UTC by Robb Romans
Modified: 2019-01-07 20:06 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-07 20:06:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Robb Romans 2018-12-22 03:49:17 UTC
Description of problem:

Since updating to kernel 4.19.9-300, Fedora 29, system hangs on boot with AMD Arctic Islands / Polaris11 series graphics cards. Also applies to kernel 4.19.10-300.


Version-Release number of selected component (if applicable):

linux-firmware-20181008-88.gitc6b6265d.fc29.noarch


Steps to Reproduce:
1. x86_64 system, open source amdgpu graphics drivers
2. Radeon RX 500 series card (RX 560 in this case) and similar
3. Fedora 29, kernel >= 4.19.9-300
4. Boot system

Actual results:
System hangs on boot when switching to amdgpudrm framebuffer on this line:
fb0: amdgpudrmfb frame buffer device

Expected results:
System continues boot


Additional info:
When booting with modprobe.blacklist=amdgpu, dmesg shows the actual error to be a missing file in /lib/firmware/amdgpu:
polaris11_k_mc.bin

How to fix:

Copy this file 
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/amdgpu/polaris11_k_mc.bin
to /lib/firmware/amdgpu

Therefore, this file needs to be included in an updated linux-firmware package and the kernel initramfs.

Result: System boots normally.

Thanks!

Comment 1 Steve 2018-12-22 21:49:24 UTC
(In reply to Robb Romans from comment #0)
...
> Additional info:
> When booting with modprobe.blacklist=amdgpu, dmesg shows the actual error to
> be a missing file in /lib/firmware/amdgpu:
> polaris11_k_mc.bin
...

That is:

Bug 1661024 - 4.19.8-300.fc29.x86_64 -> 4.19.9-300.fc29.x86_64 update results in black screen (missing GPU firmware) 

You appear to have already worked around the problem, but for the record:

There is a linux-firmware update available:

# dnf update linux-firmware --enablerepo=updates-testing

The initramfs needs to be rebuilt too:

# dracut --kver 4.19.9-300.fc29.x86_64 --force  # similarly for 4.19.10-300

See, also:

bugfix update in Fedora 29 for linux-firmware 
https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

Comment 2 tkil 2018-12-24 05:30:16 UTC
Fix in comment 1 worked for me, thanks!
(Do we want to close this one as a duplicate of bug 1661024?)

Comment 3 Ben Beasley 2019-01-01 16:06:04 UTC
Fix in comment 1 worked for me also. Since linux-firmware-20181219-89.git0f22c852.fc29 was already in updates, I just had to run the mentioned dracut command.

Comment 4 Jeremy Cline 2019-01-07 20:06:23 UTC

*** This bug has been marked as a duplicate of bug 1659810 ***


Note You need to log in before you can comment on or make changes to this bug.