Bug 1662047 - [UI] 2 dashboard icons after upgrade
Summary: [UI] 2 dashboard icons after upgrade
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-ui-extensions   
(Show other bugs)
Version: 4.3.0
Hardware: Unspecified Unspecified
unspecified
medium
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Greg Sheremeta
QA Contact: Lukas Svaty
URL:
Whiteboard:
Keywords: Regression
: 1665430 1672254 1677266 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-25 15:04 UTC by Liran Rotenberg
Modified: 2019-02-15 21:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-02-05 13:10:15 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (18.50 KB, image/png)
2018-12-25 15:04 UTC, Liran Rotenberg
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 97561 master MERGED ovirt-engine-ui-extensions 1.0.3 2019-02-05 11:13 UTC
oVirt gerrit 97562 master MERGED spec: require ovirt-engine-ui-extensions >= 1.0.3 2019-02-05 15:10 UTC

Description Liran Rotenberg 2018-12-25 15:04:51 UTC
Created attachment 1516663 [details]
screenshot

Description of problem:
There are 2 dashboard icons in the left pane.
This is happened to me after upgrading the engine from 4.2.8 to 4.3.
Starting point was ovirt-engine-4.2.8.1-0.1.el7ev.noarch.

Version-Release number of selected component (if applicable):
# yum list ovirt-engine{,-webadmin-portal,-dashboard,-ui-extensions}
Loaded plugins: search-disabled-repos, versionlock
Installed Packages
ovirt-engine.noarch                                             4.3.0-0.6.alpha2.el7                @rhv-4.3.0
ovirt-engine-dashboard.noarch                                   1.2.4-1.el7ev                       installed 
ovirt-engine-ui-extensions.noarch                               1.0.1-0.20181015git084f380.el7ev    @rhv-4.3.0
ovirt-engine-webadmin-portal.noarch                             4.3.0-0.6.alpha2.el7                @rhv-4.3.0

# ls /usr/share/ovirt-engine/ui-plugins | grep "\.json$"
dashboard.json
rhvm-doc-plugin.json
ui-extensions.json


How reproducible:
I saw it once, didn't try to reproduce.

Steps to Reproduce:
1. Deploy 4.2.8.
2. Upgrade engine to 4.3.

Actual results:
Two dashboards in the left pane.

Expected results:
One dashboard in the left pane.

Additional info:
Related bug: https://bugzilla.redhat.com/show_bug.cgi?id=1616318

Comment 3 Greg Sheremeta 2019-01-09 12:44:44 UTC
This should have been removed on upgrade.

ovirt-engine-dashboard.noarch                                   1.2.4-1.el7ev                       installed 

@Sandro, any idea?

Comment 4 Greg Sheremeta 2019-01-09 17:30:10 UTC
[This was also previously reported as 1616318 – 2 dashboard icons exist https://bugzilla.redhat.com/show_bug.cgi?id=1616318
but not sure if this is something new, i.e. a genuine upgrade issue vs. a developer environment issue]

Comment 5 Sandro Bonazzola 2019-01-28 13:56:47 UTC
not blocking oVirt 4.3.0

Comment 7 Greg Sheremeta 2019-01-30 01:55:05 UTC
workaround is simply uninstall ovirt-engine-dashboard

Comment 8 Sandro Bonazzola 2019-01-30 07:21:38 UTC
(In reply to Greg Sheremeta from comment #3)
> This should have been removed on upgrade.
> 
> ovirt-engine-dashboard.noarch                                  
> 1.2.4-1.el7ev                       installed 
> 
> @Sandro, any idea?

Looking at the code:

Obsoletes: ovirt-engine-dashboard <= 1.2
Provides: ovirt-engine-dashboard

while here 1.2.4 is installed and 1.2.4 is > than 1.2

I would change above with:
Obsoletes: ovirt-engine-dashboard < 1.3
Provides: ovirt-engine-dashboard = 1.3

Comment 9 Greg Sheremeta 2019-01-30 07:42:56 UTC
ovirt-engine-dashboard 1.3 doesn't exist -- confirming that that's ok?
(Do we even need the Provides?)

Comment 10 Sandro Bonazzola 2019-01-30 07:47:30 UTC
(In reply to Greg Sheremeta from comment #9)
> ovirt-engine-dashboard 1.3 doesn't exist -- confirming that that's ok?
> (Do we even need the Provides?)

We need the provides if the package provide same functionalities, if not it's ok to just use obsoletes. In this case:

Obsoletes: ovirt-engine-dashboard

should be enough.

Comment 11 Sergey 2019-02-04 15:14:43 UTC
same behavior when upgrading from 4.2.8 to 4.3.0 GA on our test environment.
removing ovirt-engine-dashboard helps.

Comment 12 Greg Sheremeta 2019-02-04 15:24:32 UTC
(In reply to Sergey from comment #11)
> same behavior when upgrading from 4.2.8 to 4.3.0 GA on our test environment.
> removing ovirt-engine-dashboard helps.

Indeed, simply removing ovirt-engine-dashboard is the workaround until I fix the spec.

Comment 13 Sergey 2019-02-05 09:23:06 UTC
Haven't noticed, that it was delayed until 4.3.1
maybe this should be mentioned in "Known Issues" section of Release Notes?
Looks like every update before 4.3.1 announcement will hit this bug.

Comment 14 Greg Sheremeta 2019-02-05 10:10:41 UTC
(In reply to Sergey from comment #13)
> Haven't noticed, that it was delayed until 4.3.1
> maybe this should be mentioned in "Known Issues" section of Release Notes?
> Looks like every update before 4.3.1 announcement will hit this bug.

It'll be async'd out, probably today. Thanks!

Comment 15 Greg Sheremeta 2019-02-05 11:03:12 UTC
*** Bug 1672254 has been marked as a duplicate of this bug. ***

Comment 16 Greg Sheremeta 2019-02-05 11:04:32 UTC
*** Bug 1665430 has been marked as a duplicate of this bug. ***

Comment 17 Greg Sheremeta 2019-02-05 13:10:15 UTC
ovirt-engine-ui-extensions 1.0.3 is now in the repo. New upgrades of standalone engine are fixed. Hosted engine upgrades require a yum update.

Comment 18 Greg Sheremeta 2019-02-06 11:55:42 UTC
(In reply to Greg Sheremeta from comment #17)
> ovirt-engine-ui-extensions 1.0.3 is now in the repo. New upgrades of
> standalone engine are fixed. Hosted engine upgrades require a yum update.

Actually, that was incorrect. New standalone engine upgrades will catch the fix. New hosted engine upgrades will catch the fix. If you updated to either to 4.3.0 on day 1, 'yum update' and 'engine-setup' to get the fix.

Comment 19 Greg Sheremeta 2019-02-15 21:33:46 UTC
*** Bug 1677266 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.