Bug 166450 - create own mpfr rpm conflicts with gmp
create own mpfr rpm conflicts with gmp
Status: CLOSED DUPLICATE of bug 211762
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On: 199550
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-21 15:08 EDT by Jochen Schmitt
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 07:44:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2005-08-21 15:08:56 EDT
Becouse I plan the inclussion of abakus to Fedora Extras I have create
a own rpm file of mpfr-2.1.2. Unfortunately, gmp contains an ancient version
of mpfr, which coused a comflict, when I try to install the create mpfr rpm.

The version of mpfr included in gpm is useless for me, becouse abakus requires a
more recent version of mpfr.

Suggested Solution:
Set --disable-mpfr in the SPEC file of gmp.

Best Regards:

Jochen Schmitt
Comment 1 Thomas Woerner 2005-11-11 11:26:29 EST
Where exactly is the conflict?
Comment 2 Marcin Garski 2006-06-01 17:01:20 EDT
This issue will somehow be resolved when you update in future package from 4.1.4
version to currently 4.2.1. When we look into the NEWS file, we can read:

Changes between GMP version 4.1.4 and 4.2
* mpfr is gone, and will from now on be released only separately. Please see
www.mpfr.org.

When you do it, they won't be conflict betwen gmp and abakus.
Comment 3 Laurent Rineau 2006-08-07 10:59:48 EDT
I have done myself a package for GMP. The conflicts are:

        file /usr/include/mpf2mpfr.h from install of mpfr-devel-2.2.0-2.fc5 
conflicts with file from package gmp-devel-4.1.4-6
        file /usr/include/mpfr.h from install of mpfr-devel-2.2.0-2.fc5 
conflicts with file from package gmp-devel-4.1.4-6
        file /usr/share/info/mpfr.info.gz from install of 
mpfr-devel-2.2.0-2.fc5 conflicts with file from package gmp-devel-4.1.4-6
        file /usr/include/mpf2mpfr.h from install of mpfr-devel-2.2.0-2.fc5 
conflicts with file from package gmp-devel-4.1.4-6.2.1
        file /usr/include/mpfr.h from install of mpfr-devel-2.2.0-2.fc5 
conflicts with file from package gmp-devel-4.1.4-6.2.1
        file /usr/share/info/mpfr.info.gz from install of 
mpfr-devel-2.2.0-2.fc5 conflicts with file from package gmp-devel-4.1.4-6.2.1
Comment 4 Laurent Rineau 2006-08-07 11:02:00 EDT
Sorry for having changed the status to ASSIGNED. I will revert that. Sorry for 
the two extras messages.
Comment 5 Laurent Rineau 2006-08-07 11:16:37 EDT
It would be nice that this bug is fixed soon. I would like to package 
CGAL_python, but it requires shared libraries of mpfr (to dlopen stuffs), that 
cannot be packaged separately because of the current bug.
Comment 6 FX 2006-10-20 05:26:57 EDT
As I said in bug 199550: GCC-4.3 will require MPFR >= 2.2.0, so this will have
to get fixed.
Comment 7 Laurent Rineau 2006-12-01 10:39:09 EST
Actually, the gmp package ships mpfr-2.2.0+patches, since 4.1.4-8.

See related bugs: bug #211762 and bug #218041.

Jochen, does the current version of gmp, in FC-6 and FC-devel fits your needs?
Comment 8 Jochen Schmitt 2006-12-03 14:12:45 EST
Yes
Comment 9 Laurent Rineau 2006-12-04 07:44:00 EST
Well, this bug is actually a dup of bug #211762, where the same subjects are 
discussed:
  - upgrade of mpfr shipped in gmp,
  - or split of mpfr and gmp.


*** This bug has been marked as a duplicate of 211762 ***

Note You need to log in before you can comment on or make changes to this bug.