Bug 166627 - Evolution does not connect to exchange server correctly using x86_64 version
Evolution does not connect to exchange server correctly using x86_64 version
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-connector (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
Depends On: 174536
Blocks: 168429
  Show dependency treegraph
Reported: 2005-08-23 20:22 EDT by keithu@parl.clemson.edu
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0003
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-07 12:00:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Debugging output from evolution and exchange storage component (4.01 KB, text/plain)
2005-08-23 20:24 EDT, keithu@parl.clemson.edu
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 270323 None None None Never

  None (edit)
Description keithu@parl.clemson.edu 2005-08-23 20:22:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
Using Evolution to connect to an exchange server simply will not work ;-)

I have two (virtually) identical installs of RHEL4-WS update 1.  One is an i386 install an Evolution connects to exchange beautifully.  One is an x86_64 install and Evolution fails to authenticate when connecting to the exchange server.  

Version-Release number of selected component (if applicable):
evolution-2.0.2-16.x64_64.rpm, evolution-connector-2.0.2-5.x86_64.rpm, evolution-data-server-1.0.2-7.x86_64.rpm

How reproducible:

Steps to Reproduce:
1. Install RHEL4-WS on an x86_64 platform
2. Attempt to connect to an exchange server
3. fail

Actual Results:  A "could not authenticate to server. (Passowrd incorrect?)" error dialog appeared.

Expected Results:  I should have had access to exchange...

Additional info:

I flagged this as high because it is a showstopper for my migration to RHEL4.  I noticed that the evolution owner likes debug output, so I ran the debug steps requested in other emails and will attach the output.
Comment 1 keithu@parl.clemson.edu 2005-08-23 20:24:04 EDT
Created attachment 118033 [details]
Debugging output from evolution and exchange storage component
Comment 2 Dave Malcolm 2005-08-23 20:47:47 EDT
Thanks for this report, and for the debug output you attached.

What versions of libsoup are installed (on both machines)?

Are the evolution accounts on both machines configured in exactly the same way?
 The settings are stored in GConf, so if the home directory is shared between
machines they will be.  Otherwise, please ensure that the x86_64 machine's
configuration matches that of the working i386 machine.

It may help if you could run this command:
"gconftool-2 --dump /apps/evolution/mail > mail-settings.xml" on both machines
and attach the results to this bug (named appropriately).  Note that these will
contain your account settings and would be visible in bugzilla.

In addition, please can you follow the same steps you used for x86_64 to
generate debug output for the working i386 box; this will help in tracking down
the details of the Exchange setup.   You may want to review the output and
truncate it, since after correctly authenticating it may contain your data (such
as the names of your mail folders).

Even better would be a full "tcpdump -s0" of all traffic during authentication
between client and server, taken on both the working and non-working clients,
though you may wish to provide this independently of bugzilla, since it will
probably contain security-sensitive data.

Comment 3 keithu@parl.clemson.edu 2005-08-23 21:13:18 EDT
Don't ask for much, do ya? ;-)

Yes, the configs are identical.  Or, at least, they are identical for practical
purposes.  I can't possibly send you relevant parts of the mail-settings or the
tcpdump.  Security would kill me.  I am emailing the relevant debug output from
the working box (from a different email address than on my bugzilla account).  I
trimmed it right after the login exchange.

libsoup-2.2.1-1 on both.  These are identical installs - I did one yesterday and
one today and have run the same updates against them.

Of course, the x86_64 box has both the x86_64 and i386 libsoup installed.
Comment 4 keithu@parl.clemson.edu 2005-08-31 18:12:59 EDT
So, out of curiosity, is there any sane way to go up to evolution-2.2 and
associated on a RHEL4 box to try it out?  I'm kind of willing to re-install the
box afterward if necessary.  That is, if that is a path that might get me to a
working condition sooner ;-)
Comment 5 Dave Malcolm 2005-09-01 13:28:36 EDT
Thanks for your feedback.  It looks like you're running into a 64-bit
cleanliness bug in the NTLM authentication code that was tracked by upstream here:

It appears to still affect the RHEL-4 libsoup and evolution-connector packages.

I'll roll you some test packages containing the fixes for that bug, since
comment #4 suggests to me that you'd consider trying them; they would be for
Evolution 2.0, rather than 2.2.  (They won't be "officially supported" at this
stage, though)
Comment 7 Dave Malcolm 2005-09-01 14:56:54 EDT
I've built test packages for x86_64 RHEL4 with the fixes for that bug and
uploaded them here:

Please install both packages.  Do they fix the authentication problem you've
been seeing?
Comment 8 keithu@parl.clemson.edu 2005-09-02 12:26:55 EDT
Just installed them and the authentication issue seems to be fixed.  Thanks! 

Since this was the only thing standing between me and a workstation with dual
24" flat panel displays, you can imagine how happy I am to get the fix ;-)
Comment 9 Dave Malcolm 2005-09-02 13:33:05 EDT
Excellent - thanks for the feedback.
Comment 18 Red Hat Bugzilla 2006-03-07 12:00:44 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

Comment 19 Monit Kapoor 2006-09-06 08:03:33 EDT
I am still seeing issues authenticating to our Exchange server's using IMAP 
over SSL and NTLM/SPA.

I upgraded the libsoup libraries as suggested by the errata and i see proper 
authentication only 1 out of 10 tries i attempt to provide my password(Earlier 
it just kept failing).

POP does not work at all with SSL and NTLM

The above works if i select "plain password" as authentication mechanism.

Following is the list of installed RPM's for evolution and libsoup.

evolution-connector            2.0.2      5          x86_64
evolution-devel                2.0.2      16         x86_64
evolution-data-server-devel    1.0.2      7          x86_64
libsoup                        2.2.1      4          x86_64
evolution-webcal               1.0.10     1          x86_64
evolution                      2.0.2      16         x86_64
libsoup-devel                  2.2.1      4          x86_64
libsoup                        2.2.1      4          i386
evolution-data-server          1.0.2      7          x86_64
evolution-data-server          1.0.2      7          i386
Comment 20 Dave Malcolm 2006-09-06 12:19:06 EDT
mkapoor: Thanks for adding this information.

We discovered another 64-bit issue with the connector in bug 175640, which was
fixed in http://rhn.redhat.com/errata/RHBA-2006-0483.html with

You may want to try upgrading to this version and see if it helps.  If you still
run into problems, please contact Red Hat Support and we'll take things onwards
from there.  See https://www.redhat.com/apps/support/

I hope this helps.

Comment 21 Monit Kapoor 2006-09-06 15:14:40 EDT
Hi Dave,

Yes, i have even tried upgrading to all evolution and libsoup packages made 
available from RHEL4 Update 4. Doing so also does not resolve the issue.

I am also seeing this on RHEL3 Update 7 running on x86_64

I opened a NEW bug (205362) for this issue.



Note You need to log in before you can comment on or make changes to this bug.