Bug 167435 - Eclipse ant plugin is at version 1.6.5 but libraries link to 1.6.2
Eclipse ant plugin is at version 1.6.5 but libraries link to 1.6.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 12:26 EDT by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 11:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2005-09-02 12:26:21 EDT
Description of problem:
eclipse 3.1 ships with a plugin for ant at 1.6.5.  However, after some
investigation I realize that all the libraries in this plugin symlink over to
/usr/share/java/ant which is part of the ant-1.6.2-3jpp_14fc package. Ant 1.6.2
contains bugs (bug 167431) that cause problems with user defined ant tasks.

It would be nice if the ant version the plugin claims to be was really the ant
version that was run.  I see the advantage of having eclipse use the rpm ant. I
would perfer that both the native ant was at 1.6.5 (bug 167431) that way
fedora's eclipse wouldn't have a backrev'ed ant compared to the released eclipse
version.  Alternativly or perhaps additionally, the ant version the system and
eclipse uses could be under the alternatives system (bug 167432) so that the
system administrator could install alternative versions that eclipse would obey.



Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-12

How reproducible:
always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The work around is to intall a newer version of ant and set the ant home in the
windows-preferences-ant-runtime to it.
Comment 1 Andrew Overholt 2005-09-13 11:03:47 EDT
Interesting idea.

In the mean time, I don't want to un-symlink-ify (nice English) the ant jars
within Eclipse 'cause I'm happy that we've gotten it to where it is now with no
symlinks.

I'm going to CC myself on the other bug but close this one since it directly
relates to the system ant (which I believe Vadim/Gary is planning on updating RSN).

Note You need to log in before you can comment on or make changes to this bug.