Bug 167541 - megaraid device driver does not properly load during install
megaraid device driver does not properly load during install
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2005-09-04 18:54 EDT by Kenneth Porter
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-19 04:04:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Porter 2005-09-04 18:54:29 EDT
Note that a similar bug against FC3 is reported in bug 149279 and in bug 135484.

I'm attempting to update a system running FC2 with a LSI IDE RAID controller to
FC4 final and the megaraid driver is not loaded. I've attempted to run "linux
rescue" and load the driver manually, copied from a running FC4 system. modprobe
and insmod complete with no message but lsmod shows no megaraid driver loaded. I
also tried to rmmod the newer megaraid_mm/megaraid_mbox (which does remove them)
but this doesn't appear to affect the result.

I'm booting from CD using askmethod so that I can mount the downloaded DVD image
from my RAID array but the array isn't recognized so I'm stuck at that point. I
used the rescue mode to see if I can get the array recognized by manually
loading the driver, and that fails, so I don't want to update from another FC4
box by HTTP and discover my array still inaccessible. I want to make sure I can
still access it after the upgrade.

The system's boot drive is regular IDE, not part of the array.

Let me know what /proc info you need to identify the hardware in question and
I'll attach that. Under FC2 it's mounted as /dev/sda1. /etc/modprobe.conf shows
"alias scsi_hostadapter megaraid".
Comment 1 Kenneth Porter 2005-09-08 02:52:26 EDT
The PCI info reported for my card:

[ken@newred pci]$ grep raid /proc/bus/pci/devices
0048    101e1960        b       e3100008        00000000        00000000       
00000000        00000000        00000000        00000000        00010000
00000000 00000000        00000000        00000000        00000000       
00008000        megaraid

Some possible workarounds listed here:

http://www.centos.org/modules/newbb/viewtopic.php?post_id=3419&topic_id=479
Comment 2 Kenneth Porter 2005-09-08 03:04:03 EDT
The same data in more useful form (now that I remember the lspci command):

[ken@newred pci]$ lspci -s 00:09.0 -v -x
00:09.0 RAID bus controller: American Megatrends Inc. MegaRAID (rev 02)
        Subsystem: American Megatrends Inc. MegaRAID 511 i4 IDE RAID Controller
        Flags: bus master, medium devsel, latency 32, IRQ 11
        Memory at e3100000 (32-bit, prefetchable)
        Capabilities: <available only to root>
00: 1e 10 60 19 06 00 90 02 02 00 04 01 08 20 00 00
10: 08 00 10 e3 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 1e 10 11 05
30: 00 00 00 00 80 00 00 00 00 00 00 00 0b 01 00 00

I'm guessing that the newer megaraid driver is too agressive about matching PCI
ID's.
Comment 3 Kenneth Porter 2005-09-08 04:43:58 EDT
Looks like the newer driver supports the "i4 522" but not the "i4 511".
Comment 4 Kenneth Porter 2005-09-08 19:30:09 EDT
I checked the megaraid_mbox source code and then asked on the linux-scsi list
and Gerry Smith of LSI (current owner of the megaraid driver) replies that
simply plugging in a PCI device record with the subdevice code for my card
should work, as the card otherwise looks to software identical to its SCSI
counterpart. I'll generate a patch and report on how that works out.

http://marc.theaimsgroup.com/?l=linux-scsi&m=112618430317260&w=2
Comment 5 Tom Coughlan 2005-09-09 08:25:43 EDT
Ohay, thanks for checking that out. If it works, then we will work with LSI to
get it in the mainstream driver, and patch FC in the meantime. 

Tom
Comment 6 Dave Jones 2005-11-10 14:34:43 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 7 Dave Jones 2005-11-19 04:04:59 EST
Due to the overhead involved in creating new ISOs (which is what would be
required for fixing bugs seen at installation time that don't have workarounds),
this bug has been closed.

For more information and suggestions, please see bug 169613

Thanks.

Note You need to log in before you can comment on or make changes to this bug.