Bug 1677379 - Changes/MongoDB Removal
Summary: Changes/MongoDB Removal
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Patrik Novotný
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 1675719 1687591 1687592 1700073
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-14 16:44 UTC by Ben Cotton
Modified: 2019-04-30 15:49 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-30 15:49:40 UTC


Attachments (Terms of Use)

Description Ben Cotton 2019-02-14 16:44:09 UTC
This is a tracking bug for Change: Changes/MongoDB Removal
For more details, see: https://fedoraproject.org/wiki/Changes/MongoDB_Removal

Fedora has determined that the Server Side Public Licensev1 (SSPL) is not a Free Software License. Therefore, we need to drop MongoDB from Fedora or never update it again. Never updating it would bring security issues, hence we decided to remove it.

Comment 1 Ben Cotton 2019-02-19 20:30:25 UTC
According to the Fedora 30 schedule[1], today is the deadline for changes to be in a testable state. If your change is ready to be tested, please set the status to MODIFIED. If you know your change will not be ready for Fedora 30, you can set the version to rawhide and notify bcotton@fedoraproject.org. For more information about this milestone, see the Changes Policy[2].

[1] https://fedoraproject.org/wiki/Releases/30/Schedule
[2] https://fedoraproject.org/wiki/Changes/Policy#Change_Checkpoint:_Completion_deadline

Comment 2 Patrik Novotný 2019-02-20 14:47:59 UTC
Should be ready to be tested.

Comment 3 Miro Hrončok 2019-02-27 20:07:40 UTC
I'm fixing python-beaker FTBFS (skipping mongo tests).

Comment 4 Ben Cotton 2019-03-05 21:50:03 UTC
We have reached the Code Complete (100%) milestone in the Fedora 30 development cycle. At this point, all Changes should be fully code complete and ready for testing during the beta freeze. If your Change has reached this milestone, please set the status to ON_QA. If it has not, this Change will be submitted to FESCo to evaluate the contigency plan and decide if the Change will continue in the Fedora 30 cycle.

Comment 5 Miro Hrončok 2019-03-08 18:14:52 UTC
mongodb was removed already, yet there are still packages that require mongodb-server:

$ dnf repoquery --repo=compose --repo=compose-source  --whatrequires mongodb
$ dnf repoquery --repo=compose --repo=compose-source  --whatrequires mongodb-test
$ dnf repoquery --repo=compose --repo=compose-source  --whatrequires mongodb-server
fawkes-devenv-0:1.0.1-18.fc29.x86_64
mongo-tools-0:4.0.4-4.20181124git0f0d866.fc30.src

That is on rawhide. For F30, I may have old data:

$ dnf repoquery --repo=fedora --repo=fedora-source --repo=updates --repo=updates-testing --releasever 30  --whatrequires mongodb-test
$ dnf repoquery --repo=fedora --repo=fedora-source --repo=updates --repo=updates-testing --releasever 30  --whatrequires mongodb-server
fawkes-devenv-0:1.0.1-18.fc29.x86_64
mongo-tools-0:4.0.4-4.20181124git0f0d866.fc30.src
rubygem-database_cleaner-0:1.6.1-3.fc29.src
$ dnf repoquery --repo=fedora --repo=fedora-source --repo=updates --repo=updates-testing --releasever 30  --whatrequires mongodb

Comment 6 Ben Cotton 2019-03-18 20:59:27 UTC
FESCo agreed the Change is implemented, but some dependencies on removed packages remain. Those should be treated as bugs and resolved in the usual fashion.

Setting the status to ON_QA and clearing the needinfo flag.

Comment 7 Miro Hrončok 2019-04-07 17:21:17 UTC
Upgrading from Fedora 29 to Fedora 30 with mongodb-server installed:

  Problem 8: problem with installed package mongodb-server-4.0.3-3.fc29.x86_64
   - package mongodb-server-4.0.3-3.fc30.x86_64 requires libboost_filesystem.so.1.66.0()(64bit), but none of the providers can be installed
   - mongodb-server-4.0.3-3.fc29.x86_64 does not belong to a distupgrade repository
   - boost-filesystem-1.66.0-14.fc29.x86_64 does not belong to a distupgrade repository

I believe you need to obsolete the removed packages from fedora-obsolete-packages to ensure a clean upgrade path.

Comment 8 Kostya Vasilyev 2019-04-11 07:16:47 UTC
On F30 the repositories still contain:

mongodb-4.0.3-3.fc30.x86_64
mongodb-server-4.0.3-3.fc30.x86_64
mongodb-test-4.0.3-3.fc30.x86_64

Package mongodb cannot be installed due to broken versions of Boost dependencies, but that's beside the point ...

... the point being, if it's removed then it's removed and should not be in the repositories?

Comment 9 Miro Hrončok 2019-04-11 09:01:33 UTC
You are correct:

mongodb-4.0.3-3.fc30 https://koji.fedoraproject.org/koji/buildinfo?buildID=1170574

still tagged to f30 and f30-beta.

$ dnf repoquery --releasever 30 --repo=fedora --repo=updates{,-testing} mongodb
mongodb-0:4.0.3-3.fc30.x86_64

$ koji list-pkgs  --show-blocked --tag f31 --package mongodb
Package                 Tag                     Extra Arches     Owner          
----------------------- ----------------------- ---------------- ---------------
mongodb                 f31                                      releng          [BLOCKED]


$ koji list-pkgs  --show-blocked --tag f30 --package mongodb
Package                 Tag                     Extra Arches     Owner          
----------------------- ----------------------- ---------------- ---------------
mongodb                 f30                                      releng

Comment 10 Kostya Vasilyev 2019-04-11 10:23:50 UTC
Miro, sorry are you saying Mongo will not be removed from F30? Or will be removed but it's not done yet?

It it stays in F30 - then perhaps the install errors (dependency on wrong Boost lib version) should be fixed?

Comment 11 Miro Hrončok 2019-04-11 10:33:52 UTC
According to this change proposal it should be removed.
In reality, it is not. This is a bug.
I'd like the change owner to fix it.

Comment 12 Miro Hrončok 2019-04-15 05:30:30 UTC
mongodb is still not removed, still not obsoleted and still doesn't install.

$ sudo dnf install mongodb-server
Error: 
 Problem: conflicting requests
  - nothing provides libboost_system.so.1.66.0()(64bit) needed by mongodb-server-4.0.3-3.fc30.x86_64
  - nothing provides libboost_filesystem.so.1.66.0()(64bit) needed by mongodb-server-4.0.3-3.fc30.x86_64
  - nothing provides libboost_program_options.so.1.66.0()(64bit) needed by mongodb-server-4.0.3-3.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)


Patrik? I also propose a freeze exception for this, given the date.

Comment 13 Miro Hrončok 2019-04-15 05:54:53 UTC
Setting back to MODIFIED.

Comment 14 Kevin Fenzi 2019-04-15 18:31:40 UTC
This package was not properly retired in f30. It may have been due to a infrastructure outage or something similar. 

We have now manually marked it eol in pdc and blocked it in koji. 

Additionally, I filed https://bugzilla.redhat.com/show_bug.cgi?id=1700073 to add it to fedora-obsolete-packages, then did so.

We will need it to get into stable either before freeze or with a FE for it to make it for f30.

Comment 15 Geoffrey Marr 2019-04-15 21:05:53 UTC
Discussed during the 2019-04-15 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as the package not being properly retired causes problems for upgrades, and may mean a non-free package being kept in the final release package set which we would not want.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-04-15/f30-blocker-review.2019-04-15-16.03.txt

Comment 16 Adam Williamson 2019-04-15 22:06:50 UTC
Transferring FE status to https://bugzilla.redhat.com/show_bug.cgi?id=1700073 , as we don't want conflicts between the Change and Blocker/FE processes.


Note You need to log in before you can comment on or make changes to this bug.