Bug 1685458 - Default image to install ASB/TSB by operator should by downstream
Summary: Default image to install ASB/TSB by operator should by downstream
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Shawn Hurley
QA Contact: Zihan Tang
URL:
Whiteboard:
: 1685417 (view as bug list)
Depends On: 1705319 1705779
Blocks: 1680535 1689787 1689788 1693953 1700483
TreeView+ depends on / blocked
 
Reported: 2019-03-05 09:38 UTC by Zihan Tang
Modified: 2019-06-04 10:45 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:12 UTC

Description Zihan Tang 2019-03-05 09:38:28 UTC
Description of problem:
Using ASB/TSB operator to install ASB, when create CR by default, it should use downstream image by default for customer

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-04-234414
ASB operator: docker.io/automationbroker/automation-broker-operator:v4.0

How reproducible:
always

Steps to Reproduce:
1. create ns openshift-ansible-service-broker
2. install ASB operator by marketplace from UI
3. create automationbroker CR from UI by default

Actual results:
when create default CR from console, the yaml file displayed is:

apiVersion: osb.openshift.io/v1alpha1
kind: AutomationBroker
metadata:
  name: ansible-service-broker
  namespace: openshift-ansible-service-broker
spec:
  createBrokerNamespace: 'false'
  waitForBroker: 'false'

If using this yaml file to create CR, the default asb image is 
docker.io/ansibleplaybookbundle/origin-ansible-service-broker:v4.0

Expected results:
default ASB/TSB image should be downtream and to be released image.

Additional info:
When tesging, we can set 'brokerImage' in CR to use any downstream image, but for customers by default, it should be downstream ones.

Comment 2 Shawn Hurley 2019-03-05 16:17:48 UTC
*** Bug 1685417 has been marked as a duplicate of this bug. ***

Comment 3 Zhang Cheng 2019-03-07 06:38:33 UTC
@Rob Szumski

We (QE) are confusing which registry should be default and which registries can be used when OCP4.0 final release. Could you help to make clear the process or give us some suggestions?
You can reach Shawn Hurley if you hope get more detail info. Thanks.


We already have several bugs are tracing.
https://bugzilla.redhat.com/show_bug.cgi?id=1685417
https://bugzilla.redhat.com/show_bug.cgi?id=1685458
https://bugzilla.redhat.com/show_bug.cgi?id=1680535

Comment 4 Rob Szumski 2019-03-07 16:37:35 UTC
Every Operator that you are testing right now is coming from the community side, as either 1) downstream images don't exist yet or 2) a CSV using the downstream image does not exist yet.

All downstream images for 4.0 will come from:

registry.redhat.io - OCP cluster components, first party Red Hat product Operators
registry.connect.redhat.com - partner Operators that are certified

Comment 6 Shawn Hurley 2019-03-29 20:16:24 UTC
*** Bug 1685417 has been marked as a duplicate of this bug. ***

Comment 14 Mike Fiedler 2019-05-03 00:13:24 UTC
Hit https://bugzilla.redhat.com/show_bug.cgi?id=1705779 while trying to verify.

Comment 16 Zihan Tang 2019-05-06 02:16:05 UTC
I have gone through the workaround, but no access to  https://quay.io/application/redhat-operators-art/, waiting for approval.
$ oc get opsrc
NAME               TYPE          ENDPOINT              REGISTRY               DISPLAYNAME   PUBLISHER   STATUS   MESSAGE                                                        AGE
art-applications   appregistry   https://quay.io/cnr   redhat-operators-art                             Failed   The operator source endpoint returned an empty manifest list   23m

Comment 18 Shawn Hurley 2019-05-07 13:38:23 UTC
PR: https://github.com/openshift/ocp-build-data/pull/113

Comment 20 Zihan Tang 2019-05-08 02:58:30 UTC
In the latest csv in art_applications, the downstream operator image link is not correct.
in csv:
 - name: WATCH_NAMESPACE
                  valueFrom:
                    fieldRef:
                      fieldPath: metadata.namespace
                image: image-registry.openshift-image-registry.svc:5000/openshift/ose-template-service-broker:v4.1.0-201905071832-operator
                imagePullPolicy: IfNotPresent
                name: openshift-template-service-broker-operator
in pod:
$oc get pod -o yaml | grep image
      image: image-registry.openshift-image-registry.svc:5000/openshift/ose-template-service-broker:v4.1.0-201905071832-operator
      imagePullPolicy: IfNotPresent
    imagePullSecrets:
    - image: image-registry.openshift-image-registry.svc:5000/openshift/ose-template-service-broker:v4.1.0-201905071832-operator
      imageID: ""
          message: Back-off pulling image "image-registry.openshift-image-registry.svc:5000/openshift/ose-template-service-broker:v4.1.0-201905071832-operator"



packageRepositioryVersions:
   openshifttemplateservicebroker: 32.0.0

Comment 21 Shawn Hurley 2019-05-08 12:50:41 UTC
PR: https://github.com/openshift/doozer/pull/90

Comment 22 Zihan Tang 2019-05-09 05:35:00 UTC
Verified:

Cluster version is 4.1.0-0.nightly-2019-05-08-131137

ose-template-service-broker-operator:v4.1.0-201905081021
ose-template-service-broker:v4.1.0-201905081021

packageRepositioryVersions:  openshifttemplateservicebroker: 39.0.0

Comment 24 errata-xmlrpc 2019-06-04 10:45:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.