Bug 1689788 - Image pull policy of TSB operator should use 'ifNotPresent'
Summary: Image pull policy of TSB operator should use 'ifNotPresent'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: jkim
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On: 1685417 1685458
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-18 06:35 UTC by Zhang Cheng
Modified: 2019-06-04 10:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:06 UTC

Description Zhang Cheng 2019-03-18 06:35:44 UTC
Description of problem: 
Image pull policy of TSB operator should use 'ifNotPresent' to avoid deploy failed while lost image server, it is using 'Always'.

Refer bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=1686896
https://bugzilla.redhat.com/show_bug.cgi?id=1685232


Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-03-15-063749   True        False         14h       Cluster version is 4.0.0-0.nightly-2019-03-15-063749


How reproducible:
Always


Steps to Reproduce:
$ oc get po template-service-broker-operator-6b9bb48bd5-cpmlc -o yaml | grep -i imagePullPolicy
    imagePullPolicy: Always


Expected results: 
Image pull policy of TSB operator should use 'ifNotPresent'


addition info: 
None.

Comment 1 Shawn Hurley 2019-03-18 14:13:36 UTC
Which version of the CSV was used to install the TSB?

Comment 2 Zhang Cheng 2019-03-19 03:34:15 UTC
$ oc get csv
NAME                                   DISPLAY                            VERSION   REPLACES   PHASE
templateservicebrokeroperator.v0.2.0   Template Service Broker Operator   0.2.0                Succeeded

Comment 5 Zihan Tang 2019-05-10 07:48:57 UTC
Verified.
Cluster version is 4.1.0-0.nightly-2019-05-09-182710
ose-template-service-broker-operator:v4.1.0-201905091832

Comment 7 errata-xmlrpc 2019-06-04 10:46:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.