Bug 168564 - xorg-x11-6.8.2-37.FC4.48.1 breaks Intel 855GM
xorg-x11-6.8.2-37.FC4.48.1 breaks Intel 855GM
Status: CLOSED DUPLICATE of bug 168752
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-17 08:28 EDT by Miloslav Trmač
Modified: 2007-11-30 17:11 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 22:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log from ...48.1 (46.50 KB, text/plain)
2005-09-17 08:28 EDT, Miloslav Trmač
no flags Details
Server log from ...45 (working) (50.50 KB, text/plain)
2005-09-17 08:29 EDT, Miloslav Trmač
no flags Details
Xorg.0.log from broken version of xorg-x11 (50.12 KB, text/plain)
2005-09-17 18:29 EDT, Lonni J Friedman
no flags Details
Diffs from Xorg.0.log 6.8.1 (working) to 6.8.2 (not working) (17.41 KB, text/plain)
2005-09-17 20:39 EDT, Martin
no flags Details

  None (edit)
Description Miloslav Trmač 2005-09-17 08:28:04 EDT
This is likely a duplicate of #168561 and maybe of #168562;
I'm filing this separately because it is easier to close as duplicate
than to separate information.

The X server seems to start, but screen contents are garbage, and it doesn't
react even to Ctrl+Alt+Backspace

Version-Release number of selected component (if applicable):
xorg-x22-6.8.2-37.FC4.48.1
Comment 1 Miloslav Trmač 2005-09-17 08:28:05 EDT
Created attachment 118932 [details]
Server log from ...48.1
Comment 2 Miloslav Trmač 2005-09-17 08:29:00 EDT
Created attachment 118933 [details]
Server log from ...45 (working)
Comment 3 Lonni J Friedman 2005-09-17 18:29:52 EDT
Created attachment 118938 [details]
Xorg.0.log from broken version of xorg-x11
Comment 4 Lonni J Friedman 2005-09-17 18:31:07 EDT
Same problem with i830 video chipset.  In dmesg I see the following carnage:

mtrr: base(0xe8020000) is not aligned on a size(0x300000) boundary
agpgart: pg_start == 0x00000000,intel_i830_private.gtt_entries == 0x000007df
agpgart: Trying to insert into local/stolen memory
Comment 5 Martin 2005-09-17 20:39:52 EDT
Created attachment 118940 [details]
Diffs from Xorg.0.log 6.8.1 (working) to 6.8.2 (not working)

I have the same problem with xorg-x11-6.8.2-1.FC3.45 on FC3 with an
Intel 915 on-board video card.
Comment 6 Patrick Jordan 2005-09-17 20:45:13 EDT
I have the same card(855GM), and same problem.  

Temporarily sidestepped problem by using vesa driver.
Comment 7 imorgan 2005-09-18 01:37:08 EDT
Same problem on FC3 after upgrade from xorg-x11-6.8.2-1.FC3.13 to
xorg-x11-6.8.2-1.FC3.45 w/ 855GME in hp dv1000 notebook. Same failure mode as
reported. Corrupt screen, failure to revert to text-mode.

Xorg.0.log ends with:

(WW) I810(0): Extended BIOS function 0x5f05 failed.
(II) I810(0): xf86BindGARTMemory: bind key 8 at 0x00000000 (pgoffset 0)
(WW) I810(0): xf86BindGARTMemory: binding of gart memory with key 8
        at offset 0x0 failed (Invalid argument)

Fatal server error:
AddScreen/ScreenInit failed for driver 0



Downgrading all xorg packages back to .13 thankfully wasn't too difficult.
Comment 8 Red Ochsenbein 2005-09-18 09:27:09 EDT
Just wanted to drop in a 'same here' on i830 chipset...
Comment 9 Roozbeh Pournader 2005-09-18 10:16:58 EDT
Bug 168622 and bug 168623 are also probably duplicates of this.
Comment 10 Thomas Shepard 2005-09-18 10:17:53 EDT
Intel 845 using i810 driver as well
Comment 11 Stuart Ellis 2005-09-18 10:54:17 EDT
Same problem on a Thinkpad with i855 chipset, after updating FC4 from the
previous Xorg packages. Using the vesa X driver instead of the default i810
driver enables X to run successfully. The error in the log is identical to
comment 7.
Comment 12 Thomas Shepard 2005-09-18 11:42:40 EDT
vesa X driver does not work with Intel 845
Comment 13 Arthur Pemberton 2005-09-18 13:55:59 EDT
Intel i810 on a Presario 2210US running Fedora Core 4. I did a `yum -y update`
last night which consisted mainly of xorg, next reboot failed to display
anything comprehendable. I tried different kernel versions, same thing.
Comment 14 Konstantin Antselovich 2005-09-19 05:03:31 EDT
This thing scared the hell out of me today!
Inter 830M chipset on Fujitsu C7651 laptop
--from Xorg.0.log.old with xorg-x11-6.8.2-37.FC4.48.1--
(II) I810(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(WW) I810(0): Extended BIOS function 0x5f05 failed.
(II) I810(0): xf86BindGARTMemory: bind key 7 at 0x00000000 (pgoffset 0)
(WW) I810(0): xf86BindGARTMemory: binding of gart memory with key 7
        at offset 0x0 failed (Invalid argument)
---end----

<a href="http://konstantin.antselovich.com/downloads/bug168564/Xorg.0.log">Full
working log from xorg-x11-6.8.2-31</a>
<a
href="http://konstantin.antselovich.com/downloads/bug168564/Xorg.0.log.old">Full
X crash log from xorg-x11-6.8.2-37.FC4.48.1</a>
Comment 15 Konstantin Antselovich 2005-09-19 05:18:14 EDT
----
Sep 18 16:41:04 lifebook kernel: mtrr: base(0xe8020000) is not aligned on a
size(0x300000) boundary
Sep 18 16:41:07 lifebook kernel: agpgart: Trying to insert into local/stolen memory
Sep 18 16:41:08 lifebook gdm[3992]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
----
Comment 16 joe 2005-09-19 17:27:50 EDT
Take that damn xorg update down - it has blown up my Dell, HP and Compaq systems.
Comment 17 joe 2005-09-19 17:42:53 EDT
(In reply to comment #16)
> Take that damn xorg update down - it has blown up my Dell, HP and Compaq systems.

I had to boot to single user mode with Grub and change my inittab setting to 3
so it would not boot into X - X is just garbage and it locked up all three
systems so like windoze I could only power off - ctl-alt-F1 would not work and
ctl-alt-backspace would not work, so it was no suprise ctl-alt-delete was also
dead. I will not touch my production boxes until I can get these test boxes working.
Comment 18 James 2005-09-19 18:18:06 EDT
Seen here too. This blew away X on my i855 notebook. Everything apart from the
display worked, so Ctrl+Alt+Del restarted the machine cleanly. Rolled back to
the last updates of packages xorg-x11, xorg-x11-devel, xorg-x11-xfs and
xorg-x11-libs (version 6.8.2-37.FC4.45).
Comment 19 Mike A. Harris 2005-09-19 22:19:32 EDT

*** This bug has been marked as a duplicate of 168752 ***

Note You need to log in before you can comment on or make changes to this bug.