Bug 1688131 - Missing version info for cluster operator openshift-cloud-credential-operator
Summary: Missing version info for cluster operator openshift-cloud-credential-operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Devan Goodwin
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On: 1688122 1688132
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 08:26 UTC by Liang Xia
Modified: 2019-06-04 10:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1688122
Environment:
Last Closed: 2019-06-04 10:45:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:54 UTC

Description Liang Xia 2019-03-13 08:26:56 UTC
+++ This bug was initially created as a clone of Bug #1688122 +++

Description of problem:
Missing version info for clusteroperators console/openshift-authentication/openshift-cloud-credential-operator/service-ca/service-catalog-apiserver/service-catalog-controller-manager

Version-Release number of selected component (if applicable):
4.0.0-0.alpha-2019-03-12-005310

How reproducible:
Always

Steps to Reproduce:
1. $ oc get clusteroperators

Actual results:
$ oc get clusteroperators
NAME                                  VERSION                           AVAILABLE   PROGRESSING   FAILING   SINCE
cluster-autoscaler                    4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
console                                                                 True        False         False     28h
dns                                   4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
image-registry                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
ingress                               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
kube-apiserver                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
kube-controller-manager               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
kube-scheduler                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
machine-api                           4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
machine-config                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     174m
marketplace-operator                  4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
monitoring                            4.0.0-0.alpha-2019-03-12-005310   False       False         True      58m
network                               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
node-tuning                           4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
openshift-apiserver                   4.0.0-0.alpha-2019-03-12-005310   False       False         False     9s
openshift-authentication                                                True        False         False     12s
openshift-cloud-credential-operator                                     True        False         False     28h
openshift-controller-manager          4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
openshift-samples                     4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
operator-lifecycle-manager            0.8.1-25a917e                     True        False         False     28h
service-ca                                                              True        False         False     28h
service-catalog-apiserver                                               True        False         False     28h
service-catalog-controller-manager                                      True        False         False     28h
storage                               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h


Expected results:
All cluster operator should have version info.

Additional info:

--- Additional comment from Liang Xia on 2019-03-13 08:14:52 UTC ---

Split the bug based on https://bugzilla.redhat.com/show_bug.cgi?id=1667360#c5

to ensure that we get real versions into all those operators before we ship.

Comment 1 Liang Xia 2019-03-21 07:21:51 UTC
Verified the issue has been fixed.

$ oc get clusteroperators | grep cloud
openshift-cloud-credential-operator   4.0.0-0.nightly-2019-03-20-153904   True        False         False     3h22m

Comment 3 errata-xmlrpc 2019-06-04 10:45:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.