Bug 1688132 - Missing version info for cluster operator service-ca
Summary: Missing version info for cluster operator service-ca
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On: 1688122
Blocks: 1688131
TreeView+ depends on / blocked
 
Reported: 2019-03-13 08:33 UTC by Liang Xia
Modified: 2019-06-04 10:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1688122
Environment:
Last Closed: 2019-06-04 10:45:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:54 UTC

Description Liang Xia 2019-03-13 08:33:09 UTC
+++ This bug was initially created as a clone of Bug #1688122 +++

Description of problem:
Missing version info for clusteroperators console/openshift-authentication/openshift-cloud-credential-operator/service-ca/service-catalog-apiserver/service-catalog-controller-manager

Version-Release number of selected component (if applicable):
4.0.0-0.alpha-2019-03-12-005310

How reproducible:
Always

Steps to Reproduce:
1. $ oc get clusteroperators

Actual results:
$ oc get clusteroperators
NAME                                  VERSION                           AVAILABLE   PROGRESSING   FAILING   SINCE
cluster-autoscaler                    4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
console                                                                 True        False         False     28h
dns                                   4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
image-registry                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
ingress                               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
kube-apiserver                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
kube-controller-manager               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
kube-scheduler                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
machine-api                           4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
machine-config                        4.0.0-0.alpha-2019-03-12-005310   True        False         False     174m
marketplace-operator                  4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
monitoring                            4.0.0-0.alpha-2019-03-12-005310   False       False         True      58m
network                               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
node-tuning                           4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
openshift-apiserver                   4.0.0-0.alpha-2019-03-12-005310   False       False         False     9s
openshift-authentication                                                True        False         False     12s
openshift-cloud-credential-operator                                     True        False         False     28h
openshift-controller-manager          4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
openshift-samples                     4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h
operator-lifecycle-manager            0.8.1-25a917e                     True        False         False     28h
service-ca                                                              True        False         False     28h
service-catalog-apiserver                                               True        False         False     28h
service-catalog-controller-manager                                      True        False         False     28h
storage                               4.0.0-0.alpha-2019-03-12-005310   True        False         False     28h


Expected results:
All cluster operator should have version info.

Additional info:

--- Additional comment from Liang Xia on 2019-03-13 08:14:52 UTC ---

Split the bug based on https://bugzilla.redhat.com/show_bug.cgi?id=1667360#c5

to ensure that we get real versions into all those operators before we ship.

Comment 1 Jay Boyd 2019-03-13 12:46:02 UTC
Fixed in service catalog controller manager via https://github.com/openshift/cluster-svcat-controller-manager-operator/pull/25 and should be in builds 4.0.0-0.alpha-2019-03-14 and newer.
*pending* in service catalog apiserver via https://github.com/openshift/cluster-svcat-apiserver-operator/pull/39

Comment 2 Jay Boyd 2019-03-13 16:54:34 UTC
both prs have merged.

Comment 3 Liang Xia 2019-03-14 05:09:52 UTC
$ oc get clusteroperators | grep service
service-ca                                                              True        False         False     27m
service-catalog-apiserver             4.0.0-0.alpha-2019-03-14-014544   True        False         False     23m
service-catalog-controller-manager    4.0.0-0.alpha-2019-03-14-014544   True        False         False     23m


The issue for service-catalog-apiserver/service-catalog-controller-manager are fixed.

@Jay, Are your team responsible for the operator service-ca ?
If not, i can verify this bug and open a new one to track that.

Comment 4 Jian Zhang 2019-03-14 05:54:08 UTC
Service Catalog operators works well, moving this bug to Auth team since the "service-ca" has not been fixed yet.

[jzhang@dhcp-140-18 ocp14]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-13-233958   True        False         117m    Cluster version is 4.0.0-0.nightly-2019-03-13-233958

[jzhang@dhcp-140-18 ocp14]$ oc get clusteroperator
NAME                                  VERSION                             AVAILABLE   PROGRESSING   FAILING   SINCE
cluster-autoscaler                    4.0.0-0.nightly-2019-03-13-233958   True        False         False     124m
console                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     114m
dns                                   4.0.0-0.nightly-2019-03-13-233958   True        False         False     123m
image-registry                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m
ingress                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m
kube-apiserver                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     121m
kube-controller-manager               4.0.0-0.nightly-2019-03-13-233958   True        False         False     122m
kube-scheduler                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     123m
machine-api                           4.0.0-0.nightly-2019-03-13-233958   True        False         False     124m
machine-config                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     124m
marketplace-operator                  4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m
monitoring                            4.0.0-0.nightly-2019-03-13-233958   True        False         False     2m46s
network                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m
node-tuning                           4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m
openshift-apiserver                   4.0.0-0.nightly-2019-03-13-233958   True        False         False     119m
openshift-authentication                                                  True        False         False     118m
openshift-cloud-credential-operator                                       True        False         False     124m
openshift-controller-manager          4.0.0-0.nightly-2019-03-13-233958   True        False         False     119m
openshift-samples                     4.0.0-0.nightly-2019-03-13-233958   True        False         False     117m
operator-lifecycle-manager            0.8.1-31e16a9                       True        False         False     124m
service-ca                                                                True        False         False     124m
service-catalog-apiserver             4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m
service-catalog-controller-manager    4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m
storage                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     118m

Comment 6 Liang Xia 2019-03-19 03:04:46 UTC
$ oc get clusteroperators
NAME                                  VERSION                           AVAILABLE   PROGRESSING   FAILING   SINCE
authentication                        4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m25s
cluster-autoscaler                    4.0.0-0.alpha-2019-03-18-221255   True        False         False     13m
console                               4.0.0-0.alpha-2019-03-18-221255   True        False         False     2m40s
dns                                   4.0.0-0.alpha-2019-03-18-221255   True        False         False     12m
image-registry                        4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m
ingress                               4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m1s
kube-apiserver                        4.0.0-0.alpha-2019-03-18-221255   True        False         False     9m
kube-controller-manager               4.0.0-0.alpha-2019-03-18-221255   True        False         False     10m
kube-scheduler                        4.0.0-0.alpha-2019-03-18-221255   True        False         False     11m
machine-api                           4.0.0-0.alpha-2019-03-18-221255   True        False         False     13m
machine-config                        4.0.0-0.alpha-2019-03-18-221255   True        False         False     12m
marketplace-operator                  4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m15s
monitoring                            4.0.0-0.alpha-2019-03-18-221255   True        False         False     105s
network                               4.0.0-0.alpha-2019-03-18-221255   True        False         False     13m
node-tuning                           4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m27s
openshift-apiserver                   4.0.0-0.alpha-2019-03-18-221255   True        False         False     8m20s
openshift-cloud-credential-operator   4.0.0-0.alpha-2019-03-18-221255   True        False         False     12m
openshift-controller-manager          4.0.0-0.alpha-2019-03-18-221255   True        False         False     11m
openshift-samples                     4.0.0-0.alpha-2019-03-18-221255   True        False         False     6m22s
operator-lifecycle-manager            4.0.0-0.alpha-2019-03-18-221255   True        False         False     13m
service-ca                                                              True        False         False     12m
service-catalog-apiserver             4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m29s
service-catalog-controller-manager    4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m32s
storage                               4.0.0-0.alpha-2019-03-18-221255   True        False         False     7m34s

Comment 7 Liang Xia 2019-03-21 07:14:11 UTC
The last cluster operator which is missing version info

Comment 8 Chuan Yu 2019-03-25 09:51:49 UTC
The issue should be fixed with https://github.com/openshift/service-ca-operator/pull/34 merged.

$ oc get clusteroperator service-ca
NAME         VERSION                             AVAILABLE   PROGRESSING   FAILING   SINCE
service-ca   4.0.0-0.nightly-2019-03-23-183709   True        False         False     3h16m

Comment 9 Chuan Yu 2019-03-25 09:52:46 UTC
Verified.

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-23-183709   True        True          3h28m   4.0.0-0.nightly-2019-03-23-183709

Comment 10 Jay Boyd 2019-03-27 20:19:03 UTC
*** Bug 1679077 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2019-06-04 10:45:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.