Bug 169226 - ACPI battery reading + hal stopped working with 2.6.12-1.1447_FC4
ACPI battery reading + hal stopped working with 2.6.12-1.1447_FC4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 169221 169222 169223 169224 169225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-25 08:30 EDT by Éric Brunet
Modified: 2015-01-04 17:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 17:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -v (6.29 KB, text/plain)
2005-09-25 08:30 EDT, Éric Brunet
no flags Details
Output of dmesg (27.76 KB, application/octet-stream)
2005-09-25 08:32 EDT, Éric Brunet
no flags Details

  None (edit)
Description Éric Brunet 2005-09-25 08:30:57 EDT
Description of problem:

I can no longer read battery status in /proc/acpi/battery/BAT0/*, and the deamon
HAL is no longer starting since kernel 2.6.12-1.1447. (kernel 2.6.12-1.1456
isn't working either, but kernel 2.6.12-1.1398_FC4 is fine.)

The computer is an ASUS laptop S5200N, with an Intel chipset (see attached lspci).

During boot time, the computer freezes during about half a minute at three
places: after printing (note the ok, the freeze occurs between this message and
the next)
        Configuration du nom d'hôte             [ok]
and after printing
        Démarrage du démon HAL
and during the launch of kde, when it prints
        Initialisation des périphériques
(I prefer not backtranslating the messages to english; the meaning shoud be
clear. "Démarrage" is "start")

The processes hald and haldaddon-acpi, which I usually have, are not present.

The battery is not readable; trying to read /proc/acpi/battery/BAT0/info
or /proc/acpi/battery/BAT0/state takes tens of seconds and print wrong
information (all the numbers are wrong). In dmesg appears each time I try to
read these files a couple of times the following line
     ACPI-0145: *** Error: Invalid owner_id: 00

I am attaching the output of lspci -v and of dmesg


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4

How reproducible:
     every time

Steps to Reproduce:
1. boot
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Éric Brunet 2005-09-25 08:30:57 EDT
Created attachment 119236 [details]
Output of lspci -v
Comment 2 Éric Brunet 2005-09-25 08:32:50 EDT
Created attachment 119237 [details]
Output of dmesg
Comment 3 Warren Togami 2005-09-25 10:19:32 EDT
http://people.redhat.com/davej/kernels/Fedora/FC4/
Please try the latest test kernel from here and report back.
Comment 4 Matthias Hensler 2005-09-25 13:52:36 EDT
Same problem on Asus M5N with 2.6.12-1.1447_FC4 and 2.6.12-1.1456_FC4. Never was
an issue with a kernel from rawhide, and is fixed with 2.6.13-1.1524_FC4.
Comment 5 Éric Brunet 2005-09-25 13:59:06 EDT
It works again for me with kernel kernel-2.6.13-1.1525_FC4.i686.rpm.
What was the problem ? I don't see any changelogs around   
http://people.redhat.com/davej/kernels .

Thanks.
Comment 6 Gerwin Krist 2005-09-25 14:27:46 EDT
*** Bug 169225 has been marked as a duplicate of this bug. ***
Comment 7 Gerwin Krist 2005-09-25 14:27:48 EDT
*** Bug 169224 has been marked as a duplicate of this bug. ***
Comment 8 Gerwin Krist 2005-09-25 14:28:13 EDT
*** Bug 169223 has been marked as a duplicate of this bug. ***
Comment 9 Gerwin Krist 2005-09-25 14:28:25 EDT
*** Bug 169222 has been marked as a duplicate of this bug. ***
Comment 10 Gerwin Krist 2005-09-25 14:30:10 EDT
*** Bug 169221 has been marked as a duplicate of this bug. ***
Comment 11 Dave Jones 2005-09-30 02:35:18 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 12 Éric Brunet 2005-10-01 02:56:05 EDT
The problem I reported is fixed in kernel 2.6.13-1.1526_FC4.

(I don't seem to have any sound anymore, but I'll fill another bug or wait for
someone to do so)

Note You need to log in before you can comment on or make changes to this bug.