Bug 169282 - fedora-logos should own /usr/lib/anaconda-runtime
fedora-logos should own /usr/lib/anaconda-runtime
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
:
: 442146 (view as bug list)
Depends On: 189415
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2005-09-26 10:31 EDT by Ralf Corsepius
Modified: 2008-11-06 16:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 16:26:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-09-26 10:31:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.7.10-1.5.2

Description of problem:
The fedora-logos rpm contains /usr/lib/anaconda-runtime/boot/syslinux-splash.png.

This directory is unowned, if not having anaconda installed (Note: fedora-logos is independent from  without anaconda*)




Version-Release number of selected component (if applicable):
fedora-logos-1.1.31-1

How reproducible:
Always

Steps to Reproduce:
1. yum install fedora-logos
2. yum remove anaconda-runtime
3. 
# rpm -qf /usr/lib/anaconda-runtime/boot/syslinux-splash.png
fedora-logos-1.1.31-1
# rpm -qf /usr/lib/anaconda-runtime/boot
file /usr/lib/anaconda-runtime/boot is not owned by any package
# rpm -qf /usr/lib/anaconda-runtime
file /usr/lib/anaconda-runtime is not owned by any package


Actual Results:  cf. above.

Expected Results:  /usr/lib/anaconda-runtime/boot/syslinux-splash.png is installed into a directory not owned by any parent package.

=> fedora-logos must own /usr/lib/anaconda-runtime and /usr/lib/anaconda-runtime/boot

This causes these directories to stay around on the filesystem, when users remove the fedora-logos rpm.

Additional info:
Comment 1 Jesse Keating 2006-04-19 16:32:47 EDT
This needs anaconda-runtime to track ownership of its files better, since it
requires fedora-logos.
Comment 2 Jesse Keating 2006-06-21 17:02:37 EDT
Jeremy, what do you think here?  Do we want fedora-logos to own that dir, or
what?  I'm pretty sure we don't want fedora-logos to depend on anaconda-runtime...
Comment 5 Michel Alexandre Salim 2008-01-26 21:53:35 EST
Hello? It's been 19 months since last reply. If anaconda-runtime depends on
fedora-logos, perhaps either move the files owned by fedora-logos somewhere
else, or as Ralf suggested, make fedora-logos own the directories concerned?
Comment 6 Matthias Clasen 2008-05-06 00:06:15 EDT
*** Bug 442146 has been marked as a duplicate of this bug. ***
Comment 7 petrosyan 2008-05-13 10:42:04 EDT
the following folders should be owned by fedora-logos:

/usr/lib/anaconda-runtime
/usr/lib/anaconda-runtime/boot
/usr/share/anaconda
/usr/share/anaconda/pixmaps
Comment 8 petrosyan 2008-05-20 23:44:15 EDT
The following folders should be owned by fedora-logos:

/usr/lib/anaconda-runtime
/usr/lib/anaconda-runtime/boot
/usr/share/anaconda
/usr/share/anaconda/pixmaps
/usr/share/kde-settings
/usr/share/kde-settings/kde-profile
/usr/share/kde-settings/kde-profile/default
/usr/share/kde-settings/kde-profile/default/share
/usr/share/kde-settings/kde-profile/default/share/icons
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/16x16
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/16x16/places
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/24x24
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/24x24/places
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/32x32
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/32x32/places
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/36x36
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/36x36/places
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/48x48
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/48x48/places
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/96x96
/usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE/96x96/places
/usr/share/kde4
/usr/share/kde4/apps
/usr/share/kde4/apps/ksplash
/usr/share/kde4/apps/ksplash/Themes
/usr/share/rhgb
Comment 9 petrosyan 2008-08-04 13:01:21 EDT
this bug is still present in fedora-logos-9.99.0-1.fc10
Comment 10 Tom "spot" Callaway 2008-11-06 16:26:03 EST
Fixed in fedora-logos-10.0.1-1.fc10

Note You need to log in before you can comment on or make changes to this bug.