Bug 169667 - no more sound after kernel update (via82xx)
no more sound after kernel update (via82xx)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 16:29 EDT by Sylvain Rouillard
Modified: 2015-01-04 17:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 00:23:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sylvain Rouillard 2005-09-30 16:29:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I get no sound after today's kernel upgrade.

lsmod shows all the modules. There is no particular message in dmesg nor in /var/log/messages. kmixer responds normally. The sound card is reported correctly by KDE, though the sound test produces no sound. Just there is no sound produced.

My sound chip is a VIA 8237, and I use the snd_via82xx module (among others).

Let me know if you need any more info or log or whatever.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. log in
2. play any sound (amarok for instance)
3. make sure you're not deaf (the wife is a sure test) before confirming that the computer makes no sound
  

Actual Results:  I heared no sound

Expected Results:  I should have heard my fav tunes!

Additional info:

Available on request, feel free to ask
Comment 1 Sylvain Rouillard 2005-09-30 16:31:16 EDT
When I spoke of kmixer, I should have mentionned that yes, I made sure nothing
was muted and that the levels were all at their maximum.
Comment 2 Andreas M. Kirchwitz 2005-09-30 22:07:19 EDT
Same problem here (Intel Pentium III), but with Soundblaster Live (lspci -v):

00:10.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
        Subsystem: Creative Labs SBLive! Player 5.1
        Flags: bus master, medium devsel, latency 64, IRQ 9
        I/O ports at 1060 [size=32]
        Capabilities: <available only to root>

With the new kernel 2.6.13-1.1526_FC4, the "master volume" control
seems to be missing from all mixer programs (like alsamixer,
gnome-volume-control). All other controls seem to be without effect.

Downgraded to kernel 2.6.12-1.1456_FC4 for now. Looks like ALSA had
some changes in 2.6.13 which breaks it on certain systems. On other
systems (different sound cards), the "master volume" control is not
missing.

The bug is not specific to x86_64, but also occurs with i686 CPUs.
Comment 3 Sylvain Rouillard 2005-10-01 03:53:39 EDT
When you say that the master control is missing, I reckon you do not mean that
it is not displayed on the application level, do you? I do see a master volume
control (as well as a master mono), that I can slide up and down, with AlsaMixer
as well as with Kmixer. However, you are right in the sense that it does seem
like if changing this setting has no effect behind the scenes, and that it
actually stays stuck at 0.

For comparison, lspci -v :

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 A
C97 Audio Controller (rev 60)
        Subsystem: ASUSTeK Computer Inc. A7V600/K8V Deluxe motherboard (ADI AD19
80 codec [SoundMAX])
        Flags: medium devsel, IRQ 185
        I/O ports at cc00 [size=256]
        Capabilities: [c0] Power Management version 2

Also, there seems to be a specific bugzilla for your chip:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169152
I refrained from posting there, considering Dave's Comment #7, but it does look
like the problem is very similar in many ways.

Cheers
Comment 4 Andreas M. Kirchwitz 2005-10-01 09:17:57 EDT
Actually, my "master" volume control is in fact missing from
all mixing tools (alsamixer, gnome-volume-control etc.)
Haven't seen such strange behaviour before. That really weird.

Bug 169152 is a good hint. Thanks for pointing that out. Haven't found
it at first because it's already closed. There's also bug 168668 which
is related to FC5 but describes exactly the same problem I have with FC4.

However, it looks like some more people have strange sound problems
when upgrading from kernel 2.6.12 to 2.6.13. Well, it doesn't help us
much right now, but it's good to know we're not alone. ;-)
Comment 5 Pedro Lamarão 2005-10-02 19:57:12 EDT
I can confirm the problem with Soundblaster Live!, sound not working, master
volume control missing from mixer interfaces.
Comment 6 Éric Brunet 2005-10-03 13:45:42 EDT
I have a similar problem with that kernel (1526_FC4), but with an inegrated
intel AC'97 soundcard:
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
        Subsystem: ASUSTeK Computer Inc.: Unknown device 1803
        Flags: bus master, medium devsel, latency 0, IRQ 7
        I/O ports at e000 [size=256]
        I/O ports at e100 [size=64]
        Memory at 2f800400 (32-bit, non-prefetchable) [size=512]
        Memory at 2f800600 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

I don't have all the controls available, and the controls missing seem to be
different at each reboot, which is very weird. For instance, right now, I only have
3D Control - Center, 3D Control - Depth and IEC958 Playback AC97-SPSA
showing in alsa-mixer.

My logs contain lines such as
codec_semaphore: semaphore is not ready [0x1][0x700300]
codec_read 0: semaphore is not ready for register 0x72

and also
error in snd_ac97_set_rate: cidx=0, reg=0x2c, rate=22050, err=-22
Comment 7 Dave Jones 2005-10-03 17:52:08 EDT
folks, the summary of this bug has 'via82xx' added to it to distinguish it from
other bugs. Please add your comments to the bugs relevant to your chipset, or
create a new one if necessary. thanks.
Comment 8 Sylvain Rouillard 2005-10-06 12:53:19 EDT
alright, I'd like to add two more details to my initial report.

1/ I just re-installed the previous kernel with rpm -ivh --oldpackage. I
faithfully uninstalled it after last kernel upgrade, so even though it was
pretty obvious that the kernel update was in cause with this bug, I couldn't
factually confirm it. Now I can confirm it, I have sound again when booting on
the previous kernel (2.6.12-1.1456_FC4). For what it's worth, the mixer settings
were all funky after I booted on that newly installed kernel (IIRC, PCM, Center
and AC97 Playback were all down at zero), even though every channels were at
their max after my desperate attempts to get some sound out of the buggy kernel).

2/ I only recently (about one month ago?) installed FC4. Before that, I've been
running the devel side for a while (actually since FC4T2). I used to update
every packages daily, including the kernel ones. Believe it or not, I never got
any problem with sound during all that time (only once it's been buzzing but it
was only bad mixer settings). Tracing back the rawhide reports, I found that a
kernel named 1526 has allready been tested in late august, back when I was still
using the devel branch. Though I don't really know what to conclude from that
except that probably the devel tagging is not the same as the prod one, I
thought it was worth mentionning it.

Hope that helps.
Comment 9 Sylvain Rouillard 2005-10-21 06:12:04 EDT
This problem is still present in kernel-2.6.13-1.1532_FC4.
Comment 10 Ivan Martinez 2005-10-28 22:16:41 EDT
Same problem here, ASUS K8V-X with via82xx.
2.6.12 works 2.6.13 does not.
Comment 11 Marek Kassur 2005-11-06 15:12:24 EST
There is a workaround mentioned on the ALSA bugtracking system,
can someone try it, as I don't have via82xx.

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1526
Comment 12 Sylvain Rouillard 2005-11-07 03:15:03 EST
This link is passworded. Any chance you could sum it up so that we (I) don't
have to create yet another account? I'd be glad to give it a try.
Comment 13 Sylvain Rouillard 2005-11-07 07:15:54 EST
Alright, I am daft I did not notice the public bypass link they provide on the
login page. Anyway, my daftness goes even beyong not paying attention to links
on a page: I also do not understand what this guy means by 'external amp', and
am therefore unable to follow his instructions correctly. I hope that someone
concerned by this bug will be smarter than I am, or that some good willing soul
can explain the meaning of this alsa-bug post...
Comment 14 Marek Kassur 2005-11-07 15:02:41 EST
I think he means "External Amplifier", you can find it in Kmix/Switches or in
alsamixer (hit 'm' to mute/unmute).
Comment 15 Sylvain Rouillard 2005-11-08 02:07:58 EST
OK

I tested this with 2.6.13-1.1532_FC4.

Booting, and then muting/unmuting 'External Amplifier' with either KMix or
alsamixer did not help. I also tried to boot, mute it, reboot and unmute, no
dice. The alsa-bug post mentions "If i first load windows,let it init the card,
and reboot, the card works fine", so I tried cold booting XP Pro SP2 and then
rebooting with 2.6.13-1.1532_FC4, no change.

I do hope that I did the tests you had expected, but am still not 100% sure to
exactly understand the description of that alsa bug. So if you want me to try
anything else, feel free to ask.
Comment 16 Sylvain Rouillard 2005-11-08 02:22:34 EST
Alright, I pushed the experiment a bit further and started playing with all the
buttons on the 'switches' tab of Kmix. When I mute them all, the sound comes
back. Unmutting them produces a variety of results depending on the order and
combination I use. Here is the list of switches I get:

Headphone Jack Sense (1)
Line Jack Sense (2)
Mic Boost (+20dB) (3)
Video (4)
IEC958 (5)
IEC958 Output (6)
Mix (7)
Mix Mono (8)
Exchange Front/Surround (9)
External Amplifier (10)
Spread Front to Surround and Center/LFE (11)
Stereo Mic (12)

Unmuting 9 only => no sound
Unmuting 11 only => horrible continuous scratch noise
Unmuting any of the other alone => everything is just fine
Unmuting 1+2 => no sound
Unmuting 1+9 => no sound
Unmuting 1+Anything else (including 11) => works fine

So I ended up unmutting everything except 2 and 9, so far so good. Let me know
if you're interested in any combination in particular.
Comment 17 Marek Kassur 2005-11-08 16:11:19 EST
Good to hear it work for you. But as I said, I don't have the hardware.
I saw this bug and decided to see what I could find.
Maybe some kernel/alsa hacker would comment. Is it suppose to work like this ?

Comment 18 Dave Jones 2005-11-10 15:12:44 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 19 Sylvain Rouillard 2005-11-11 03:49:27 EST
After updating to this newly released kernel, the sound is still working with
the settings described in my last post. Using the same references as in my post,
1+9 now works also (that would be an improvement). However, the other
combinations still produce the same results (no sound in most cases, awful
scratch noise in others). So now my setting is everything on except 2. With 2 on
I get no sound. With 2 back off and 11 off, I get no sound anymore, etc, etc...

I didn't test all the combinations extensively again, but bottom line is that a
wrong combination can still give a silent system, which does not seem right to
me. Of course it could also be by design, I don't know enough about alsa stuff
to say, but it is weird if it is, nonetheless.

I'm ready to provide any useful information on request.
Comment 20 Dave Jones 2005-11-11 03:54:16 EST
if you find a combination that doesn't work that you think should, bringing it
up with the alsa developers directly is probably the fastest path to getting
this changed. They have a bug tracker at http://www.alsa-project.org
Comment 21 Dave Jones 2006-02-03 02:16:16 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 22 Ivan Martinez 2006-02-03 05:54:15 EST
In my case 2.6.14-1.1656_FC4 is working fine, I don't know for the original
reporter.
Comment 23 Sylvain Rouillard 2006-02-07 02:52:36 EST
I'm actually surprized to see that this report is still open. 2.6.14 as well as
the new 2.6.15 work the same way, ie I have to choose correctly my switches
combination to get any sound. This has been narrowed down to being an alsa bug
at worst or an obscur feature at best.

As far as I am concerned, I have neither the time nor the sufficient knowledge
to push it further upstream. Furthermore, as long as it all works, I am happy.
Now if someone has a better understanding as to what those switches are supposed
to be used for, feel free to investigate.

Anyways, there does not seem to be anything that the FC guys can do, so I reckon
this report can be closed.
Cheers
Comment 24 Dave Jones 2006-02-21 00:23:47 EST
Thanks for the update.
If anyone else is still seeing problems with the latest updates, please open a
new bug rather than adding more to this already confusing bug, and I'll see if I
can't get the ALSA developers to take a look.

Thanks again.

Note You need to log in before you can comment on or make changes to this bug.