Bug 170117 - libwpd-0.8.2 update breaks dependencies
libwpd-0.8.2 update breaks dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libwpd (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
: 170232 170324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 10:43 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.8.2-1.fc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 09:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-10-07 10:43:16 EDT
Description of problem:

.....
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libwpd to pack into transaction set.
libwpd-0.8.2-1.fc3.i386.r 100% |=========================| 4.1 kB    00:00     
---> Package libwpd.i386 0:0.8.2-1.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: libwpd-1.so.7 for package: abiword
--> Finished Dependency Resolution
Error: Missing Dependency: libwpd-1.so.7 is needed by package abiword

Oops!  abiword was updated few days ago.

Version-Release number of selected component (if applicable):
libwpd-0.8.2-1.fc3
Comment 1 Radek Bíba 2005-10-10 10:16:45 EDT
*** Bug 170232 has been marked as a duplicate of this bug. ***
Comment 2 Radek Bíba 2005-10-10 10:34:41 EDT
To be exact, abiword requires libwpd-1.so.7 while new libwpd (-0.8.2-1) provides
libwpd-0.8.so.8. This disallows the whole update process to pass, one has to use
a workaround like yum --exclude=libwpd{,-tools,-devel} update. Changing severity
to 'high'. Please fix the dependencies here or in abiword.
Comment 3 DaXiong 2005-10-11 00:49:42 EDT
libwpd-0.8.so.8 also causes Open Office to crash on any open or save.
Comment 4 Radek Bíba 2005-10-11 03:26:57 EDT
DaXiong: are you sure? With the old libwpd OpenOffice crashes on any open or save,
too, but only in KDE. Please see bug 166267 - do you have openoffice.org-kde? Are
you running KDE? I've no problem in GNOME. After upgrade to the new libwpd
(abiword removed to satisfy the dependencies) OpenOffice still doesn't crash on
open or save on my system in GNOME and still does in KDE.
Comment 5 Michal Jaegermann 2005-10-11 10:41:58 EDT
I did not notice any crashes in OpenOffice after a quick test (but I am using
this thingy only when I am really out of other options) and it read correctly
these two files from WordPerfect which I happen to have laying around.

It is possible to install 'libwpd' update using '--nodeps' option to rpm
and abiword still works fine after that; minus an ability to import WordPerfect
formats but this is not that surprising (it gets something but results
are garbage).
Comment 6 Caolan McNamara 2005-10-11 16:23:38 EDT
*** Bug 170324 has been marked as a duplicate of this bug. ***
Comment 7 DaXiong 2005-10-11 23:36:35 EDT
(In reply to comment #4)
> DaXiong: are you sure? With the old libwpd OpenOffice crashes on any open or save,
> too, but only in KDE. Please see bug 166267 - do you have openoffice.org-kde? Are
> you running KDE? I've no problem in GNOME. After upgrade to the new libwpd
> (abiword removed to satisfy the dependencies) OpenOffice still doesn't crash on
> open or save on my system in GNOME and still does in KDE.

So right you are. updated to new libwpd and switched to KDE on the same day.
Another case opf blaming the wrong variable. Thanks. Works fine under Gnome.
Comment 8 Caolan McNamara 2005-10-13 18:36:20 EDT
abiword should be in the update queue
Comment 9 Matthew Miller 2005-10-14 16:10:52 EDT
The new abiword update isn't linked against libwpd at all. So that solves the
dependency issue, but, y'know, only by breaking other things. Bug #170869.
Comment 10 Caolan McNamara 2005-10-20 09:38:48 EDT
will follow up with bug 170869

Note You need to log in before you can comment on or make changes to this bug.