Bug 170402 - /etc/cron.daily/makewhatis.cron: 3000 lines of "zcat: stdout: broken pipe"
/etc/cron.daily/makewhatis.cron: 3000 lines of "zcat: stdout: broken pipe"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: man (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
: 199203 201526 201817 201818 (view as bug list)
Depends On:
Blocks: 187538
  Show dependency treegraph
 
Reported: 2005-10-11 07:17 EDT by Ivana Varekova
Modified: 2014-01-21 17:52 EST (History)
43 users (show)

See Also:
Fixed In Version: RHBA-2006-0344
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 17:38:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch used in man-1.5o1-9.test (515 bytes, patch)
2006-01-02 04:05 EST, Ivana Varekova
no flags Details | Diff
Test version of makewhatis script. (10.92 KB, text/plain)
2006-07-24 03:28 EDT, Ivana Varekova
no flags Details
/usr/bin/makewhatis from RHEL 4 (10.89 KB, application/octet-stream)
2006-07-24 08:56 EDT, Brian Long
no flags Details
Verbose output from /usr/bin/makewhatis test script (440.09 KB, application/x-bzip)
2006-07-24 10:34 EDT, Brian Long
no flags Details

  None (edit)
Comment 2 Douglas E. Warner 2005-10-24 08:44:24 EDT
This seems very similar to bug#64836 reported against RHEL3.  As far as I can  
tell, this just popped up in RHEL4 after update 2 (I updated just last week 
and this Sunday had a bunch of these messages).  Anyone else confirm that  
they didn't have it before, and now is happening?  
Comment 3 Aaron Suggs 2005-10-25 12:13:13 EDT
Yeah, after we updated, we started getting these messages from our machine running RHEL4 AS.
I don't get them on any of my machines running RHEL4 WS, but they have different packages installed too.
Comment 4 Ivana Varekova 2005-10-27 08:31:13 EDT
Hello, 
test version of man which contains patch against this bug is available:
http://people.redhat.com/varekova/man-1.5o1-9.test.src.rpm
and
http://people.redhat.com/varekova/man-1.5o1-9.test.i386.rpm.
Could you please test it?
Comment 6 Dominic Skilton 2005-11-23 03:27:26 EST
I'd be most interested in the results of the patch as to wether it resolves 
the problem before I go and install it on a client's production system.  I've 
been having this problem for a number of months now.
Comment 7 Ivana Varekova 2006-01-02 04:05:47 EST
Created attachment 122683 [details]
patch used in man-1.5o1-9.test
Comment 8 Shiraz Esat 2006-01-03 06:49:58 EST
Isn't this patch just throwing error messages away?
Wouldn't it be better to actually not have the errors in the first place?
Comment 9 Ivana Varekova 2006-01-05 05:28:59 EST
Shiraz, you are right. The patch is only erasing "broken pipe" error messages,
the real problem is in other package. It will be better to fix the reason of
this error messages, but this patch does not exist now so and man patch fixes
this problem. 
Comment 10 Zenon Panoussis 2006-04-02 10:32:14 EDT
cron.daily/00-makewhatis:

weekday=`/bin/date +%u`
if [ "$weekday" = "7" ]
then
   makewhatis -w
else
   makewhatis -u -w
fi

Then we can throw away cron.weekly/makewhatis and the lockfiles as well. The
logic of keeping weekly jobs in cron.weekly is defeated anyway, either by the
lockfile or by the bug. 
Comment 15 Red Hat Bugzilla 2006-04-26 17:17:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0344.html
Comment 16 Red Hat Bugzilla 2006-04-26 17:38:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0344.html
Comment 17 Brian Long 2006-06-01 14:19:24 EDT
The package mentioned in the above errata is dated 2004.  How can a fix from
2006 already exist in this package?  We're still seeing the makewhatis problem
using man-1.5o1-9 which is the only version of man available in the RHEL 4 RHN
channels.
Comment 18 Seth Vidal 2006-06-01 14:24:27 EDT
Same thing still happening here, too.
Comment 19 Dave Miller 2006-07-16 11:16:56 EDT
This appears to have come back as of the makewhatis run of last night (16 July
2006).  Same symptoms as before.  Looks like the patch got zapped.
Comment 20 Michal Jaegermann 2006-07-16 12:49:01 EDT
> Looks like the patch got zapped.

I would rather assume that recent updates to vixie-cron made a workaround
ineffective.
Comment 21 Michal Jaegermann 2006-07-16 13:18:16 EDT
Looking closer it appears that 'man-1.5p-pipe_makewhatis.patch', i.e.

--- man-1.5p/src/makewhatis.sh.pipe     2005-05-12 15:23:07.635109152 +0200
+++ man-1.5p/src/makewhatis.sh  2005-05-12 15:24:19.780141440 +0200
@@ -208,9 +208,9 @@
       sub(/\..*/, "", progname);
       if (use_zcat || use_bzcat) {
        if (use_zcat) {
-         pipe_cmd = "zcat \"" filename "\"";
+         pipe_cmd = "zcat \"" filename "\" 2>/dev/null";
        } else {
-         pipe_cmd = "bzcat \"" filename "\"";
+         pipe_cmd = "bzcat \"" filename "\" 2>/dev/null";
        }
        # try to avoid suspicious stuff
        if (filename ~ /[;&|`$(]/) {

was never applied in an RHEL context and vixie-cron updates from the
last week brought that to light.
Comment 22 Ivana Varekova 2006-07-18 03:29:40 EDT
*** Bug 199203 has been marked as a duplicate of this bug. ***
Comment 23 Ivana Varekova 2006-07-18 04:03:03 EDT
This problem is fixed in man-1.5o1-9.rhel4. man-1.5o1-9 is affected with this
bug. Please ask GSS about man-1.5o1-9.rhel4 package.
If there is anybody who has a system with man-1.5o1-9.rhel4 which is affected by
this bug please add a comment here.
Comment 24 Brian Long 2006-07-18 08:47:00 EDT
Please see comment #17 which I submitted.  We are seeing the problem with
man-1.5o1-9.rhel4 because the problem that was fixed in RHEL 3 was never ported
to RHEL 4.
Comment 25 Steven Estrada 2006-07-23 08:07:42 EDT
>> If there is anybody who has a system with man-1.5o1-9.rhel4 which is 
affected by this bug please add a comment here. <<

RHEL4 + man-1.5o1-9.rhel4 = still see trouble
Comment 26 Ivana Varekova 2006-07-24 03:28:58 EDT
Created attachment 132900 [details]
Test version of makewhatis script.

Could you please attach your actual makewhatis script (/usr/bin/makewhatis).
And could you please replace the actual version of makewhatis script by
attached test version. (The output of attached test version is more verbose)
and attach the weekly output of this version to bugzilla comment.
Comment 27 Mirjam van den Hout - van Vroonhoven 2006-07-24 05:05:42 EDT
I have here RedHat Enterprise Linux AS 4, and I see the same errors since the
last vixie-cron update. However the fixed man package is not available in the
rhel-x86_64-as-4 channel of RedHat Network. Could this fixed package be made
available there as well?
Comment 28 Brian Long 2006-07-24 08:56:41 EDT
Created attachment 132914 [details]
/usr/bin/makewhatis from RHEL 4

Please re-open this bug as it's clear we still have a bug in RHEL 4.
Comment 29 Ivana Varekova 2006-07-24 09:06:08 EDT
Please Brian could you attach the version (release number) of your man - package?
Comment 30 Brian Long 2006-07-24 10:32:16 EDT
man-1.5o1-9.  In comment you mention man-1.5o1-9.rhel4 which does not exist to
my knowledge.
Comment 31 Brian Long 2006-07-24 10:34:06 EDT
Created attachment 132919 [details]
Verbose output from /usr/bin/makewhatis test script

This 50+MB of output is from your test script.
Comment 32 Wade Mealing 2006-07-25 21:56:10 EDT
Can I get someone to test this in a test environment.  I have been working on
porting the bug fix forward to RHEL4.

Can I get you to test the rpm packages available from:

http://people.redhat.com/wmealing/RPMS/RHEL4/man/

These are test packages only, and should not be used on a production system. 
Red Hat GSS will not support these packages.

Assuming it does solve the issue I'll attempt to get the fix in the next release.
Comment 33 Wade Mealing 2006-08-08 21:41:28 EDT
Moved this bug back to 3, as it originally was.

RHEL 4 bug is at 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201817
Comment 34 Ivana Varekova 2006-08-09 04:28:31 EDT
*** Bug 201818 has been marked as a duplicate of this bug. ***
Comment 35 Ivana Varekova 2006-08-09 05:16:12 EDT
The rhel3 version of this bug is 64836, this bug is against rhel4.
Comment 36 Ivana Varekova 2006-08-09 05:21:09 EDT
*** Bug 201817 has been marked as a duplicate of this bug. ***
Comment 37 Ivana Varekova 2006-08-21 10:06:26 EDT
*** Bug 201526 has been marked as a duplicate of this bug. ***
Comment 38 Brian Long 2006-08-21 10:10:20 EDT
What is the status of getting an errata for this?  Any chance it could be
considered for Fastrack?
Comment 39 Ivana Varekova 2006-08-21 10:14:05 EDT
The link to errata for this problem is in comment #15.  
Comment 40 Brian Long 2006-08-21 10:32:39 EDT
No, that errata for RHEL 4 does not fix the problem which is why this bug is
supposed to be re-open.  Only the RHEL 3 man errata fixed the problem for RHEL
3.  There has been no RHEL 4 errata which fixes this issue.  I still have an
open Issue Tracker 94958 in regards to this issue and I was given a test package
"man-1.5o1-10_TEST.x86_64.rpm" which DOES fix the problem.  I'll follow up in IT
as well.
Comment 41 Ivana Varekova 2006-08-21 11:12:57 EDT
 Brian I look at comment #28 there is your makewhatis patch - which is not
fixed, but I just grub man-1.5o1-9.rhel4.i386 and it's version of makewhatis
script contains patch against this bug.
 Please could you try re-install your man page package and send me
/usr/sbin/makewhatis script and output of "rpm -q man" command again. Thanks.
Comment 42 Matthew Miller 2006-11-01 19:43:36 EST
From one of my (knowledgeable) users:

Version of man pages has nothing to do with it.  Somehow yum or rpm environment
is set up to ignore sigclose and when post script restarts crond during update,
crond inherits those environment settings.  Restarting crond by hand fixes this
problem.

To observe this, update crond and:
grep SigIgn /proc/{cron pid}/status
then restart crond and compare.

Minor, easy to fix problem after all.
Comment 43 Damian Menscher 2008-12-07 16:20:38 EST
I copy/pasted comment 42 into a new bug (475106) in hopes of getting someone's attention to this 3-year-old issue.  (We can't reopen this bug.)

Note You need to log in before you can comment on or make changes to this bug.