Bug 1705932 - python-grafyaml fails to build with Sphinx 2 (blocks Python 3.8 rebuild) / nonresponsive maintainer
Summary: python-grafyaml fails to build with Sphinx 2 (blocks Python 3.8 rebuild) / n...
Keywords:
Status: CLOSED DUPLICATE of bug 1736503
Alias: None
Product: Fedora
Classification: Fedora
Component: python-grafyaml
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Belanger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1716496 (view as bug list)
Depends On: 1737205
Blocks: PYTHON38 F31FTBFS SPHINX2 1718323 1731531 1731544 1732841
TreeView+ depends on / blocked
 
Reported: 2019-05-03 08:58 UTC by Miro Hrončok
Modified: 2019-08-14 21:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-05 13:50:09 UTC
Type: Bug


Attachments (Terms of Use)
Full log from Copr (112.85 KB, text/plain)
2019-05-03 08:58 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2019-05-03 08:58:13 UTC
Created attachment 1562246 [details]
Full log from Copr

python-grafyaml 0.0.5-13.fc31 fails to build dost with Sphinx 2:


+ /usr/bin/python3 setup.py build_sphinx
running build_sphinx
[pbr] Generating AUTHORS
[pbr] AUTHORS complete (0.0s)
Running Sphinx v2.0.1
fatal: --local can only be used inside a git repository
making output directory... done

Exception occurred:
  File "/usr/lib/python3.8/site-packages/oslosphinx/__init__.py", line 76, in builder_inited
    app.info('Using openstack theme from %s' % theme_dir)
AttributeError: 'Sphinx' object has no attribute 'info'
The full traceback has been saved in /tmp/sphinx-err-k5mmly9o.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
A bug report can be filed in the tracker at <https://github.com/sphinx-doc/sphinx/issues>. Thanks!


----

Full lo attached. The critical error is:

    AttributeError: 'Sphinx' object has no attribute 'info'

Please use the logging API instead:

https://www.sphinx-doc.org/en/2.0/extdev/logging.html

This blocks the Python 3.8 rebuild of the package.

Comment 1 Miro Hrončok 2019-05-03 08:59:07 UTC
File "/usr/lib/python3.8/site-packages/oslosphinx/__init__.py" is from 	python-oslo-sphinx.

Comment 2 Miro Hrončok 2019-07-10 10:20:47 UTC
Alan, please respond.

Comment 3 Miro Hrončok 2019-07-10 12:59:55 UTC
*** Bug 1716496 has been marked as a duplicate of this bug. ***

Comment 4 Alan Pevec 2019-08-03 15:18:57 UTC
opendev/graphyaml is not an openstack project and should not depend on oslosphinx and latest version does not have it, although it has dep on openstackdocstheme which should also be removed in the upstream.
oslosphinx itself was retired upstream and should be removed in Fedora.

Re. py3.8 compat: upstream opendev CI jobs have only py35 jobs afaict, so there might be more issues.
We could try updating graphyaml to the latest version and see how that goes.

Comment 5 Alan Pevec 2019-08-03 15:29:20 UTC
Paul, please add update grafyaml in Fedora also if you like add openstack-sig group as admin in https://src.fedoraproject.org/rpms/python-grafyaml

Comment 6 Miro Hrončok 2019-08-03 21:31:09 UTC
AttributeError: 'Sphinx' object has no attribute 'info' is a bug in oslosphinx. I'll open a separate issue if you'd prefer.

Comment 7 Alan Pevec 2019-08-04 11:16:24 UTC
oslossphinx is gone upstream and solution will be to retire it, fixing it will not help grafyaml compat with py36

Comment 8 Miro Hrončok 2019-08-05 11:39:19 UTC
I cannot parse that sentence. If grafyaml is only compatible with Python 3.6 and not 3.7 or 3.8, it should have been retired 3 releases ago.

Comment 9 Miro Hrončok 2019-08-05 13:50:09 UTC
Closing in favor of bz1736503.

*** This bug has been marked as a duplicate of bug 1736503 ***

Comment 11 Alan Pevec 2019-08-14 21:25:03 UTC
grafyaml scratch build worked with python-oslo-sphinx-4.18.0-5.fc31 in buildroot: https://koji.fedoraproject.org/koji/taskinfo?taskID=37042454


Note You need to log in before you can comment on or make changes to this bug.