Bug 1711725 - Drop python2 sub-package from F31+
Summary: Drop python2 sub-package from F31+
Keywords:
Status: CLOSED DUPLICATE of bug 1718781
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pandas
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: kushaldas@gmail.com
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY2REMOVAL 1674101
TreeView+ depends on / blocked
 
Reported: 2019-05-20 00:40 UTC by Orion Poplawski
Modified: 2019-06-11 15:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-11 15:57:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2019-05-20 00:40:29 UTC
Description of problem:

Let's drop the python2 package.  The only package that requires it is python-hardware, which appears to be abandoned.  See bug#1711724.

Comment 1 Orion Poplawski 2019-05-20 01:00:03 UTC
Looks like we may need 0.25.0 to address this - https://github.com/pandas-dev/pandas/commit/90617c6c9fb476c8e7af9933531c59f9322d567c

Comment 2 Miro Hrončok 2019-05-20 08:36:58 UTC
You don't actually need Python 3 semantics (language level) in Cython sources to build with/for Python 3 only.

Comment 3 Orion Poplawski 2019-05-20 13:46:15 UTC
Hmm, all I know is that when I removed the python2 build pandas fails to build.

Comment 4 Miro Hrončok 2019-05-20 13:58:21 UTC
May I have a look?

Comment 5 Miro Hrončok 2019-06-11 15:57:09 UTC
Marking as duplicate for the automatic bug.

*** This bug has been marked as a duplicate of bug 1718781 ***


Note You need to log in before you can comment on or make changes to this bug.