Bug 171221 - nm256 locks up on Dell Latitude.
nm256 locks up on Dell Latitude.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://www.wardrivers.it/dell_lock.jpg
:
: 171222 171223 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 12:18 EDT by frabbo
Modified: 2015-01-04 17:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 21:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description frabbo 2005-10-19 12:18:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
On boot my Dell Latitude LS hang in "Hardware Initialization"

".. hardware .. network.."   HANG 

Tried the  acpi=off option and also 
Sometimes if I press the "I" key for interactive startup It goes.


Version-Release number of selected component (if applicable):
kernels-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1.Just boot

Additional info:
Comment 1 John Mahowald 2005-10-19 12:25:11 EDT
*** Bug 171223 has been marked as a duplicate of this bug. ***
Comment 2 John Mahowald 2005-10-19 12:25:26 EDT
*** Bug 171222 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2005-11-10 14:18:15 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 4 Auzie Morgan 2005-11-14 16:30:18 EST
Sony Vaio pcg-z505sx - added yum archs for lvinia, dider,dries
Floppy net install via the fc4 floppy project, 
updated all to include kernel 2.6.14-1.1637_FC4 added kernel-kmdl-madwifi for
same via lvinia.. still get the same kind of random lockup on boot, tried the
interactive mode to see if it clears it seems to help.. 
My hang is after network on the udev init.. 
Lots of laptops with this bug could it be pcmcia related? Is there any way to
maybe tweak udevs rules to block steps? aka could be neomagic being probed, so
how about stoping udev from initing audio or network just to track this down?
Comment 5 Dave Jones 2005-11-14 19:54:02 EST
Can you try without the madwifi stuff installed ?

Another thing to try..
edit /etc/rc.d/rc.sysinit, and change load_module at line 165 or so to add a...

echo $1

before the LC_ALL=C fgrep... line.

That should print out the name of the module that causes the hang
Comment 6 Pete Zaitcev 2005-11-23 22:55:31 EST
What Dave said. Also, I have z505je, works with Rawhide ok.
Comment 7 frabbo 2006-01-03 15:47:18 EST
UPDATE for DELL LATITUDE LS hanging on boot
The problem is still present with the latest kernel (2.6.14-1.1653_FC4)
I put "NOMCE" option as boot option in grub and It boot without problem.
There owerver still a little problem.
My system is multi boot.
The partition table is the seguent:
HDA1 Windows2K NTFS
HDA2 FAT32
HDA3 extended
HDA4 FC4
HDA5 Auditor (a knoppis/kalnoppix derivative)
HDA6 SWAP

When I occasionalli boot under Windows the next time I boot under FC4 the
notebook hangs as above on "Hardware Initialization"
".. hardware .. network.."   HANG 

I boot under Auditor without problem. Shutdown.
I boot again FC4 and this time work.
Amazing!
Comment 8 Auzie Morgan 2006-01-05 03:04:08 EST
Bingo, Dave,, 
Ok I hacked that rc script up kind of like you said, going on my hunch I found
each dev section and added various echo's covering the module name in each
instance, btw might want to use a common format in that area guys,, but I did
figure out the hang point.. snd_nm256,, 

I thought it looked like network completed before the lock up.. The problem is
that your script echo's say audio after its done?? I would say lets consider
making that set of steps a bit cleaner.. and obviously in my case its alsa
drivers blowing up at random.. 

Why? duno but I think its a kernel / alsa problem.. 

For now I disabled all the audio init lines.. its my laptop.. I need networking
and gui more than anything else.. 

Here is my sound section.. 
# Sound
#for module in `/sbin/modprobe -c | LC_ALL=C awk
'/^alias[[:space:]]+snd-card-[[:digit:]]+[[:space:]]/ { print $3 }'` $audio; do
        #echo $module
        #load_module $module
#done

echo -n $" audio disabled"

# Everything else (duck and cover)
#for module in $other ; do
#       echo $module
#       load_module $module
#done

Note how I inserted echo $module,, from the looks of things load_module does the
real dirty work so before it tries to load the mod I echoed the $module
variable.. :)  I did the same trick on the other sections.. 


How to fix? 
Comment 9 Dave Jones 2006-01-05 20:27:49 EST
can you attach the output of lspci -n please ?

could be it needs a blacklist addition.
That driver already has some checks for some Dell Latitudes with comments about
it locking up when certain registers are poked.  Could be yours is a newer model
than those already blacklisted.
Comment 10 Dave Jones 2006-01-19 20:28:17 EST
ping ?
Comment 11 Auzie Morgan 2006-01-20 12:26:28 EST
Well I haven't had much time to test again, I added the latest kernel updates a 
week ago and re activated those lines, it booted clean a couple of times but I 
haven't had time to sit and reboot it over and over to see if its still 
failing..  Ill update the bug again in a few days..
Comment 12 Dave Jones 2006-02-03 00:20:54 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 13 John Thacker 2006-05-04 21:48:27 EDT
Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.