Bug 171648 - suspend to memory no longer works for thinkpad
suspend to memory no longer works for thinkpad
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
: 172003 172019 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2005-10-24 14:38 EDT by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-04 16:21:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch (381 bytes, patch)
2005-11-05 09:17 EST, David Woodhouse
no flags Details | Diff

  None (edit)
Description Brian G. Anderson 2005-10-24 14:38:08 EDT
Description of problem:
Since about kernel 1622 or so, 'echo mem>/sys/power/state' no longer suspends to
memory.  The log reports the following

kernel: Stopping Tasks: ========================================================
kernel: stopping tasks failed (1 tasks remaining)
kernel: Restarting tasks...<6> Strange, kauditd not stopped
kernel: done

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
1.at root prompt issue 'echo mem > /sys/power/state'
Actual results:
Blanks X to console, reports stopping tasks, but then returns to X again.

Expected results:
Blank X, stop tasks and then go into sleep mode

Additional info:
Also the stopping tasks takes a lot longer that it used to.  Printing of that
message used to fly by,  now it takes about a second for each '=' to be printed.
Comment 1 Dave Jones 2005-11-04 16:23:13 EST
*** Bug 172003 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2005-11-04 16:23:41 EST
*** Bug 172019 has been marked as a duplicate of this bug. ***
Comment 3 Reshat Sabiq 2005-11-04 17:51:42 EST
The bug is closed. What version of kernel is this fixed in?
Comment 4 Dave Jones 2005-11-04 19:42:08 EST
current rawhide should have it fixed. (It was fixed a few days back whilst I was
away, so I'm not sure the exact revision it got fixed in).
Comment 5 Brian G. Anderson 2005-11-05 07:37:10 EST
I have kernel 2.6.14-1.1639 and it still doesn't suspend, but for a different
reason.  Now the messages are

kernel: Stopping tasks: =================================|
kernel: hci_usb 4-1:1.1: no suspend?
kernel: hci_usb 4-1:1.0: no suspend?
kernel: Could not suspend device 4-1: error -16
kernel: Some devices failed to suspend.

So it still doesn't work for me.  Should this bug be reopened or should I file a
new one?
Comment 6 David Woodhouse 2005-11-05 07:42:20 EST
It's a new one -- the USB Bluetooth driver lacks a suspend method. 

I work around this on my PowerBook by running 'hid2hci --tohid' in the
pre-suspend script, and 'hid2hci' again upon resume. Obviously that requires
that your bluetooth device supports HID mode.
Comment 7 Vladimir Kondratiev 2005-11-05 09:14:21 EST
would you attach patch to fix this bug?
I'd like to try it with vanilla kernel.
Comment 8 David Woodhouse 2005-11-05 09:17:45 EST
Created attachment 120761 [details]
Comment 9 Reshat Sabiq 2005-11-05 16:33:28 EST
Mine suspended, but doesn't come out of it, with some thread exceptions and
stack traces dumped out on resume.
Comment 10 Vladimir Kondratiev 2005-11-06 03:35:09 EST
For me, works fine. I applied it to vanilla 2.6.14.
Comment 11 David Woodhouse 2005-11-06 03:52:52 EST
You still shouldn't have kauditd running unless you've specifically configured
your system that way, though. If you do, that's a bug -- and may be causing your
system to run _much_ slower than it needs to. Please check whether you have the
'audit' package installed, and whether auditd is started by default.
Comment 12 Brian G. Anderson 2005-11-08 15:00:03 EST
I haven't specically configured the system except through frequent updates to
rawhide.  How should audit be configured?  'audit' package is installed and
'auditd' is running (its configured to start at levels 2-5)
Comment 13 David Woodhouse 2005-11-08 17:07:09 EST
I thought it was decided that auditd shouldn't enable itself by default?

Comment 14 Steve Grubb 2005-11-09 09:45:54 EST
David, auditd doesn't enable itself by default on RHEL4 only. FC4 shipped before
we decided to do that and there hasn't been a distribution release since then. I
want rawhide to keep it on by default so that problems are found and reported.
Looks like we found one.

Note You need to log in before you can comment on or make changes to this bug.