Bug 1717994 - must-gather does not include logs from pods in openshift-cluster-version namespace
Summary: must-gather does not include logs from pods in openshift-cluster-version name...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.1.z
Assignee: Abhinav Dahiya
QA Contact: sheng.lao
URL:
Whiteboard:
: 1721620 1722966 (view as bug list)
Depends On: 1715634 1721620
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-06 15:42 UTC by Eric Rich
Modified: 2019-07-18 18:59 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1715634
Environment:
Last Closed: 2019-07-04 09:01:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1635 None None None 2019-07-04 09:01:33 UTC

Comment 1 Eric Paris 2019-06-06 15:50:46 UTC
https://github.com/openshift/must-gather/pull/98

Comment 2 Abhinav Dahiya 2019-06-18 18:14:26 UTC
*** Bug 1721620 has been marked as a duplicate of this bug. ***

Comment 4 sheng.lao 2019-06-20 05:41:23 UTC
The bus is verified with version 4.1.0-0.nightly-2019-06-19-220253

# oc adm must-gather
namespace/openshift-must-gather-d658g created
clusterrolebinding.rbac.authorization.k8s.io/must-gather-rftz5 created
...

# find -type f |grep openshift-cluster-version
./namespaces/openshift-cluster-version/apps.openshift.io/deploymentconfigs.yaml
./namespaces/openshift-cluster-version/apps/daemonsets.yaml
./namespaces/openshift-cluster-version/apps/deployments.yaml
./namespaces/openshift-cluster-version/apps/replicasets.yaml
./namespaces/openshift-cluster-version/apps/statefulsets.yaml
./namespaces/openshift-cluster-version/autoscaling/horizontalpodautoscalers.yaml
./namespaces/openshift-cluster-version/batch/cronjobs.yaml
./namespaces/openshift-cluster-version/batch/jobs.yaml
./namespaces/openshift-cluster-version/build.openshift.io/buildconfigs.yaml
./namespaces/openshift-cluster-version/build.openshift.io/builds.yaml
./namespaces/openshift-cluster-version/core/configmaps.yaml
./namespaces/openshift-cluster-version/core/events.yaml
./namespaces/openshift-cluster-version/core/pods.yaml
./namespaces/openshift-cluster-version/core/replicationcontrollers.yaml
./namespaces/openshift-cluster-version/core/secrets.yaml
./namespaces/openshift-cluster-version/core/services.yaml
./namespaces/openshift-cluster-version/image.openshift.io/imagestreams.yaml
./namespaces/openshift-cluster-version/pods/cluster-version-operator-94456444f-r9tm4/cluster-version-operator/cluster-version-operator/logs/current.log
./namespaces/openshift-cluster-version/pods/cluster-version-operator-94456444f-r9tm4/cluster-version-operator/cluster-version-operator/logs/previous.log
./namespaces/openshift-cluster-version/pods/cluster-version-operator-94456444f-r9tm4/cluster-version-operator-94456444f-r9tm4.yaml
./namespaces/openshift-cluster-version/route.openshift.io/routes.yaml
./namespaces/openshift-cluster-version/openshift-cluster-version.yaml

Comment 6 errata-xmlrpc 2019-07-04 09:01:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1635

Comment 7 Eric Rich 2019-07-18 18:59:59 UTC
*** Bug 1722966 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.