Bug 171880 - Installer uses incorrect resolution
Installer uses incorrect resolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 09:13 EDT by Christopher
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 17:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher 2005-10-27 09:13:17 EDT
+++ This bug was initially created as a clone of Bug #115679 +++

My copy of FC4 is a copy I downloaded on 10/23/05.

My hardware platform:

Compaq Proliant 850R
Dual PPro-200MHz (256K Cache)
128MB RAM
Compaq SMART2-SL RAID Controller
3x4.3 GB SCSI in RAID5 Array
System has onboard SCSI Controller with nothing attached
IDE CD-ROM (Appears to require ide=nodma)
Anaconda probes the onbaord video as Cirrus Logic GD543x

I've tried two different monitors:
OptiQuest Q17 17" CRT
NEC MultiSync LCD M7000+ 17" Flat Panel

I've tried all of the following commands with both monitors:

<enter> at initial load screen
linux ide=nodma
linux resolution=800x600
linux resolution=640x480
linux resolution=1024x768
linux ide=nodma resolution=800x600
linux ide=nodma resolution=640x480
linux ide=nodma nofb resolution=800x600
linux ide=nodma nofb resolution=640x480

What happens is that on all three of these commands, when anaconda loads, it's 
the same resolution everytime...which pushes the bottom and right sides out of 
my monitor, leaving me unable to view things like the buttons.

With either monitor, anaconda can probe the video card, but is unable to probe 
the monitor.

With the flat panel hooked up, I am able to have it tell me what resolution it 
is at. In all the above commands, my flat panel continues to tell me that it 
is ALWAYS being shown in 640x480@60Hz. The 'resolution' keyword appears to 
make little difference once anaconda comes up.

As a verification of the video card itself, I installed Win2K on this system. 
Win2K will allow me to choose 640x480, 800x600, 1024x768 (256 Colors), or 
1280x1024 (16 colors). So, it appears that the video card should be handling 
these resolutions just fine.
Comment 1 Jeremy Katz 2005-11-07 21:24:28 EST
Does it work better if you boot with 'linux nofb'?
Comment 2 Christopher 2005-11-08 08:59:36 EST
I had nofb in the command line when I tried booting on the last two occasions. 
I'll go ahead and try nofb as the only option and get back to you.
Comment 3 Christopher 2005-11-15 12:18:45 EST
I have tried

linux nofb

Same results. The monitor's resolution is 640x480, but the screen that shows 
up is formatted for a larger resolution and thus, it doesn't display correctly 
on the screen and is unusable.
Comment 4 Myk Melez 2006-03-03 15:00:49 EST
I see this problem with FC5test3 on an SGI 330 with an nVidia NV10GL [Quadro]
video card hooked up via a DVI-D connection to a Dell 2005FPW monitor running at
1680x1050 native resolution.

If I start the installer without specifying a resolution, it dies complaining
that the window manager can't open the display (i.e. something like the message
in bug 72088).  If I specify resolution=1680x1050 when booting, on the other
hand, the graphical installer starts up fine, but as with the original reporter
it displays at an unusably low resolution (720x400 70Hz according to my monitor).

Note that my video card and my monitor have VGA connectors, and if I connect
them via a VGA cable instead of a DVI-D cable the graphical installer starts up
in 800x600 resolution, which seems like the minimum necessary to navigate its
screens.  But if I specify resolution=800x600 when booting with the DVI-D cable
I get the same "window manager can't open display" error as when I don't specify
a resolution.  So the problem seems to be specific to the DVI connection.
Comment 5 Chris Lumens 2006-08-03 16:23:01 EDT
Please try again with FC6 or FC6 test 2.  Lots of work has gone into X
configuration and startup for this release.
Comment 6 Red Hat Bugzilla 2007-06-11 22:58:54 EDT
requested by Jams Antill
Comment 7 Chris Lumens 2007-08-24 17:11:40 EDT
This should be fixed in later releases of Fedora.

Note You need to log in before you can comment on or make changes to this bug.