Bug 171897 - Bogus warning saving excel spreadsheet
Bogus warning saving excel spreadsheet
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 12:19 EDT by David L. Parsley
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHEA-2007-0698
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:14:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch; samba svn changesets 3895 and 5720 combined (10.92 KB, patch)
2005-10-27 14:43 EDT, David L. Parsley
no flags Details | Diff
Forgotten TMP file (4.23 KB, image/png)
2007-08-14 15:50 EDT, Josef Kubin
no flags Details

  None (edit)
Description David L. Parsley 2005-10-27 12:19:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050923 CentOS/1.0.7-1.4.1.centos4 Firefox/1.0.7

Description of problem:
When using Office XP or Office 2003 latest service pack, saving an excel spreadsheet to an RHEL4 (and RHEL3 as well) samba share gives the warning that "The file (whatever) may have been changed by another user since you last saved it ...".  This can be worked around by setting a registry key _for each user_, but that just wors around a samba bug, see:
http://lists.samba.org/archive/samba-technical/2005-March/039942.html
<quote>
On Wed, Mar 16, 2005 at 04:11:26PM +0100, Simo Sorce wrote:
> Found this link on msdn (thanks to Marco Vitis on samba-it at xsec.it mailing list).
> 
> http://support.microsoft.com/default.aspx?scid=kb;en-us;324491
> 
> Seem this is a way to solve Excel problems with some misbehaving samba versions.
> 
> Have anybody tested this thing?

The fixes for write timestamps I've put into the current SAMBA_3_0 SVN
(due to be released as 3.0.12) should make this fix not needed. I'd
be interested for people to test this.

Thanks,

	Jeremy.
</quote>

I've verified that building samba-3.0.20-2 from Fedora Core devel fixes this issue.

Version-Release number of selected component (if applicable):
samba-3.0.10-1.4E.2

How reproducible:
Always

Steps to Reproduce:
1. Create a samba share on RHEL3/4
2. Map it from Windows box w/ Excel XP or 2003 latest service pack
3. Create, save to share, and close spreadsheet
4. Open spreadsheet again, modify it, save it
  

Actual Results:  "File xxx may have been changed ..." bogus warning

Expected Results:  File saves without warning

Additional info:

The default action in the dialog is 'Save a copy', this confuses a lot of users.
Comment 1 David L. Parsley 2005-10-27 14:43:15 EDT
Created attachment 120480 [details]
Proposed patch; samba svn changesets 3895 and 5720 combined

Did a lot of digging on samba lists, and traced it back to samba bug #2045. 
Combining both changesets that address this bug fixed the issue for me on
RHEL4.
Comment 2 David L. Parsley 2005-10-27 15:18:31 EDT
This patch also applies cleanly to samba-3.0.9-1.3E.5 (RHEL3), and likewise
fixes the issue there.
Comment 3 Karsten Weiss 2005-11-16 06:39:12 EST
Does this maybe also fix the following bug or should I open a separate bug for it?

Excel, PowerPoint files timestamp is always updated even when the file is not
saved on the samba share
https://bugzilla.samba.org/show_bug.cgi?id=1601

We are seeing it on a RHEL4U2 fileserver with samba-3.0.10-1.4E.2.
Comment 4 RHEL Product and Program Management 2006-08-18 13:07:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Charlie Brady 2007-02-12 17:29:32 EST
pm-rhel@redhat.com, you've already fixed this on RHEL3, so it seems strange that
you would be hesitant to also fix RHEL4. 

* Tue Sep 20 12:00:00 2005 Jay Fenlason <fenlason{%}redhat{*}com> 0:3.0.9-1.3E.6

    - Include the -plaintext patch to close
      bz#150004 samba mishandles plaintext passwords
    - Include the -smbmnt patch to close
      bz#160189 CRM 565876: samba-3.0.8pre1-smbmnt.patch to fix smbmount UID
wraparound bug for RHEL3 Samba packages
    - Include the -rpc-parse-64bit-clients patch to close
      bz#166788 CRM 562408: 64-bit windows clients cannot join Samba PDC domain
due to Samba RPC parsing error fixed in 3.0.20
    - Include the (updated for 3.0.9) -excel patch to close
      bz#167920 Samba erroneously changes file date/time when opened by Excel


Comment 7 RHEL Product and Program Management 2007-04-17 17:25:27 EDT
Although this bugzilla was approved for RHEL 4.5, we were unable
to resolve it in time to be included in the release.  Therefore
it is now proposed for RHEL 4.6.
Comment 8 RHEL Product and Program Management 2007-05-09 07:10:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Josef Kubin 2007-08-14 15:50:23 EDT
Created attachment 161305 [details]
Forgotten TMP file

The bug is fixed, but I have encountered strange thing. It sometimes
(MSExcel|Samba) forgets temporary file.
Comment 12 Michael Best 2007-09-29 17:09:22 EDT
Is this still scheduled for inclusion in RHEL 4.6?
Comment 13 Simo Sorce 2007-09-30 12:03:58 EDT
Yes, the bugfix is in status VERIFIED and will be included in 4.6 which will
actually see a rebase of samba to 3.0.25b
Comment 15 errata-xmlrpc 2007-11-15 11:14:14 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0698.html

Note You need to log in before you can comment on or make changes to this bug.