Bug 17207 - Redhat 6.2 fails to install on Althlon machines
Redhat 6.2 fails to install on Althlon machines
Status: CLOSED DUPLICATE of bug 16229
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
: 17334 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-03 14:06 EDT by David Summers
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-11 14:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Summers 2000-09-03 14:06:30 EDT
Hi,

I tried installing Redhat 6.2 on my new Slot A Athlon machine. The
instillation goes well, until finished and you must reboot. On the reboot
the kernel falls over and the machine freezes with the message :-

Disabling CPUID Serial number...general protection fault: 0000
CPU:    0
EIP:    0010:[<c02340f4>]
EFLAGS  00010282

This seems to be caused becuase the install script if flagging the Slot A
Athlon as a i686 machine, and installing the 686 kernel. This kernel seems
to have been compiled with the CPUID option. I guess the code that is run
here works on a PIII, but on an Athlon it just turns over and dies.

This seems to be a problem with the installer - if the Althon was flagged
as a 386 machine I guess it would work. I note I'm not the only person with
this problem, see :-

http://bugs.gnome.org/db/18/18159-b.html

Some auxillery information.

Redhat 6.0 based on the 2.2.5 kernel installs and runs fine.
Upgraded the RPMs to the 6.2 set + errata (including the 2.2.16-3 i386
kernel) also runs fine.
The kernel 2.4.0-test7 compiled for a Athlon also runs fine.

Hope this helps,

David Summers.
Comment 1 David Summers 2000-09-03 14:13:40 EDT
Oops typo in the above. My machine is a Socket A Althlon. The other person noted
above with the same problem was Slot A. The only thing common between his and my
set up is the Athlon processor and Redhat 6.2

David.
Comment 2 Michael Fulbright 2000-09-07 16:41:22 EDT
The installer uses the output from the uname program to determine the
architecture. This is a kernel issue.
Comment 3 Nalin Dahyabhai 2000-09-11 14:52:02 EDT
*** Bug 17334 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2000-09-12 18:55:39 EDT

*** This bug has been marked as a duplicate of 16229 ***

Note You need to log in before you can comment on or make changes to this bug.