Bug 17249 - tcsh core dumps after upgrading glibc
Summary: tcsh core dumps after upgrading glibc
Status: CLOSED DUPLICATE of bug 17187
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcsh   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-05 11:38 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-05 20:24:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-05 11:38:10 UTC
After updating glibc on my 5.2 system from glibc-2.0.7-29 to
glibc-2.0.7-29.2 , the tcsh and csh shell core dumps. I have tried to
rebuild the latest tcsh src rpm, with out any luck.  The
tcsh version is tcsh-6.07.09-1 . I have made the same update on 3 5.2
system with the same result.

Comment 1 Need Real Name 2000-09-05 13:33:02 UTC
Downgrading to glibc-2.0.7-29 temporary solved the problem !

Comment 2 Gilbert E. Detillieux 2000-09-05 19:53:28 UTC
The "man" command similarly core dumps, regardless of command line options
used...

[root@localhost /]# ltrace man --help
atexit(0x40005d10)                                = 0
__libc_init_first(2, 0xbffffe57, 0xbffffe5b, 0, 0xbffffe62) = 0x40005d10
atexit(0x0804e2d0)                                = 0
getenv("LANG")                                    = NULL
getenv("MANPAGER")                                = NULL
getenv("PAGER")                                   = NULL
getenv("SYSTEM")                                  = NULL
getenv("MANROFFSEQ")                              = NULL
getenv("MANSECT")                                 = NULL
getenv("MANPL")                                   = NULL
getenv("MAN_HP_DIREXT")                           = NULL
getenv("LANGUAGE")                                = NULL
getenv("LC_MESSAGES")                             = NULL
setlocale(5, "")                                  = "C"
getenv("MAN_HP_DIREXT")                           = NULL
getenv("MAN_IRIX_CATNAMES")                       = NULL
strrchr("man", '/')                               = NULL
malloc(4)                                         = 0x08055af0
strcpy(0x08055af0, "man")                         = 0x08055af0
getuid()                                          = 0
geteuid()                                         = 0
getgid()                                          = 0
getegid()                                         = 15
getenv("MANWIDTH")                                = NULL
isatty(0)                                         = 1
isatty(1)                                         = 1
ioctl(0, 21523, 0xbffffd5c, 0xbffffe57, 0x0804de96) = 0
getopt_long(2, 0xbffffd9c, "C:M:P:S:acdDfFhkKm:p:tvVwW?", 0x0804e880, NULL) =
104
catopen(0x0804e95c, 0, 13, 0, 2)                  = 0x08055b00
catgets(0x08055b00, 1, 13, 0x0804e983, 0 <unfinished ...>
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

After downgrading glibc (as above), it worked fine.  The call to catgets() does
indeed have a null fourth argument (the message parameter), which apparently
used to be OK.  Perhaps this is the cause of the SEGV, at least in this
instance?  I'm not sure if the tcsh problem is the same, though.

Comment 3 Gilbert E. Detillieux 2000-09-05 20:24:06 UTC
See also bug # 17187 and bug # 17192.

Comment 4 Jeff Johnson 2000-10-06 22:19:09 UTC

*** This bug has been marked as a duplicate of 17187 ***


Note You need to log in before you can comment on or make changes to this bug.