Bug 1726325 - [osp14] Rebase facter to 3.9.3
Summary: [osp14] Rebase facter to 3.9.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: facter
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z4
: 14.0 (Rocky)
Assignee: Martin Magr
QA Contact:
URL:
Whiteboard:
Depends On: 1728382
Blocks: 1731209 1737512 1749885
TreeView+ depends on / blocked
 
Reported: 2019-07-02 15:34 UTC by Alex Schultz
Modified: 2019-11-06 16:53 UTC (History)
2 users (show)

Fixed In Version: boost159-1.59.0-2.el7ost leatherman-1.3.0-9.el7ost cpp-hocon-0.1.6-9.el7ost facter-3.9.3-7.el7ost puppet-4.8.2-3.el7ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1737512 (view as bug list)
Environment:
Last Closed: 2019-11-06 16:53:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1812938 0 None None None 2019-07-24 11:12:12 UTC
RDO 21131 0 None None None 2019-08-05 14:52:24 UTC
RDO 21311 0 None None None 2019-07-24 11:15:06 UTC
RDO 21356 0 None None None 2019-07-05 12:59:54 UTC
Red Hat Product Errata RHBA-2019:3747 0 None None None 2019-11-06 16:53:41 UTC

Description Alex Schultz 2019-07-02 15:34:49 UTC
Description of problem:
We would like to upgrade facter to facter3 to improve performance. See Bug 1711267

Packages have been built upstream https://review.rdoproject.org/r/#/c/21311/. We'll likely need the facter package & and it's dependencies as well as a puppet version bump with a dependency to require ruby-facter.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Alfredo Moralejo 2019-07-05 12:59:55 UTC
New deps and a change in puppet is needed to make it depend on ruby-facter. Change in RDO for Rocky https://review.rdoproject.org/r/#/c/21311/

Comment 2 Alex Schultz 2019-07-08 15:36:57 UTC
We'll need to make sure that we have the fix for https://bugs.launchpad.net/tripleo/+bug/1812938 before updating as well.

Comment 3 Alfredo Moralejo 2019-08-05 15:05:04 UTC
Following changes have been done in RDO Rocky to rebase facter to 3.9.3:

Added as runtime deps:

boost159-1.59.0-2.el7.1
boost-nowide-0-20171026.gitec9672b.el7
cpp-hocon-0.1.6-9.el7
leatherman-1.3.0-9.el7
yaml-cpp-0.5.1-6.el7

Updated packages:

puppet-4.8.2-2.el7
facter-3.9.3-7.el7

Special care needed for boost. Fedora and CentOS/RDO uses versioned name, boost159, etc... while RHEL uses just "boost" so specs man need to be fixed.

Comment 4 Alfredo Moralejo 2019-08-05 15:20:27 UTC
leatherman bundles boost-nowide upstream and it's unblunded in the spec:

https://github.com/rdo-common/leatherman/blob/train-rdo/leatherman.spec#L55

adding boost-nowide may be avoided but removing the unbundling and leaving the one bundled upstream.

Comment 14 errata-xmlrpc 2019-11-06 16:53:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3747


Note You need to log in before you can comment on or make changes to this bug.