Bug 1737512 - [osp13] Rebase facter to 3.9.3
Summary: [osp13] Rebase facter to 3.9.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: facter
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z9
: 13.0 (Queens)
Assignee: Alfredo Moralejo
QA Contact:
URL:
Whiteboard:
: 1749885 (view as bug list)
Depends On: 1726325 1728385 1741161
Blocks: 1731210 1749885
TreeView+ depends on / blocked
 
Reported: 2019-08-05 14:37 UTC by Alex Schultz
Modified: 2019-11-07 14:15 UTC (History)
5 users (show)

Fixed In Version: leatherman-1.3.0-9.el7ost cpp-hocon-0.1.6-9.el7ost facter-3.9.3-7.el7ost
Doc Type: Rebase: Enhancements Only
Doc Text:
This release includes a new version of facter that reduces the time needed to gather information from managed systems. As a result, Red Hat OpenStack Platform deployments are faster in some environments.
Clone Of: 1726325
: 1749885 (view as bug list)
Environment:
Last Closed: 2019-11-07 14:04:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 21371 None master: MERGED rdoinfo: Promote facter-3 to queens-testing repo (I2c0cfd61110665830197dd8c1663453936f7f610) 2019-08-20 16:13:41 UTC
Red Hat Product Errata RHBA-2019:3792 None None None 2019-11-07 14:04:32 UTC

Description Alex Schultz 2019-08-05 14:37:04 UTC
+++ This bug was initially created as a clone of Bug #1726325 +++

Description of problem:
We would like to upgrade facter to facter3 to improve performance. See Bug 1711267

Packages have been built upstream https://review.rdoproject.org/r/#/c/21311/. We'll likely need the facter package & and it's dependencies as well as a puppet version bump with a dependency to require ruby-facter.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Alfredo Moralejo on 2019-07-05 12:59:55 UTC ---

New deps and a change in puppet is needed to make it depend on ruby-facter. Change in RDO for Rocky https://review.rdoproject.org/r/#/c/21311/

--- Additional comment from Alex Schultz on 2019-07-08 15:36:57 UTC ---

We'll need to make sure that we have the fix for https://bugs.launchpad.net/tripleo/+bug/1812938 before updating as well.

Comment 1 Alfredo Moralejo 2019-08-05 15:13:31 UTC
Following changes have been done in RDO Rocky to rebase facter to 3.9.3:

Added as runtime deps:

boost159-1.59.0-2.el7.1
boost-nowide-0-20171026.gitec9672b.el7
cpp-hocon-0.1.6-9.el7
leatherman-1.3.0-9.el7

Updated packages:

puppet-4.8.2-2.el7
facter-3.9.3-7.el7

Special care needed for boost. Fedora and CentOS/RDO uses versioned name, boost159, etc... while RHEL uses just "boost" so specs man need to be fixed.

Comment 2 Alfredo Moralejo 2019-08-19 16:38:02 UTC
Following packages must be pushed together:

boost159-1.59.0-2.el7ost
leatherman-1.3.0-9.el7ost
cpp-hocon-0.1.6-9.el7ost
facter-3.9.3-7.el7ost
puppet-4.8.2-3.el7ost
puppet-tripleo >= 8.4.1-16.el7ost

Note that this update should also be coordinated with OSP14 one in https://bugzilla.redhat.com/show_bug.cgi?id=1726325

Comment 10 Alex Schultz 2019-09-17 21:51:08 UTC
Looks like we also need yaml-cpp-0.5.1-6.el7.x86_64.rpm

Comment 11 Alfredo Moralejo 2019-09-18 07:47:07 UTC
(In reply to Alex Schultz from comment #10)
> Looks like we also need yaml-cpp-0.5.1-6.el7.x86_64.rpm

yaml-cpp-0.5.1-8.el7ost.x86_64.rpm  is already in the OSP13 and 14 repos. I tested the builds with it.

@steve, is there any problem with having a list of packages in fixed in?, iiuc, it should work.

Comment 20 Alex McLeod 2019-10-31 11:29:02 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 21 Steve Linabery 2019-11-04 22:44:44 UTC
*** Bug 1749885 has been marked as a duplicate of this bug. ***

Comment 23 errata-xmlrpc 2019-11-07 14:04:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3792


Note You need to log in before you can comment on or make changes to this bug.