Bug 1726433 - kibana presenting blank page or timeout
Summary: kibana presenting blank page or timeout
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.11.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
: 1722218 (view as bug list)
Depends On: 1644008 1705589 1726434
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-02 20:17 UTC by Jeff Cantrill
Modified: 2019-07-23 19:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The dynamic seeding is inefficient and user's with visibility to a large number of projects exposes this issue by making too many calls to the Elasticsearch cluster. Additionally, there is no caching for user requests causing the seeding process to occur more frequently. Consequence: Calls to Elasticsearch can timeout before a response is returned. Fix: Introduce caching of the API calls and ACL seeding Result: Dynamic seeding is more efficient reducing the opportunity for page timeouts.
Clone Of: 1705589
Environment:
Last Closed: 2019-07-23 19:56:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin-aggregated-logging pull 1650 'None' closed bug 1705589. Consume newer version of plugin to mitigate blank page 2020-02-19 09:09:19 UTC
Red Hat Product Errata RHBA-2019:1753 None None None 2019-07-23 19:56:43 UTC

Comment 2 Jeff Cantrill 2019-07-02 20:31:11 UTC
*** Bug 1722218 has been marked as a duplicate of this bug. ***

Comment 4 Anping Li 2019-07-11 12:08:56 UTC
Couldn't reproduce this issue. Regression pass.  move to verified.  openshift3/ose-logging-kibana5:v3.11.128

Comment 6 errata-xmlrpc 2019-07-23 19:56:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1753


Note You need to log in before you can comment on or make changes to this bug.