Bug 1726434 - kibana presenting blank page or timeout
Summary: kibana presenting blank page or timeout
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On: 1705589
Blocks: 1726433
TreeView+ depends on / blocked
 
Reported: 2019-07-02 20:22 UTC by Jeff Cantrill
Modified: 2019-08-28 19:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The dynamic seeding is inefficient and user's with visibility to a large number of projects exposes this issue by making too many calls to the Elasticsearch cluster. Additionally, there is no caching for user requests causing the seeding process to occur more frequently. Consequence: Calls to Elasticsearch can timeout before a response is returned. Fix: Introduce caching of the API calls and ACL seeding Result: Dynamic seeding is more efficient reducing the opportunity for page timeouts.
Clone Of: 1705589
Environment:
Last Closed: 2019-08-28 19:54:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin-aggregated-logging pull 1684 None None None 2019-07-02 20:24:27 UTC
Red Hat Product Errata RHBA-2019:2547 None None None 2019-08-28 19:54:54 UTC

Comment 2 Anping Li 2019-08-02 09:21:15 UTC
Regression pass on openshift/ose-logging-kibana5:v4.1.9-201907311355

Comment 7 Anping Li 2019-08-16 05:52:23 UTC
Test blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1741753

Comment 8 Anping Li 2019-08-19 06:19:12 UTC
Verified in 4.1.12

Comment 12 Anping Li 2019-08-26 03:44:53 UTC
Regression pass in 4.1.13

Comment 14 errata-xmlrpc 2019-08-28 19:54:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547


Note You need to log in before you can comment on or make changes to this bug.