Bug 173000 - xchat segfaults when started without server list
xchat segfaults when started without server list
Status: CLOSED DUPLICATE of bug 188894
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 173125 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 18:04 EST by Demond James
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 08:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Demond James 2005-11-11 18:04:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

Description of problem:
xchat segfaults unless you start up with the server list shown and if you close the server list box without connecting to a server it segfaults also.  

Version-Release number of selected component (if applicable):
xchat-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1.start xchat
2. select the "Skip server list on startup" box and connect to a server or just close the server list
3. restart xchat
  

Actual Results:  if you closed the server list in step 2 above xchat segfaults.  If you selected "Skip server list on startup" and connected to a server xchat starts but when you tyr to restart it will just segfault.


Expected Results:  If you close the server list on startup xchat should start without connecting to any server

Additional info:
Comment 1 Christopher Aillon 2005-11-14 08:59:58 EST
*** Bug 173125 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Malmgren 2006-02-13 08:49:47 EST
I can confirm the above, using xchat 2.6.0-3.1.

Only way I succeeded to start xchat was by editing ~/.xchat2/xchat.conf manually
and setting the variable gui_slist_skip to 0.
Comment 3 Kevin Kofler 2007-07-10 08:21:19 EDT
Does this still happen in current versions? 2.6.0 is very old.
It definitely doesn't happen for me with any current version (but I'm on i386, 
not x86_64).
Comment 4 Kevin Kofler 2007-07-10 08:34:47 EDT
Actually, this is most likely a duplicate of bug 188894 (see bug 188894 comment 
9, also this is 2.6.0).

*** This bug has been marked as a duplicate of 188894 ***

Note You need to log in before you can comment on or make changes to this bug.