Bug 173027 - libXaw package provides bogus
Summary: libXaw package provides bogus
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 173042 (view as bug list)
Depends On:
Blocks: xorg-modular
TreeView+ depends on / blocked
 
Reported: 2005-11-12 18:29 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-13 01:13:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2005-11-12 18:29:46 UTC
The soname of the libXaw libraries are broken -- they're libXaw.[67] instead of
libXaw.so.[67].  This seems like libtool horkage on generation of the upstream
tarballs as rerunning autogen.sh looks like it fixes things from a quick test.

Comment 1 Mike A. Harris 2005-11-12 21:54:34 UTC
Indeed.

$ rpm -qp --requires xterm-206-3.i386.rpm
/bin/sh
libICE.so.6
libSM.so.6
libX11.so.6
libXaw.7
libXext.so.6
libXmu.so.6
libXt.so.6
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libtermcap.so.2
libutempter.so.0
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1


Comment 2 Mike A. Harris 2005-11-12 21:55:09 UTC
Additional comments from jeremy, sent via email

"The naming of the files is fine, the problem is just with DT_SONAME in
the shared libs.  It is definitely wrong to have a soname without the
shared lib extension.  And it looks like the intent is for it to be
there as -soname libXaw.${sharedext}.6 is passed to ld, just
${sharedext} isn't getting substituted properly."

Comment 3 Mike A. Harris 2005-11-13 01:13:47 UTC
Fixed in libXaw-0.99.2-2 with libXaw-0.99.2-bug-173027-libtool-sucks.patch
and rerunning autoconf.

$ for pkg in
/mnt/redhat/beehive/comps/dist/fc5-test/libXaw/0.99.2-2/{i386,x86_64,ppc,ppc64,s390,s390x,ia64}/libXaw-0.*.rpm
; do (echo -e "\n${pkg##*/}:" ; rpm -qp --provides $pkg ); done

libXaw-0.99.2-2.i386.rpm:
libXaw.so.6
libXaw.so.7
libXaw = 0.99.2-2

libXaw-0.99.2-2.x86_64.rpm:
libXaw.so.6()(64bit)
libXaw.so.7()(64bit)
libXaw = 0.99.2-2

libXaw-0.99.2-2.ppc.rpm:
libXaw.so.6
libXaw.so.7
libXaw = 0.99.2-2

libXaw-0.99.2-2.ppc64.rpm:
libXaw.so.6()(64bit)
libXaw.so.7()(64bit)
libXaw = 0.99.2-2

libXaw-0.99.2-2.s390.rpm:
libXaw.so.6
libXaw.so.7
libXaw = 0.99.2-2

libXaw-0.99.2-2.s390x.rpm:
libXaw.so.6()(64bit)
libXaw.so.7()(64bit)
libXaw = 0.99.2-2

libXaw-0.99.2-2.ia64.rpm:
libXaw.so.6()(64bit)
libXaw.so.7()(64bit)
libXaw = 0.99.2-2


Closing as 'RAWHIDE', although it's in dist-fc5-test not rawhide. ;)

Comment 4 Jeremy Katz 2005-11-13 21:42:36 UTC
*** Bug 173042 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.