Bug 173071 - Obsoletes iiimf-* needed in all scim sub-packages
Obsoletes iiimf-* needed in all scim sub-packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: 171491 FC5Blocker SCIM
  Show dependency treegraph
 
Reported: 2005-11-13 11:19 EST by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 18:12:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2005-11-13 11:19:16 EST
Jeremy says that we need to add Obsoletes for all sub-packages of iiimf into
their corresponding scim packages.  These Obsoletes would be versioned so they
ensure removal of the version shipped in IIIMF, but it would allow installing of
newer versions if they are built and desired by the user.

This is a bit of a mess, because we would need to add Obsoletes for each
corresponding sub-package and they don't exactly match up.  For example:
scim-libs would contain:
Obsoletes: iiimf-libs <= iiimf-12.2

(In this case using the version is probably good enough.)

We need this built in dist-fc5 before test1.
Comment 1 Akira TAGOH 2005-11-14 09:13:57 EST
scim-anthy and scim-hangul has been rebuilt. FYI.
Comment 2 Jens Petersen 2005-11-14 21:11:25 EST
And so have the rest of the scim packages.
Comment 3 Jens Petersen 2006-02-15 22:36:59 EST
*** Bug 181479 has been marked as a duplicate of this bug. ***
Comment 4 Jens Petersen 2006-02-17 02:41:24 EST
The scim, scim-qtimm and scim-tables (move to scim-m17n) packages are missing
the iiimf epoch.
Comment 5 Warren Togami 2006-02-20 18:12:05 EST
NOTE:
Obsoletes of iiimf versions less than or equal to 12.2 epoch 1 have been added
to scim packages.  The purpose of these obsoletes are to ensure a smooth upgrade
transition between supported distributions of Fedora.  This does not prevent
users from using iiimf on our platform, however iiimf packages need to be fixed
in two possible ways in order to be compatible with FC5+.

1. RPM version of iiimf must be higher than 12.2.
2. RPM epoch must be higher than 1.

Fedora promotes choice in software, so our system is engineered to allow
installation and usage of alternative input method frameworks.  In the future Bu
#147579 should be implemented with will provide a graphical chooser for
installed IM frameworks.  Until the graphical chooser is implemented, a simple
framework of alternatives symlinks allows setting of both system-wide and user
IM framework choices.

Note You need to log in before you can comment on or make changes to this bug.