Bug 173268 - Modular X: keyboard map changes in system-config-keyboard and anaconda
Summary: Modular X: keyboard map changes in system-config-keyboard and anaconda
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
: 173600 (view as bug list)
Depends On:
Blocks: xorg-modular
TreeView+ depends on / blocked
 
Reported: 2005-11-15 19:45 UTC by Nicolas Mailhot
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 14:57:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2005-11-15 19:45:29 UTC
Modular X uses new xkbdata wich is significantly different from the one in old xorg

At least the fr-latin9 map changed to latin9 variant of fr map

system-config-keyboard needs to be audited to make sure it can cope with the new
xkbdata

Comment 1 Nicolas Mailhot 2005-11-15 19:49:53 UTC
Moving to rhpl as I guess that's what system-config-keyboard & anaconda use as
keyboard data

Comment 2 Chris Lumens 2005-11-22 16:51:28 UTC
Please test after test1 and see if this works for you.

Comment 3 Nicolas Mailhot 2005-11-22 18:48:36 UTC
Ok, I'll test keyboard in the install phase (won't actually overwrite/update my
install though)

Comment 4 Nicolas Mailhot 2005-12-04 13:49:24 UTC
I can confirm system-config-keyboard works in rawhide now

Loading /lib/kbd/keymaps/i386/azerty/fr-latin9.map.gz
assuming iso-8859-1 cedilla
assuming iso-8859-1 acute
assuming iso-8859-1 diaeresis
assuming iso-8859-1 brokenbar
assuming iso-8859-1 threequarters
assuming iso-8859-1 currency
assuming iso-8859-1 onehalf
assuming iso-8859-1 onequarter

-> should not we use UTF-8 by default now ?

Didn't try anaconda yet (but it's using the same backend right ?)


Comment 5 Chris Lumens 2005-12-05 14:57:06 UTC
Yes, anaconda uses the rhpl code as well so this should be fixed.  Closing based
on comment #4.  If you experience problems in anaconda, feel free to reopen.

Comment 6 Mike A. Harris 2006-02-22 01:53:25 UTC
*** Bug 173600 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.