Bug 173600 - XkbLayout "us_intl" breaks Ctrl-Alt-F1, Compose, ISO_Level3_Shift
XkbLayout "us_intl" breaks Ctrl-Alt-F1, Compose, ISO_Level3_Shift
Status: CLOSED DUPLICATE of bug 173268
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-18 10:54 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 20:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-11-18 10:54:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
Today's rawhide still can't switch to VT1 from the X login screen.  What a pain :-(  Also, Right-Alt, normally mapped to ISO_Level3_Shift or to Compose with my keyboard settings (us-intl), has no such effect, and behaves like Left-Alt.  Dead accents still work, but cedilla can't be generated because of the absence of the compose keys.  setxkbmap says there's an error loading the new keyboard description, but stracing it makes it seem like it's the server that's rejecting the request.

Version-Release number of selected component (if applicable):
xorg-x11-xkb-utils-0.99.1-2

How reproducible:
Always

Steps to Reproduce:
1.Try to switch to VT1 with Ctrl-Alt-F1

Actual Results:  You can't

Expected Results:  Sometimes you really need it

Additional info:
Comment 1 Alexandre Oliva 2005-11-30 07:06:46 EST
FWIW, I found out that it is this line in /etc/X11/xorg.conf that is the culprit:

	Option	    "XkbLayout" "us_intl"

If I change that to plain `us', then Ctrl-Alt-F1 works, but compose keys don't.
 If I log in and then run:

setxkbmap us -symbols 'us(pc105compose)+compose(ralt)+us_intl(basic)'

then compose works and I'm happy, but users can't use compose keys to enter
their login or password, so that would be a problem for a final release.

Any idea of why us_intl would have stopped working, or at least some pointer
about where I can start looking for clues?

Thanks,
Comment 2 Alexandre Oliva 2006-01-05 20:29:55 EST
This is still broken, and not being able to use the keyboard properly nor switch
to the text console before logging in will drive a lot of people away from FC5T2
if it's still broken.

Any suggestions of where to start looking for a solution?
Comment 3 Nicolas Mailhot 2006-01-07 05:34:38 EST
This is actually the same problem than #173267 and #173268

I suggest you test system-config-keyboard to see if it manages to produce a
xorking xorg.conf in your case, and if not reopen #173268
 (marking this one as duplicate)

Note that after you've fixed your xorg.conf you'll probably hit #173267 so you
should also test this one
Comment 4 Alexandre Oliva 2006-01-07 11:01:47 EST
Thanks for the pointers.  The suggestion of using system-config-keyboard in bug
173268 has enabled me to change my long-ago custom-made xorg.conf such that it
works with modular X the way it used to before modular X.

As for bug 173267, I'm not going to run into it because I use us_intl
exclusively, no layout hot switching.

I'll leave this open because there should be some sort of warning somewhere
(Xorg.0.log) indicating that us_intl does not work, as opposed to being AFAICT
silently ignored.
Comment 5 Mike A. Harris 2006-02-21 20:53:18 EST

*** This bug has been marked as a duplicate of 173268 ***

Note You need to log in before you can comment on or make changes to this bug.